summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-03-20 14:25:50 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-03-20 14:25:50 +0000
commit22fb01d820104c31fbc88410d2a8975d38ddc609 (patch)
tree171080445c2468ace29f67c83a3dd76a97a01022 /sys-cluster/liblogthread
parentversion bump (diff)
downloadgentoo-2-22fb01d820104c31fbc88410d2a8975d38ddc609.tar.gz
gentoo-2-22fb01d820104c31fbc88410d2a8975d38ddc609.tar.bz2
gentoo-2-22fb01d820104c31fbc88410d2a8975d38ddc609.zip
version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster/liblogthread')
-rw-r--r--sys-cluster/liblogthread/ChangeLog9
-rw-r--r--sys-cluster/liblogthread/liblogthread-3.2.0.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/sys-cluster/liblogthread/ChangeLog b/sys-cluster/liblogthread/ChangeLog
index 8f67e87a459f..19557b74b518 100644
--- a/sys-cluster/liblogthread/ChangeLog
+++ b/sys-cluster/liblogthread/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/liblogthread
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/liblogthread/ChangeLog,v 1.2 2011/10/18 20:54:23 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/liblogthread/ChangeLog,v 1.3 2013/03/20 14:25:50 ultrabug Exp $
+
+*liblogthread-3.2.0 (20 Mar 2013)
+
+ 20 Mar 2013; Ultrabug <ultrabug@gentoo.org> +liblogthread-3.2.0.ebuild:
+ version bump
18 Oct 2011; Jeroen Roovers <jer@gentoo.org> liblogthread-3.1.5.ebuild:
Marked ~hppa (bug #386951).
diff --git a/sys-cluster/liblogthread/liblogthread-3.2.0.ebuild b/sys-cluster/liblogthread/liblogthread-3.2.0.ebuild
new file mode 100644
index 000000000000..7a8020197cb7
--- /dev/null
+++ b/sys-cluster/liblogthread/liblogthread-3.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/liblogthread/liblogthread-3.2.0.ebuild,v 1.1 2013/03/20 14:25:50 ultrabug Exp $
+
+EAPI=4
+
+inherit linux-info multilib toolchain-funcs versionator
+
+CLUSTER_RELEASE="${PV}"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+MAJ_PV="$(get_major_version)"
+MIN_PV="$(get_version_component_range 2-3)"
+
+DESCRIPTION="Thread-Safe Syslog Logging Library"
+HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
+SRC_URI="https://fedorahosted.org/releases/c/l/cluster/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND=">=sys-kernel/linux-headers-2.6.24"
+
+S="${WORKDIR}/${MY_P}/common/${PN}"
+
+src_configure() {
+ cd "${WORKDIR}/${MY_P}"
+ ./configure \
+ --cc=$(tc-getCC) \
+ --cflags="-Wall" \
+ --libdir=/usr/$(get_libdir) \
+ --disable_kernel_check \
+ --kernel_src=${KERNEL_DIR} \
+ --somajor="$MAJ_PV" \
+ --sominor="$MIN_PV" \
+ --logtlibdir=/usr/$(get_libdir) \
+ --logtincdir=/usr/include \
+ || die "configure problem"
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${D}"/usr/lib*/*.a
+}