summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-05-15 21:48:13 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-05-15 21:48:13 +0000
commit9195b62bbdac241861e4ac638f1261496bc6cac6 (patch)
treec29007ccd08408d92c818bc2c97c23e49380499e /sys-cluster/lam-mpi
parentAdded initgroups support to asterisk, this fixes realtime priority support (-... (diff)
downloadgentoo-2-9195b62bbdac241861e4ac638f1261496bc6cac6.tar.gz
gentoo-2-9195b62bbdac241861e4ac638f1261496bc6cac6.tar.bz2
gentoo-2-9195b62bbdac241861e4ac638f1261496bc6cac6.zip
Fixed BUG #88110. Building liblammpio.so now, too.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-cluster/lam-mpi')
-rw-r--r--sys-cluster/lam-mpi/ChangeLog6
-rw-r--r--sys-cluster/lam-mpi/files/lam-mpi-7.1.1-shared-romio.patch49
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild3
3 files changed, 56 insertions, 2 deletions
diff --git a/sys-cluster/lam-mpi/ChangeLog b/sys-cluster/lam-mpi/ChangeLog
index 630ba1000881..2d1fb6052c5d 100644
--- a/sys-cluster/lam-mpi/ChangeLog
+++ b/sys-cluster/lam-mpi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/lam-mpi
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.30 2005/05/06 19:55:27 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.31 2005/05/15 21:48:13 kugelfang Exp $
+
+ 15 May 2005; Danny van Dyk <kugelfang@gentoo.org>
+ +files/lam-mpi-7.1.1-shared-romio.patch, lam-mpi-7.1.1.ebuild:
+ Fixed BUG #88110. liblammpio will now be built as static and shared library.
06 May 2005; David Holm <dholm@gentoo.org> lam-mpi-7.1.1.ebuild:
Readded to ~ppc. Please don't remove it without filing a proper bug report.
diff --git a/sys-cluster/lam-mpi/files/lam-mpi-7.1.1-shared-romio.patch b/sys-cluster/lam-mpi/files/lam-mpi-7.1.1-shared-romio.patch
new file mode 100644
index 000000000000..344ff13ad94a
--- /dev/null
+++ b/sys-cluster/lam-mpi/files/lam-mpi-7.1.1-shared-romio.patch
@@ -0,0 +1,49 @@
+--- lam-7.1.1/romio/mpi-io/Makefile.in.orig 2005-05-15 23:12:33.317533904 +0200
++++ lam-7.1.1/romio/mpi-io/Makefile.in 2005-05-15 23:15:25.733322720 +0200
+@@ -1,6 +1,9 @@
+ CC = @CC@
+ AR = @AR@
+ LIBNAME = @LIBNAME@
++PICFLAGS = -fPIC -DPIC
++SOFLAGS = -shared
++SONAME = $(basename @LIBNAME@).so
+ RANLIB = @RANLIB@
+ srcdir = @srcdir@
+
+@@ -55,10 +58,14 @@
+
+ all: $(LIBNAME)
+
++dir:
++ mkdir -p shared/
++
+ .SUFFIXES: $(SUFFIXES) .p
+
+ .c.o:
+ $(CC) $(CFLAGS) -c $<
++ $(CC) $(CFLAGS) $(PICFLAGS) -c -o shared/$@ $<
+
+ .c.p:
+ @cp $(srcdir)/$*.c _$*.c
+@@ -69,8 +76,10 @@
+ $(AR) $(LIBNAME) $(MPIO_REAL_POBJECTS)
+ @rm -f _*.o
+
+-$(LIBNAME): $(MPIO_OBJECTS)
++$(LIBNAME): dir $(MPIO_OBJECTS)
+ $(AR) $(LIBNAME) $(MPIO_OBJECTS)
++ $(CC) $(SOFLAGS) -o $(SONAME) $(addprefix shared/, $(MPIO_OBJECTS))
+
+ clean:
+ @rm -f *.o
++ @rm -f shared/*.o
+--- lam-7.1.1/romio/util/romioinstall.in.orig 2005-05-11 20:06:51.526529552 +0200
++++ lam-7.1.1/romio/util/romioinstall.in 2005-05-11 20:07:10.845592608 +0200
+@@ -128,6 +128,7 @@
+ # Library files
+ dir="$libdir"
+ append "$ROMIO_TOP_BUILDDIR/lib/liblammpio.a:$dir/liblammpio.a"
++append "$ROMIO_TOP_BUILDDIR/lib/liblammpio.so:$dir/liblammpio.so"
+
+ # Man pages
+ dir="$mandir/man3"
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild
index 50de67553ef8..51b6ab4789f0 100644
--- a/sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild
+++ b/sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild,v 1.3 2005/05/06 19:55:27 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild,v 1.4 2005/05/15 21:48:13 kugelfang Exp $
inherit fortran
@@ -27,6 +27,7 @@ LICENSE="as-is"
src_unpack() {
unpack ${A}
+ epatch ${FILESDIR}/${P}-shared-romio.patch
cd ${S}/romio/util/
sed -i "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in
}