summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-02-21 08:56:35 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-02-21 08:56:35 +0000
commit64e8a3b2cb23d85905a4996069110db8c123bddb (patch)
treef6693cfcc0611849504428673391e655cb5a1ac0 /sys-cluster/lam-mpi
parentremove old ebuilds (diff)
downloadgentoo-2-64e8a3b2cb23d85905a4996069110db8c123bddb.tar.gz
gentoo-2-64e8a3b2cb23d85905a4996069110db8c123bddb.tar.bz2
gentoo-2-64e8a3b2cb23d85905a4996069110db8c123bddb.zip
Version bump. (#66291) Build Fortran stuff. (#62561) Check for Fortran compiler.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-cluster/lam-mpi')
-rw-r--r--sys-cluster/lam-mpi/ChangeLog9
-rw-r--r--sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.11
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild64
3 files changed, 73 insertions, 1 deletions
diff --git a/sys-cluster/lam-mpi/ChangeLog b/sys-cluster/lam-mpi/ChangeLog
index f46897f1bec8..751a5679f18f 100644
--- a/sys-cluster/lam-mpi/ChangeLog
+++ b/sys-cluster/lam-mpi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/lam-mpi
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.27 2005/02/07 12:01:47 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.28 2005/02/21 08:56:35 spyderous Exp $
+
+*lam-mpi-7.1.1 (21 Feb 2005)
+
+ 21 Feb 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +lam-mpi-7.1.1.ebuild:
+ Version bump. (#66291) Build Fortran stuff. (#62561) Check for Fortran
+ compiler.
07 Feb 2005; Jeremy Huddleston <eradicator@gentoo.org> lam-mpi-7.1.ebuild:
Adding ~amd64 as it was mistakenly removed.
diff --git a/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.1 b/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.1
new file mode 100644
index 000000000000..280f97bd3d73
--- /dev/null
+++ b/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.1
@@ -0,0 +1 @@
+MD5 0a3eee53281884a063ce2c44793672b3 lam-7.1.1.tar.bz2 7589413
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild
new file mode 100644
index 000000000000..a68228ff0687
--- /dev/null
+++ b/sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.1.ebuild,v 1.1 2005/02/21 08:56:35 spyderous Exp $
+
+inherit fortran
+
+IUSE="crypt"
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="the LAM MPI parallel computing environment"
+SRC_URI="http://www.lam-mpi.org/download/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.lam-mpi.org"
+
+DEPEND="virtual/libc"
+# we need ssh if we want to use it instead of rsh
+RDEPEND="${DEPEND}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )
+ !sys-cluster/mpich"
+
+SLOT="6"
+KEYWORDS="~amd64 ~x86 ~sparc"
+LICENSE="as-is"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/romio/util/
+ sed -i "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in
+}
+
+src_compile() {
+
+ local myconf
+
+ if use crypt; then
+ myconf="${myconf} --with-rsh=ssh"
+ else
+ myconf="${myconf} --with-rsh=rsh"
+ fi
+
+ econf \
+ --sysconfdir=/etc/lam-mpi \
+ --enable-shared \
+ --with-threads=posix \
+ ${myconf} || die
+
+ # sometimes parallel doesn't finish since it gets ahead of itself :)
+
+ emake -j1 || die
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die
+
+ # There are a bunch more tex docs we could make and install too,
+ # but they might be replicated in the pdf.
+ dodoc README HISTORY LICENSE VERSION
+ cd ${S}/doc
+ dodoc {user,install}.pdf
+}