summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-07-20 06:19:07 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-07-20 06:19:07 +0000
commit54efe30d242cfbb1517561e1a0baee0619d99b1b (patch)
tree57cd4a603aed6abd0d034a704d140f010066cce1 /sys-cluster/lam-mpi
parentremove emacs from IUSE #140847 (diff)
downloadgentoo-2-54efe30d242cfbb1517561e1a0baee0619d99b1b.tar.gz
gentoo-2-54efe30d242cfbb1517561e1a0baee0619d99b1b.tar.bz2
gentoo-2-54efe30d242cfbb1517561e1a0baee0619d99b1b.zip
(#140725) Bump (Eric Thibodeau). (#135168) Add gcc-4 fix. (#136071) rsh should boot now.
(Portage version: 2.1.1_pre3)
Diffstat (limited to 'sys-cluster/lam-mpi')
-rw-r--r--sys-cluster/lam-mpi/ChangeLog11
-rw-r--r--sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.23
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.1.2.ebuild97
3 files changed, 109 insertions, 2 deletions
diff --git a/sys-cluster/lam-mpi/ChangeLog b/sys-cluster/lam-mpi/ChangeLog
index d723ca6b1663..a97d26430610 100644
--- a/sys-cluster/lam-mpi/ChangeLog
+++ b/sys-cluster/lam-mpi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/lam-mpi
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.42 2005/10/03 20:03:44 xmerlin Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.43 2006/07/20 06:19:07 dberkholz Exp $
+
+*lam-mpi-7.1.2 (20 Jul 2006)
+
+ 20 Jul 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +lam-mpi-7.1.2.ebuild:
+ (#140725) Bump (Eric Thibodeau). (#135168) Add gcc-4 fix. (#136071) rsh
+ should boot now.
03 Oct 2005; Christian Zoffoli <xmerlin@gentoo.org> lam-mpi-7.1.1-r3.ebuild:
fixed bug #106443.
diff --git a/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.2 b/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.2
new file mode 100644
index 000000000000..7e6fcf27f30f
--- /dev/null
+++ b/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.2
@@ -0,0 +1,3 @@
+MD5 07c59cf03c773a67199e066e500e499b lam-7.1.2.tar.bz2 7851483
+RMD160 4aeb62d41dc0b6f910424feb1046c6925bd620c4 lam-7.1.2.tar.bz2 7851483
+SHA256 b3826e79f1a674ed275d2a0e32895aefe63d4278126bd5fa01dbe43cc1c1960b lam-7.1.2.tar.bz2 7851483
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.1.2.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.1.2.ebuild
new file mode 100644
index 000000000000..67180cff3ad1
--- /dev/null
+++ b/sys-cluster/lam-mpi/lam-mpi-7.1.2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.2.ebuild,v 1.1 2006/07/20 06:19:07 dberkholz Exp $
+
+inherit autotools eutils fortran flag-o-matic portability
+
+# LAM is a PITA with PBS. If it's detected, there is NO way to turn it off!
+# Likewise for the other SSI boot modules (globus/slurm/tm are affected)
+IUSE="crypt pbs fortran"
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="the LAM MPI parallel computing environment"
+SRC_URI="http://www.lam-mpi.org/download/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.lam-mpi.org"
+PROVIDE="virtual/mpi"
+DEPEND="virtual/libc
+ pbs? ( virtual/pbs )
+ !virtual/mpi"
+# we need ssh if we want to use it instead of rsh
+RDEPEND="${DEPEND}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )"
+
+SLOT="6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="as-is"
+# confcache breaks the make process
+RESTRICT="confcache"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/romio/util/
+ sed -i "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in
+
+ for i in ${S}/share/memory/{ptmalloc,ptmalloc2,darwin7}/Makefile.in; do
+ sed -i -e 's@^\(docdir = \)\$(datadir)/lam/doc@\1'/usr/share/doc/${PF}'@' ${i}
+ done
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-lam_prog_f77.m4.patch
+ eautoreconf
+}
+
+pkg_setup() {
+ : # make sure fortran_pkg_setup does NOT run
+}
+
+src_compile() {
+
+ local myconf
+
+ if use crypt; then
+ myconf="${myconf} --with-rsh=ssh"
+ else
+ myconf="${myconf} --with-rsh=rsh"
+ fi
+
+ use pbs && append-ldflags -L/usr/lib/pbs
+
+ if use fortran; then
+ fortran_pkg_setup
+ # this is NOT in pkg_setup as it is NOT needed for RDEPEND right away it
+ # can be installed after merging from binary, and still have things fine
+ myconf="${myconf} --with-fc=${FORTRANC}"
+ else
+ myconf="${myconf} --without-fc"
+ fi
+
+ econf \
+ --sysconfdir=/etc/lam-mpi \
+ --enable-shared \
+ --with-threads=posix \
+ ${myconf} || die
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die
+
+ # There are a bunch more tex docs we could make and install too,
+ # but they might be replicated in the pdf.
+ # They are replicated in the pdfs! Thus remove this comment?
+ dodoc README HISTORY LICENSE VERSION
+ cd ${S}/doc
+ dodoc {user,install}.pdf
+
+ # install examples
+ cd ${S}/examples
+ mkdir -p ${D}/usr/share/${P}/examples
+ find -name README -or -iregex '.*\.[chf][c]?$' >${T}/testlist
+ while read p; do
+ treecopy $p ${D}/usr/share/${P}/examples ;
+ done < ${T}/testlist
+}