summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2005-01-21 18:14:37 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2005-01-21 18:14:37 +0000
commit7b10f16e78a04dbb668a9a10ab28f7be2d317479 (patch)
treefd139ba002a0d3d5a6a6cb910f68c99bd78c251d /sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
parentPull in all CVS changes from 0.8.10_rc5 to now. Includes several bugfixes (lo... (diff)
downloadgentoo-2-7b10f16e78a04dbb668a9a10ab28f7be2d317479.tar.gz
gentoo-2-7b10f16e78a04dbb668a9a10ab28f7be2d317479.tar.bz2
gentoo-2-7b10f16e78a04dbb668a9a10ab28f7be2d317479.zip
updated copyright, added additional checks on kernel version (1.21 works only on kernel 2.4.x)
Diffstat (limited to 'sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild')
-rw-r--r--sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild32
1 files changed, 19 insertions, 13 deletions
diff --git a/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild b/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
index 4e83b6393493..d58d48089c61 100644
--- a/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
+++ b/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild,v 1.7 2004/09/03 15:21:28 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild,v 1.8 2005/01/21 18:14:37 xmerlin Exp $
+inherit check-kernel
DESCRIPTION="ipvsadm is a utility to administer the IP virtual server services offered by the Linux kernel with IP virtual server support."
HOMEPAGE="http://linuxvirtualserver.org"
LICENSE="GPL-2"
DEPEND="virtual/libc
+ virtual/linux-sources
>=sys-libs/ncurses-5.2"
SRC_URI="http://www.linuxvirtualserver.org/software/kernel-2.4/${P}.tar.gz"
@@ -15,23 +17,27 @@ SLOT="0"
KEYWORDS="x86 ~ppc"
IUSE=""
+pkg_setup() {
+ if is_2_5_kernel || is_2_6_kernel
+ then
+ die "${P} does not support 2.5 and 2.6 kernels, please try ${PN}-1.24"
+ fi
+}
+
+
src_compile() {
- cd "${S}"
- make || die
+ check_KV
+ make || die "error compiling source"
}
src_install() {
into /
- dosbin ipvsadm
- dosbin ipvsadm-save
- dosbin ipvsadm-restore
+ dosbin ipvsadm ipvsadm-save ipvsadm-restore || die
- doman ipvsadm.8
- doman ipvsadm-save.8
- doman ipvsadm-restore.8
+ doman ipvsadm.8 ipvsadm-save.8 ipvsadm-restore.8
exeinto /etc/init.d
- newexe ${FILESDIR}/ipvsadm-init ipvsadm
+ newexe ${FILESDIR}/ipvsadm-init ipvsadm || die
keepdir /var/lib/ipvsadm
diropts -m 755 -o root -g root
@@ -40,10 +46,10 @@ src_install() {
insopts -m 644 -o root -g root
insinto /usr/lib
- doins libipvs/libipvs.a
+ doins libipvs/libipvs.a || die
insinto /usr/include/ipvs
- newins libipvs/libipvs.h ipvs.h
+ newins libipvs/libipvs.h ipvs.h || die
einfo "You will need a kernel that has ipvs patches to use LVS"
}