summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-22 00:31:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-22 00:31:33 +0000
commit9a073157bd0acb447eb461b253b182f3f1edbbab (patch)
tree09f88ab5d2747e0aa76985695eb343844bdbd257 /sys-cluster/gearmand
parentDrop DEPRECATED flags, bug #388019 (diff)
downloadgentoo-2-9a073157bd0acb447eb461b253b182f3f1edbbab.tar.gz
gentoo-2-9a073157bd0acb447eb461b253b182f3f1edbbab.tar.bz2
gentoo-2-9a073157bd0acb447eb461b253b182f3f1edbbab.zip
Version bump, thanks to Pavel.
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/gearmand')
-rw-r--r--sys-cluster/gearmand/ChangeLog9
-rw-r--r--sys-cluster/gearmand/gearmand-0.24.ebuild92
2 files changed, 99 insertions, 2 deletions
diff --git a/sys-cluster/gearmand/ChangeLog b/sys-cluster/gearmand/ChangeLog
index a30330d2dedd..2c6f2a50d3a9 100644
--- a/sys-cluster/gearmand/ChangeLog
+++ b/sys-cluster/gearmand/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/gearmand
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.10 2010/10/15 14:59:29 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.11 2011/10/22 00:31:33 flameeyes Exp $
+
+*gearmand-0.24 (22 Oct 2011)
+
+ 22 Oct 2011; Diego E. Pettenò <flameeyes@gentoo.org> +gearmand-0.24.ebuild:
+ Version bump, thanks to Pavel.
15 Oct 2010; Diego E. Pettenò <flameeyes@gentoo.org>
gearmand-0.12.ebuild, gearmand-0.14.ebuild:
diff --git a/sys-cluster/gearmand/gearmand-0.24.ebuild b/sys-cluster/gearmand/gearmand-0.24.ebuild
new file mode 100644
index 000000000000..d3276ca25015
--- /dev/null
+++ b/sys-cluster/gearmand/gearmand-0.24.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.24.ebuild,v 1.1 2011/10/22 00:31:33 flameeyes Exp $
+
+EAPI=2
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="Generic framework to farm out work to other machines"
+HOMEPAGE="http://www.gearman.org/"
+SRC_URI="http://launchpad.net/gearmand/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tcmalloc +memcache drizzle sqlite tokyocabinet postgres"
+
+RESTRICT="test"
+# restricting tests because of failures, package runs fine
+
+RDEPEND="dev-libs/libevent
+ || ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
+ tcmalloc? ( dev-util/google-perftools )
+ memcache? ( >=dev-libs/libmemcached-0.47 )
+ drizzle? ( dev-db/drizzle )
+ sqlite? ( dev-db/sqlite:3 )
+ tokyocabinet? ( dev-db/tokyocabinet )
+ postgres? ( dev-db/postgresql-base:9.0 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewuser gearmand -1 -1 /dev/null nogroup
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # Don't ever use --enable-assert since configure.ac is broken, and
+ # only does --disable-assert correctly.
+ if use debug; then
+ # Since --with-debug would turn off optimisations as well as
+ # enabling debug, we just enable debug through the
+ # preprocessor then.
+ append-flags -DDEBUG
+ else
+ myconf="${myconf} --disable-assert"
+ fi
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --disable-mtmalloc \
+ $(use_enable tcmalloc) \
+ $(use_enable memcache libmemcached) \
+ $(use_enable drizzle libdrizzle) \
+ $(use_enable sqlite libsqlite3) \
+ $(use_enable tokyocabinet libtokyocabinet) \
+ $(use_enable postgres libpq)
+}
+
+src_test() {
+ # Since libtool is stupid and doesn't discard /usr/lib64 from the
+ # load path, we'd end up testing against the installed copy of
+ # gearmand (bad).
+ #
+ # We thus cheat and "fix" the scripts by hand.
+ sed -i -e '/LD_LIBRARY_PATH=/s|/usr/lib64:||' "${S}"/tests/*_test \
+ || die "test fixing failed"
+
+ emake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc README AUTHORS ChangeLog || die "dodoc failed"
+
+ newinitd "${FILESDIR}"/gearmand.init.d gearmand || die
+ newconfd "${FILESDIR}"/gearmand.conf.d gearmand || die
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog ""
+ elog "Unless you set the PERSISTENT_TABLE option in"
+ elog "/etc/conf.d/gearmand, Gearmand will use table 'queue'."
+ elog "If such table doesn't exist, Gearmand will create it for you"
+ elog ""
+}