summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2009-09-30 14:00:20 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2009-09-30 14:00:20 +0000
commit78057481e0a253caab0595471af4c5f05a10502a (patch)
treedfee3fae54caaff488c4dc860500cec2714bf044 /sys-cluster/drbd/files
parentAdd patch for fcgi issue per bug #286902. Thx to Kacper Kowalik for the patch. (diff)
downloadgentoo-2-78057481e0a253caab0595471af4c5f05a10502a.tar.gz
gentoo-2-78057481e0a253caab0595471af4c5f05a10502a.tar.bz2
gentoo-2-78057481e0a253caab0595471af4c5f05a10502a.zip
Fixed compilation on newer kernels.
(Portage version: 2.1.4.5)
Diffstat (limited to 'sys-cluster/drbd/files')
-rw-r--r--sys-cluster/drbd/files/drbd-8.3.2-bitsperlong.h.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-cluster/drbd/files/drbd-8.3.2-bitsperlong.h.patch b/sys-cluster/drbd/files/drbd-8.3.2-bitsperlong.h.patch
new file mode 100644
index 000000000000..1a17b9b0f014
--- /dev/null
+++ b/sys-cluster/drbd/files/drbd-8.3.2-bitsperlong.h.patch
@@ -0,0 +1,35 @@
+From: Lars Ellenberg <lars.ellenberg@linbit.com>
+Date: Mon, 14 Sep 2009 11:33:26 +0000 (+0200)
+Subject: compat: remove special -I$(KDIR)/include for drbdsetup
+X-Git-Url: http://git.drbd.org/?p=drbd-8.3.git;a=commitdiff_plain;h=a6e36c389adb4485313191fd50405395fa3c1a74
+
+compat: remove special -I$(KDIR)/include for drbdsetup
+
+Finally get rid of that special case hack.
+---
+
+diff --git a/user/Makefile b/user/Makefile
+index 04cdcae..0143e09 100644
+--- a/user/Makefile
++++ b/user/Makefile
+@@ -22,8 +22,6 @@ KDIR := /lib/modules/$(shell uname -r)/build
+ CC = gcc
+ OPTFLAGS = -O1
+ CFLAGS = $(OPTFLAGS) -c -W -Wall -I../drbd
+-# for the netlink connector stuff <linux/connector.h>:
+-drbdsetup: CFLAGS += -I$(KDIR)/include
+
+ drbdadm-obj = drbdadm_scanner.o drbdadm_parser.o drbdadm_main.o \
+ drbdadm_adjust.o drbdtool_common.o drbdadm_usage_cnt.o \
+diff --git a/user/drbdsetup.c b/user/drbdsetup.c
+index 4c3d132..d3b353d 100644
+--- a/user/drbdsetup.c
++++ b/user/drbdsetup.c
+@@ -46,6 +46,7 @@
+ #include <time.h>
+
+ #define __bitwise /* Build-workaround for broken RHEL4 kernels (2.6.9_78.0.1) */
++#include <linux/types.h>
+ #include <linux/netlink.h>
+ #include <linux/connector.h>
+