summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2006-06-04 13:23:50 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2006-06-04 13:23:50 +0000
commit9f62dcc4f947387f3eb0625c7905f3ec7db2c772 (patch)
treed43d8fba457278869a5f5151de30e0bf9b5451c8 /sys-cluster/csync2/csync2-1.32.ebuild
parentFix bug #133871. (diff)
downloadgentoo-2-9f62dcc4f947387f3eb0625c7905f3ec7db2c772.tar.gz
gentoo-2-9f62dcc4f947387f3eb0625c7905f3ec7db2c772.tar.bz2
gentoo-2-9f62dcc4f947387f3eb0625c7905f3ec7db2c772.zip
Conf. moved to /etc/csync2 .
(Portage version: 2203-svn)
Diffstat (limited to 'sys-cluster/csync2/csync2-1.32.ebuild')
-rw-r--r--sys-cluster/csync2/csync2-1.32.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-cluster/csync2/csync2-1.32.ebuild b/sys-cluster/csync2/csync2-1.32.ebuild
index d2eb42ce703c..6fe792d773a7 100644
--- a/sys-cluster/csync2/csync2-1.32.ebuild
+++ b/sys-cluster/csync2/csync2-1.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-1.32.ebuild,v 1.3 2006/06/04 13:17:28 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-1.32.ebuild,v 1.4 2006/06/04 13:23:50 xmerlin Exp $
DESCRIPTION="Cluster synchronization tool."
SRC_URI="http://oss.linbit.com/csync2/${P}.tar.gz"
@@ -33,7 +33,10 @@ src_compile() {
src_install() {
- make DESTDIR=${D} localstatedir=${D}/var install || die "install problem"
+ make DESTDIR=${D} \
+ localstatedir=${D}/var \
+ sysconfdir=${D}/etc/csync2 \
+ install || die "install problem"
insinto /etc/xinetd.d
newins ${FILESDIR}/${PN}.xinetd ${PN} || die
@@ -63,7 +66,7 @@ pkg_config() {
} > /etc/services.new
mv -f /etc/services.new /etc/services
- if [ ! -f /etc/${PN}/csync2_ssl_key.pem ]; then
+ #if [ ! -f /etc/${PN}/csync2_ssl_key.pem ]; then
einfo "Creating default certificate in /etc/${PN}"
openssl genrsa -out /etc/${PN}/csync2_ssl_key.pem 1024 &> /dev/null
@@ -81,5 +84,5 @@ pkg_config() {
&> /dev/null
rm /etc/${PN}/csync2_ssl_cert.csr
- fi
+ #fi
}