summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-07-17 15:31:11 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-07-17 15:31:11 +0000
commit833db4fe71219692ef9eeb4f991204d2aec668ba (patch)
tree7a7a349d4916137b1a71f93670a635fd3bd11662 /sys-cluster/corosync
parentversion bump (diff)
downloadgentoo-2-833db4fe71219692ef9eeb4f991204d2aec668ba.tar.gz
gentoo-2-833db4fe71219692ef9eeb4f991204d2aec668ba.tar.bz2
gentoo-2-833db4fe71219692ef9eeb4f991204d2aec668ba.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/corosync')
-rw-r--r--sys-cluster/corosync/ChangeLog7
-rw-r--r--sys-cluster/corosync/corosync-1.2.6.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-cluster/corosync/ChangeLog b/sys-cluster/corosync/ChangeLog
index b83d0584a9a2..2c6125973fc9 100644
--- a/sys-cluster/corosync/ChangeLog
+++ b/sys-cluster/corosync/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/corosync
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.5 2010/06/29 08:33:51 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.6 2010/07/17 15:31:11 cardoe Exp $
+
+*corosync-1.2.6 (17 Jul 2010)
+
+ 17 Jul 2010; Doug Goldstein <cardoe@gentoo.org> +corosync-1.2.6.ebuild:
+ version bump
29 Jun 2010; Guy Martin <gmsoft@gentoo.org> corosync-1.2.5.ebuild:
Added ~hppa to KEYWORDS.
diff --git a/sys-cluster/corosync/corosync-1.2.6.ebuild b/sys-cluster/corosync/corosync-1.2.6.ebuild
new file mode 100644
index 000000000000..135461e19511
--- /dev/null
+++ b/sys-cluster/corosync/corosync-1.2.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-1.2.6.ebuild,v 1.1 2010/07/17 15:31:11 cardoe Exp $
+
+EAPI="3"
+
+inherit base autotools
+
+DESCRIPTION="OSI Certified implementation of a complete cluster engine"
+HOMEPAGE="http://www.corosync.org/"
+SRC_URI="ftp://ftp:${PN}.org@${PN}.org/downloads/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc infiniband ssl"
+
+RDEPEND="!sys-cluster/heartbeat
+ ssl? ( dev-libs/nss )
+ infiniband? (
+ sys-infiniband/libibverbs
+ sys-infiniband/librdmacm
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( sys-apps/groff )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-ldflags.patch"
+ "${FILESDIR}/${PN}-docs.patch"
+)
+
+DOCS=( "README.recovery" "README.devmap" "SECURITY" "TODO" "AUTHORS" )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ # appends lib to localstatedir automatically
+ # FIXME: install both static and shared libs
+ econf \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable ssl nss) \
+ $(use_enable infiniband rdma)
+}
+
+src_install() {
+ base_src_install
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+
+ keepdir /var/lib/corosync
+}