summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-12 05:25:33 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-12 05:25:33 +0000
commit0d67163d1d18e52f190954aef408ba344ae774c1 (patch)
tree05ae83eaad6809f1ced602a9f588232f776a27b9 /sys-cluster/cinder
parentupdate to distutils-r1 (diff)
downloadgentoo-2-0d67163d1d18e52f190954aef408ba344ae774c1.tar.gz
gentoo-2-0d67163d1d18e52f190954aef408ba344ae774c1.tar.bz2
gentoo-2-0d67163d1d18e52f190954aef408ba344ae774c1.zip
full distutils-r1 support
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster/cinder')
-rw-r--r--sys-cluster/cinder/ChangeLog11
-rw-r--r--sys-cluster/cinder/cinder-2012.2.4-r3.ebuild (renamed from sys-cluster/cinder/cinder-2012.2.4-r2.ebuild)21
-rw-r--r--sys-cluster/cinder/cinder-2013.1.3-r2.ebuild (renamed from sys-cluster/cinder/cinder-2013.1.3-r1.ebuild)19
-rw-r--r--sys-cluster/cinder/cinder-2013.1.9999.ebuild19
-rw-r--r--sys-cluster/cinder/cinder-9999.ebuild19
5 files changed, 59 insertions, 30 deletions
diff --git a/sys-cluster/cinder/ChangeLog b/sys-cluster/cinder/ChangeLog
index b1364bdb7f99..1d384a794bc6 100644
--- a/sys-cluster/cinder/ChangeLog
+++ b/sys-cluster/cinder/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-cluster/cinder
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/ChangeLog,v 1.17 2013/09/10 05:07:29 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/ChangeLog,v 1.18 2013/09/12 05:25:33 prometheanfire Exp $
+
+*cinder-2012.2.4-r3 (12 Sep 2013)
+*cinder-2013.1.3-r2 (12 Sep 2013)
+
+ 12 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +cinder-2012.2.4-r3.ebuild, +cinder-2013.1.3-r2.ebuild,
+ -cinder-2012.2.4-r2.ebuild, -cinder-2013.1.3-r1.ebuild,
+ cinder-2013.1.9999.ebuild, cinder-9999.ebuild:
+ full distutils-r1 support
10 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
cinder-2012.2.4-r2.ebuild:
diff --git a/sys-cluster/cinder/cinder-2012.2.4-r2.ebuild b/sys-cluster/cinder/cinder-2012.2.4-r3.ebuild
index 867c60f17ffd..588e83acb96c 100644
--- a/sys-cluster/cinder/cinder-2012.2.4-r2.ebuild
+++ b/sys-cluster/cinder/cinder-2012.2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2012.2.4-r2.ebuild,v 1.2 2013/09/10 05:07:29 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2012.2.4-r3.ebuild,v 1.1 2013/09/12 05:25:33 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -15,7 +15,8 @@ SRC_URI="http://launchpad.net/${PN}/folsom/${PV}/+download/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+api +scheduler +volume"
+IUSE="+api +scheduler +volume ldap mysql postgres sqlite"
+REQUIRED_USE="|| ( ldap mysql postgres sqlite )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
app-admin/sudo"
@@ -24,18 +25,22 @@ RDEPEND="~dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
>=dev-python/anyjson-0.2.4[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
~dev-python/kombu-1.0.4[${PYTHON_USEDEP}]
- ~dev-python/lockfile-0.8
+ ~dev-python/lockfile-0.8[${PYTHON_USEDEP}]
>=dev-python/lxml-2.3[${PYTHON_USEDEP}]
~dev-python/routes-1.12.3[${PYTHON_USEDEP}]
>=dev-python/webob-1.0.8[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
~dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-0.7.3
- <=dev-python/sqlalchemy-0.7.9
- >=dev-python/sqlalchemy-migrate-0.7.2
- >=dev-python/stevedore-0.8
- ~dev-python/suds-0.4
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.8[${PYTHON_USEDEP}]
+ ~dev-python/suds-0.4[${PYTHON_USEDEP}]
dev-python/paramiko[${PYTHON_USEDEP}]
>=dev-python/Babel-0.9.6[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-2013.1.3-r1.ebuild b/sys-cluster/cinder/cinder-2013.1.3-r2.ebuild
index a44fb5053d1c..06661781b592 100644
--- a/sys-cluster/cinder/cinder-2013.1.3-r1.ebuild
+++ b/sys-cluster/cinder/cinder-2013.1.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2013.1.3-r1.ebuild,v 1.1 2013/09/05 19:41:28 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2013.1.3-r2.ebuild,v 1.1 2013/09/12 05:25:33 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -15,7 +15,8 @@ SRC_URI="http://launchpad.net/${PN}/grizzly/${PV}/+download/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+api +scheduler +volume"
+IUSE="+api +scheduler +volume ldap mysql postgres sqlite"
+REQUIRED_USE="|| ( ldap mysql postgres sqlite )"
#sudo is a build dep because I want the sudoers.d directory to exist, lazy.
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
@@ -32,11 +33,15 @@ RDEPEND="~dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-0.7.3
- <=dev-python/sqlalchemy-0.7.9
- >=dev-python/sqlalchemy-migrate-0.7.2
- >=dev-python/stevedore-0.8
- >=dev-python/suds-0.4
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.8[${PYTHON_USEDEP}]
+ >=dev-python/suds-0.4[${PYTHON_USEDEP}]
dev-python/paramiko[${PYTHON_USEDEP}]
>=dev-python/Babel-0.9.6[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-2013.1.9999.ebuild b/sys-cluster/cinder/cinder-2013.1.9999.ebuild
index 1ed379449546..1edfccb33e44 100644
--- a/sys-cluster/cinder/cinder-2013.1.9999.ebuild
+++ b/sys-cluster/cinder/cinder-2013.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2013.1.9999.ebuild,v 1.3 2013/09/05 19:41:28 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2013.1.9999.ebuild,v 1.4 2013/09/12 05:25:33 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -16,7 +16,8 @@ EGIT_BRANCH="stable/grizzly"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="+api +scheduler +volume"
+IUSE="+api +scheduler +volume ldap mysql postgres sqlite"
+REQUIRED_USE="|| ( ldap mysql postgres sqlite )"
#sudo is a build dep because I want the sudoers.d directory to exist, lazy.
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
@@ -33,11 +34,15 @@ RDEPEND="=dev-python/amqplib-0.6.1-r1[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-0.7.3
- <=dev-python/sqlalchemy-0.7.9
- >=dev-python/sqlalchemy-migrate-0.7.2
- >=dev-python/stevedore-0.8
- >=dev-python/suds-0.4
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.8[${PYTHON_USEDEP}]
+ >=dev-python/suds-0.4[${PYTHON_USEDEP}]
dev-python/paramiko[${PYTHON_USEDEP}]
>=dev-python/Babel-0.9.6[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-9999.ebuild b/sys-cluster/cinder/cinder-9999.ebuild
index 0c9f6a80e864..18c4d97fef0d 100644
--- a/sys-cluster/cinder/cinder-9999.ebuild
+++ b/sys-cluster/cinder/cinder-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-9999.ebuild,v 1.2 2013/09/05 19:41:28 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-9999.ebuild,v 1.3 2013/09/12 05:25:33 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -15,7 +15,8 @@ EGIT_REPO_URI="https://github.com/openstack/cinder.git"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="+api +scheduler +volume"
+IUSE="+api +scheduler +volume ldap mysql postgres sqlite"
+REQUIRED_USE="|| ( ldap mysql postgres sqlite )"
#sudo is a build dep because I want the sudoers.d directory to exist, lazy.
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
@@ -37,11 +38,15 @@ RDEPEND=">=dev-python/amqplib-0.6.1-r1[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-0.7.8
- <=dev-python/sqlalchemy-0.7.99
- >=dev-python/sqlalchemy-migrate-0.7.2
- >=dev-python/stevedore-0.10
- >=dev-python/suds-0.4
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.10[${PYTHON_USEDEP}]
+ >=dev-python/suds-0.4[${PYTHON_USEDEP}]
>=dev-python/paramiko-1.8.0[${PYTHON_USEDEP}]
>=dev-python/Babel-0.9.6[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]