summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-04-17 23:51:20 +0000
committerYixun Lan <dlan@gentoo.org>2014-04-17 23:51:20 +0000
commit851e894b531ca4133be4afb9ac955103c1366056 (patch)
treea6d9a84913a9ed4bd623a34825c10f8dad6e7c8b /sys-cluster/ceph
parentDisable fatal linker warnings, bug 506268 by Vasco Gervasi. (diff)
downloadgentoo-2-851e894b531ca4133be4afb9ac955103c1366056.tar.gz
gentoo-2-851e894b531ca4133be4afb9ac955103c1366056.tar.bz2
gentoo-2-851e894b531ca4133be4afb9ac955103c1366056.zip
bump 0.79, fix libxfs dep, bug #507924, thanks @LeeL
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ChangeLog9
-rw-r--r--sys-cluster/ceph/ceph-0.78.ebuild141
-rw-r--r--sys-cluster/ceph/ceph-0.79.ebuild (renamed from sys-cluster/ceph/ceph-0.77.ebuild)20
-rw-r--r--sys-cluster/ceph/ceph-9999.ebuild25
-rw-r--r--sys-cluster/ceph/files/ceph-0.79-libzfs.patch13
-rw-r--r--sys-cluster/ceph/metadata.xml2
6 files changed, 52 insertions, 158 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index c434341cfa31..1cfe90b81c5a 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.48 2014/03/29 22:43:59 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.49 2014/04/17 23:51:20 dlan Exp $
+
+*ceph-0.79 (17 Apr 2014)
+
+ 17 Apr 2014; Yixun Lan <dlan@gentoo.org> -ceph-0.77.ebuild,
+ -ceph-0.78.ebuild, +ceph-0.79.ebuild, ceph-9999.ebuild,
+ +files/ceph-0.79-libzfs.patch, metadata.xml:
+ bump 0.79, fix libxfs dep, bug #507924, thanks @LeeL
*ceph-0.78 (29 Mar 2014)
diff --git a/sys-cluster/ceph/ceph-0.78.ebuild b/sys-cluster/ceph/ceph-0.78.ebuild
deleted file mode 100644
index 5e7d5161268a..000000000000
--- a/sys-cluster/ceph/ceph-0.78.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.78.ebuild,v 1.1 2014/03/29 22:43:59 dlan Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-if [[ $PV = *9999* ]]; then
- scm_eclass=git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://ceph.com/download/${P}.tar.bz2"
- KEYWORDS=""
-fi
-
-inherit autotools eutils multilib python-any-r1 udev ${scm_eclass}
-
-DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc"
-
-CDEPEND="
- app-arch/snappy
- dev-libs/boost:=[threads]
- dev-libs/fcgi
- dev-libs/libaio
- dev-libs/libedit
- dev-libs/leveldb[snappy]
- nss? ( dev-libs/nss )
- cryptopp? ( dev-libs/crypto++ )
- sys-apps/keyutils
- sys-apps/util-linux
- dev-libs/libxml2
- fuse? ( sys-fs/fuse )
- libatomic? ( dev-libs/libatomic_ops )
- gtk? (
- x11-libs/gtk+:2
- dev-cpp/gtkmm:2.4
- gnome-base/librsvg
- )
- radosgw? (
- dev-libs/fcgi
- dev-libs/expat
- net-misc/curl
- )
- tcmalloc? ( dev-util/google-perftools )
- $(python_gen_any_dep '
- virtual/python-argparse[${PYTHON_USEDEP}]
- ' )
- ${PYTHON_DEPS}
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- sys-apps/hdparm
- $(python_gen_any_dep '
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ' )"
-REQUIRED_USE="
- ^^ ( nss cryptopp )
- "
-
-STRIP_MASK="/usr/lib*/rados-classes/*"
-
-PATCHES=( "${FILESDIR}"/${PN}-fix-gnustack.patch )
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- if [ ! -z ${PATCHES[@]} ]; then
- epatch ${PATCHES[@]}
- fi
- sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
- > "${T}"/${PN}.initd || die
-
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- econf \
- --without-hadoop \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --includedir=/usr/include \
- $(use_with debug) \
- $(use_with fuse) \
- $(use_with libaio) \
- $(use_with libatomic libatomic-ops) \
- $(use_with nss) \
- $(use_with cryptopp) \
- $(use_with radosgw) \
- $(use_with gtk gtk2) \
- $(use_enable static-libs static) \
- $(use_with tcmalloc)
-}
-
-src_install() {
- default
-
- prune_libtool_files --all
-
- exeinto /usr/$(get_libdir)/ceph
- newexe src/init-ceph ceph_init.sh
-
- insinto /etc/logrotate.d/
- newins src/logrotate.conf ${PN}
-
- chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
-
- keepdir /var/lib/${PN}
- keepdir /var/lib/${PN}/tmp
- keepdir /var/log/${PN}/stat
-
- newinitd "${T}/${PN}.initd" ${PN}
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
-
- _python_rewrite_shebang \
- "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
- "${ED}"/usr/bin/{ceph,ceph-rest-api}
-
- #install udev rules
- udev_dorules udev/50-rbd.rules
- udev_dorules udev/95-ceph-osd.rules
-}
-
-pkg_postinst() {
- elog "We suggest to install following packages"
- elog " sys-block/parted to manage disk partions"
- elog " sys-fs/btrfs-progs to use btrfs filesytem"
- elog " sys-fs/cryptsetup to use encrypted devices with dm-crypt"
-}
diff --git a/sys-cluster/ceph/ceph-0.77.ebuild b/sys-cluster/ceph/ceph-0.79.ebuild
index ee6828bf01c4..bbca4bba03b2 100644
--- a/sys-cluster/ceph/ceph-0.77.ebuild
+++ b/sys-cluster/ceph/ceph-0.79.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.77.ebuild,v 1.1 2014/02/20 10:18:55 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.79.ebuild,v 1.1 2014/04/17 23:51:20 dlan Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -24,7 +24,7 @@ HOMEPAGE="http://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc"
+IUSE="cryptopp debug fuse gtk libatomic +libaio libxfs libzfs +nss radosgw static-libs tcmalloc"
CDEPEND="
app-arch/snappy
@@ -40,6 +40,8 @@ CDEPEND="
dev-libs/libxml2
fuse? ( sys-fs/fuse )
libatomic? ( dev-libs/libatomic_ops )
+ libxfs? ( sys-fs/xfsprogs )
+ libzfs? ( sys-fs/zfs )
gtk? (
x11-libs/gtk+:2
dev-cpp/gtkmm:2.4
@@ -70,16 +72,18 @@ REQUIRED_USE="
STRIP_MASK="/usr/lib*/rados-classes/*"
-PATCHES=( "${FILESDIR}"/${PN}-fix-gnustack.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-gnustack.patch
+ "${FILESDIR}"/${P}-libzfs.patch
+)
pkg_setup() {
python-any-r1_pkg_setup
}
src_prepare() {
- if [ ! -z ${PATCHES[@]} ]; then
- epatch ${PATCHES[@]}
- fi
+ [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
+
sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
> "${T}"/${PN}.initd || die
@@ -101,7 +105,9 @@ src_configure() {
$(use_with radosgw) \
$(use_with gtk gtk2) \
$(use_enable static-libs static) \
- $(use_with tcmalloc)
+ $(use_with tcmalloc) \
+ $(use_with libxfs) \
+ $(use_with libzfs)
}
src_install() {
diff --git a/sys-cluster/ceph/ceph-9999.ebuild b/sys-cluster/ceph/ceph-9999.ebuild
index 268b4b8d1bf4..1c47eb6aaaf6 100644
--- a/sys-cluster/ceph/ceph-9999.ebuild
+++ b/sys-cluster/ceph/ceph-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-9999.ebuild,v 1.8 2014/01/26 08:40:49 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-9999.ebuild,v 1.9 2014/04/17 23:51:20 dlan Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -24,7 +24,7 @@ HOMEPAGE="http://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc"
+IUSE="cryptopp debug fuse gtk libatomic +libaio libxfs libzfs +nss radosgw static-libs tcmalloc"
CDEPEND="
app-arch/snappy
@@ -40,6 +40,8 @@ CDEPEND="
dev-libs/libxml2
fuse? ( sys-fs/fuse )
libatomic? ( dev-libs/libatomic_ops )
+ libxfs? ( sys-fs/xfsprogs )
+ libzfs? ( sys-fs/zfs )
gtk? (
x11-libs/gtk+:2
dev-cpp/gtkmm:2.4
@@ -60,9 +62,6 @@ DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
sys-apps/hdparm
- sys-block/parted
- sys-fs/cryptsetup
- sys-fs/btrfs-progs
$(python_gen_any_dep '
dev-python/flask[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
@@ -78,9 +77,8 @@ pkg_setup() {
}
src_prepare() {
- if [ ! -z ${PATCHES[@]} ]; then
- epatch ${PATCHES[@]}
- fi
+ [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
+
sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
> "${T}"/${PN}.initd || die
@@ -102,7 +100,9 @@ src_configure() {
$(use_with radosgw) \
$(use_with gtk gtk2) \
$(use_enable static-libs static) \
- $(use_with tcmalloc)
+ $(use_with tcmalloc) \
+ $(use_with libxfs) \
+ $(use_with libzfs)
}
src_install() {
@@ -133,3 +133,10 @@ src_install() {
udev_dorules udev/50-rbd.rules
udev_dorules udev/95-ceph-osd.rules
}
+
+pkg_postinst() {
+ elog "We suggest to install following packages"
+ elog " sys-block/parted to manage disk partions"
+ elog " sys-fs/btrfs-progs to use btrfs filesytem"
+ elog " sys-fs/cryptsetup to use encrypted devices with dm-crypt"
+}
diff --git a/sys-cluster/ceph/files/ceph-0.79-libzfs.patch b/sys-cluster/ceph/files/ceph-0.79-libzfs.patch
new file mode 100644
index 000000000000..6d79c178d43e
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-0.79-libzfs.patch
@@ -0,0 +1,13 @@
+diff --git a/src/os/Makefile.am b/src/os/Makefile.am
+index 252c678..c28ad0a 100644
+--- a/src/os/Makefile.am
++++ b/src/os/Makefile.am
+@@ -61,7 +61,7 @@ noinst_HEADERS += \
+
+ if WITH_LIBZFS
+ libos_zfs_a_SOURCES = os/ZFS.cc
+-libos_zfs_a_CXXFLAGS = ${AM_CXXFLAGS} ${LIBZFS_CFLAGS}
++libos_zfs_a_CXXFLAGS = ${AM_CXXFLAGS} ${LIBZFS_CFLAGS} -I/usr/include/libzfs -I/usr/include/libspl
+ noinst_LIBRARIES += libos_zfs.a
+ noinst_HEADERS += os/ZFS.h
+ endif
diff --git a/sys-cluster/ceph/metadata.xml b/sys-cluster/ceph/metadata.xml
index 350ee821ff70..a51b0a656879 100644
--- a/sys-cluster/ceph/metadata.xml
+++ b/sys-cluster/ceph/metadata.xml
@@ -15,6 +15,8 @@ Ceph is a distributed network file system designed to provide excellent performa
<flag name='fuse'>Build fuse client</flag>
<flag name='libatomic'>Use libatomic instead of builtin atomic operations</flag>
<flag name='libaio'>Use libaio as asynchronous input/output library</flag>
+ <flag name='libxfs'>Add xfs support</flag>
+ <flag name='libzfs'>Add zfs support</flag>
<flag name='nss'>Use <pkg>dev-libs/nss</pkg> for cryptography</flag>
<flag name='radosgw'>Add radosgw support</flag>
</use>