summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-20 18:58:55 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-20 18:58:55 +0000
commit4f9ace19a0132737c6678435612eaa184f0d142f (patch)
treecafb4020a8b9bbe35257dcb141f621950949d05b /sys-cluster/ceph
parentppc/ppc64 stable wrt #341169 (diff)
downloadgentoo-2-4f9ace19a0132737c6678435612eaa184f0d142f.tar.gz
gentoo-2-4f9ace19a0132737c6678435612eaa184f0d142f.tar.bz2
gentoo-2-4f9ace19a0132737c6678435612eaa184f0d142f.zip
[sys-cluster/ceph] Version bump. Thanks to Alexys Jacob
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ChangeLog8
-rw-r--r--sys-cluster/ceph/ceph-0.24.1.ebuild72
-rw-r--r--sys-cluster/ceph/files/ceph-0.24.1-autotools.patch14
3 files changed, 93 insertions, 1 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 53478531f08e..43c778e27738 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.2 2011/01/19 17:34:13 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.3 2011/01/20 18:58:55 alexxy Exp $
+
+*ceph-0.24.1 (20 Jan 2011)
+
+ 20 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org> +ceph-0.24.1.ebuild,
+ +files/ceph-0.24.1-autotools.patch:
+ Version bump. Thanks to Alexys Jacob
19 Jan 2011; Ultrabug <ultrabug@gentoo.org> ceph-0.23.1.ebuild:
Disable tcmalloc switch until fixed by upstream. Fixes #351032. Thanks to
diff --git a/sys-cluster/ceph/ceph-0.24.1.ebuild b/sys-cluster/ceph/ceph-0.24.1.ebuild
new file mode 100644
index 000000000000..cf8b95857125
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.24.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.24.1.ebuild,v 1.1 2011/01/20 18:58:55 alexxy Exp $
+
+EAPI="3"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.newdream.net/"
+SRC_URI="http://ceph.newdream.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fuse libatomic radosgw static-libs"
+
+CDEPEND="dev-libs/boost
+ dev-libs/libedit
+ libatomic? ( dev-libs/libatomic_ops )
+ fuse? ( sys-fs/fuse )
+ radosgw? ( dev-libs/fcgi dev-libs/expat )
+ dev-libs/crypto++
+ "
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-fs/btrfs-progs"
+
+src_prepare() {
+ sed -e 's:invoke-rc\.d.*:/etc/init.d/ceph reload >/dev/null:' \
+ -i src/logrotate.conf || die
+ sed -i "/^docdir =/d" src/Makefile.am || die #fix doc path
+ epatch "${FILESDIR}/${P}-autotools.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --without-tcmalloc \
+ --docdir=/usr/share/doc/${PF} \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with radosgw) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}" -type f -name "*.la" -exec rm -f {} \;
+
+ rmdir "${D}/usr/sbin"
+
+ exeinto /usr/$(get_libdir)/ceph || die
+ newexe src/init-ceph ceph_init.sh || die
+
+ insinto /etc/logrotate.d/ || die
+ newins src/logrotate.conf ${PN} || die
+
+ chmod 644 "${D}"/usr/share/doc/${PF}/sample.* || die
+
+ keepdir /var/lib/${PN} || die
+ keepdir /var/lib/${PN}/tmp || die
+ keepdir /var/log/${PN}/stat || die
+ keepdir /var/run/${PN} || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
+ newconfd "${FILESDIR}/${PN}.confd" ${PN} || die
+}
diff --git a/sys-cluster/ceph/files/ceph-0.24.1-autotools.patch b/sys-cluster/ceph/files/ceph-0.24.1-autotools.patch
new file mode 100644
index 000000000000..b80371b4d378
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-0.24.1-autotools.patch
@@ -0,0 +1,14 @@
+--- a/configure.ac 2011-01-09 00:41:26.000000000 +0100
++++ b/configure.ac 2011-01-20 13:58:12.071764382 +0100
+@@ -33,7 +33,10 @@
+ AC_CHECK_LIB([m], [pow], [true], AC_MSG_FAILURE([libm not found]))
+ AC_CHECK_LIB([pthread], [pthread_create], [true], AC_MSG_FAILURE([libpthread not found]))
+ PKG_CHECK_MODULES([CRYPTOPP], [libcrypto++], [], [
+- AC_SEARCH_LIBS([_ZTIN8CryptoPP14CBC_EncryptionE], [crypto++ cryptopp], [true], AC_MSG_FAILURE([libcrypto++ not found]), [-lpthread])])
++ AC_LANG_PUSH([C++])
++ AC_SEARCH_LIBS([_ZTIN8CryptoPP14CBC_EncryptionE], [crypto++ cryptopp], [true], AC_MSG_FAILURE([libcrypto++ not found]), [-lpthread])
++ AC_LANG_POP([C++])
++ ])
+
+ # debug crap?
+ AC_ARG_WITH([debug],