summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-08-18 03:35:05 +0000
committerMatt Turner <mattst88@gentoo.org>2011-08-18 03:35:05 +0000
commitff16e7183e8190f53bd964cc25b5f1d975b9b567 (patch)
tree6a519a7f471883cb76bfae5eee96bbf30b1e3809 /sys-boot
parentVersion bumped. (diff)
downloadgentoo-2-ff16e7183e8190f53bd964cc25b5f1d975b9b567.tar.gz
gentoo-2-ff16e7183e8190f53bd964cc25b5f1d975b9b567.tar.bz2
gentoo-2-ff16e7183e8190f53bd964cc25b5f1d975b9b567.zip
Don't patch generated autotools files, bug 226827. Bump to EAPI4.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/dvhtool/ChangeLog8
-rw-r--r--sys-boot/dvhtool/dvhtool-1.0.1-r2.ebuild31
-rw-r--r--sys-boot/dvhtool/files/dvhtool-1.0.1-debian.diff17
3 files changed, 21 insertions, 35 deletions
diff --git a/sys-boot/dvhtool/ChangeLog b/sys-boot/dvhtool/ChangeLog
index 0fd1c987689f..f115137e4a6f 100644
--- a/sys-boot/dvhtool/ChangeLog
+++ b/sys-boot/dvhtool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/dvhtool
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/dvhtool/ChangeLog,v 1.13 2009/03/01 23:26:14 kumba Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/dvhtool/ChangeLog,v 1.14 2011/08/18 03:35:05 mattst88 Exp $
+
+ 18 Aug 2011; Matt Turner <mattst88@gentoo.org> dvhtool-1.0.1-r2.ebuild,
+ files/dvhtool-1.0.1-debian.diff:
+ Don't patch generated autotools files, bug 226827. Bump to EAPI4.
01 Mar 2009; Joshua Kinard <kumba@gentoo.org> dvhtool-1.0.1-r2.ebuild:
Make dvhtool cross-compilable via toolchain-funcs
diff --git a/sys-boot/dvhtool/dvhtool-1.0.1-r2.ebuild b/sys-boot/dvhtool/dvhtool-1.0.1-r2.ebuild
index 5a7cd7cc51ce..ca963a6245e7 100644
--- a/sys-boot/dvhtool/dvhtool-1.0.1-r2.ebuild
+++ b/sys-boot/dvhtool/dvhtool-1.0.1-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/dvhtool/dvhtool-1.0.1-r2.ebuild,v 1.3 2009/03/01 23:26:14 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/dvhtool/dvhtool-1.0.1-r2.ebuild,v 1.4 2011/08/18 03:35:05 mattst88 Exp $
-inherit eutils toolchain-funcs
+EAPI=4
+
+inherit autotools eutils toolchain-funcs
DESCRIPTION="Tool to copy kernel(s) into the volume header on SGI MIPS-based workstations."
HOMEPAGE="http://packages.debian.org/unstable/utils/dvhtool"
@@ -10,15 +12,14 @@ SRC_URI="mirror://debian/pool/main/d/dvhtool/dvhtool_1.0.1.orig.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-* ~mips ~x86 ~amd64"
+KEYWORDS="~amd64 ~mips ~x86"
IUSE=""
DEPEND=""
RDEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}.orig"
+S="${S}.orig"
+src_prepare() {
# several applicable hunks from a debian patch
epatch "${FILESDIR}"/${P}-debian.diff
@@ -28,18 +29,16 @@ src_unpack() {
# Allow dvhtool to recognize Linux RAID and Linux LVM partitions
epatch "${FILESDIR}"/${P}-add-raid-lvm-parttypes.patch
-}
-src_compile() {
- cd "${S}.orig"
- CC=$(tc-getCC) LD=$(tc-getLD) \
- econf || die "econf failed"
+ eautoreconf
+}
+src_configure() {
CC=$(tc-getCC) LD=$(tc-getLD) \
- emake || die "Failed to compile"
+ econf
}
-src_install() {
- cd "${S}.orig"
- einstall
+src_compile() {
+ CC=$(tc-getCC) LD=$(tc-getLD) \
+ emake
}
diff --git a/sys-boot/dvhtool/files/dvhtool-1.0.1-debian.diff b/sys-boot/dvhtool/files/dvhtool-1.0.1-debian.diff
index 68a402008f74..43f33ffc2596 100644
--- a/sys-boot/dvhtool/files/dvhtool-1.0.1-debian.diff
+++ b/sys-boot/dvhtool/files/dvhtool-1.0.1-debian.diff
@@ -133,20 +133,3 @@
installdirs:
$(mkinstalldirs) $(DESTDIR)$(sbindir) $(DESTDIR)$(mandir)/man8
---- dvhtool-1.0.1.orig/aclocal.m4
-+++ dvhtool-1.0.1/aclocal.m4
-@@ -1,4 +1,4 @@
--dnl aclocal.m4 generated automatically by aclocal 1.4a
-+dnl aclocal.m4 generated automatically by aclocal 1.4-p4
-
- dnl Copyright (C) 1994, 1995-8, 1999 Free Software Foundation, Inc.
- dnl This file is free software; the Free Software Foundation
-@@ -51,8 +51,6 @@
-
- AC_DEFUN(AM_INIT_AUTOMAKE,
- [AC_REQUIRE([AC_PROG_INSTALL])
--dnl We require 2.13 because we rely on SHELL being computed by configure.
--AC_PREREQ([2.13])
- PACKAGE=[$1]
- AC_SUBST(PACKAGE)
- VERSION=[$2]