summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-05 23:18:02 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-05 23:18:02 +0000
commitf2a64b6943bceec9bfb1dbaef9cc17e3485cf9f7 (patch)
tree0646bb3e7ef04b78ef6d8828571d8528858d1755 /sys-boot
parentmake sure errors are detected properly when using -v #87835 (diff)
downloadgentoo-2-f2a64b6943bceec9bfb1dbaef9cc17e3485cf9f7.tar.gz
gentoo-2-f2a64b6943bceec9bfb1dbaef9cc17e3485cf9f7.tar.bz2
gentoo-2-f2a64b6943bceec9bfb1dbaef9cc17e3485cf9f7.zip
Update the linker script with a patch from redhat which supports newer versions of binutils.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gnu-efi/ChangeLog9
-rw-r--r--sys-boot/gnu-efi/files/digest-gnu-efi-3.0a-r11
-rw-r--r--sys-boot/gnu-efi/files/gnu-efi-3.0a-lds-redhat.patch42
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0a-r1.ebuild37
4 files changed, 88 insertions, 1 deletions
diff --git a/sys-boot/gnu-efi/ChangeLog b/sys-boot/gnu-efi/ChangeLog
index 69dfaf8206f0..4b48e2e69120 100644
--- a/sys-boot/gnu-efi/ChangeLog
+++ b/sys-boot/gnu-efi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/gnu-efi
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/ChangeLog,v 1.7 2005/01/23 11:33:41 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/ChangeLog,v 1.8 2005/04/05 23:18:02 vapier Exp $
+
+*gnu-efi-3.0a-r1 (05 Apr 2005)
+
+ 05 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/gnu-efi-3.0a-lds-redhat.patch, +gnu-efi-3.0a-r1.ebuild:
+ Update the linker script with a patch from redhat which supports newer
+ versions of binutils.
23 Jan 2005; <plasmaroo@gentoo.org> gnu-efi-3.0a.ebuild:
Adding missing pcituils dependency; solves merge failures on bootstrapping.
diff --git a/sys-boot/gnu-efi/files/digest-gnu-efi-3.0a-r1 b/sys-boot/gnu-efi/files/digest-gnu-efi-3.0a-r1
new file mode 100644
index 000000000000..c0e9f5fd2a56
--- /dev/null
+++ b/sys-boot/gnu-efi/files/digest-gnu-efi-3.0a-r1
@@ -0,0 +1 @@
+MD5 0f613e693cbc3f35ff1863ac23954baf gnu-efi-3.0a.tar.gz 119079
diff --git a/sys-boot/gnu-efi/files/gnu-efi-3.0a-lds-redhat.patch b/sys-boot/gnu-efi/files/gnu-efi-3.0a-lds-redhat.patch
new file mode 100644
index 000000000000..d47dc3a0d053
--- /dev/null
+++ b/sys-boot/gnu-efi/files/gnu-efi-3.0a-lds-redhat.patch
@@ -0,0 +1,42 @@
+Updated lds patch from redhat which works with newer binutils.
+
+http://bugs.gentoo.org/show_bug.cgi?id=79091
+
+--- gnuefi/elf_ia64_efi.lds
++++ gnuefi/elf_ia64_efi.lds
+@@ -28,6 +28,5 @@
+ {
+ *(.rodata*)
+ *(.ctors)
+- *(.data)
+- *(.data1)
++ *(.data*)
+ *(.gnu.linkonce.d*)
+@@ -31,8 +31,4 @@ SECTIONS
+ *(.plabel) /* data whose relocs we want to ignore */
+- *(.IA_64.unwind)
+- *(.IA_64.unwind_info)
+- *(.IA64.unwind)
+- *(.IA64.unwind_info)
+ /* the EFI loader doesn't seem to like a .bss section, so we stick
+ it all into .data: */
+ *(.dynbss)
+@@ -48,7 +47,7 @@
+ .rela :
+ {
+ *(.rela.text)
+- *(.rela.data)
++ *(.rela.data*)
+ *(.rela.sdata)
+ *(.rela.got)
+ *(.rela.gnu.linkonce.d*)
+@@ -68,4 +64,9 @@ SECTIONS
+ *(.rela.plabel)
+ *(.rela.reloc)
+ }
++ /DISCARD/ :
++ {
++ *(.IA_64.unwind*)
++ *(.IA64.unwind*)
++ }
+ }
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0a-r1.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0a-r1.ebuild
new file mode 100644
index 000000000000..82f049fde118
--- /dev/null
+++ b/sys-boot/gnu-efi/gnu-efi-3.0a-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/gnu-efi-3.0a-r1.ebuild,v 1.1 2005/04/05 23:18:02 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Library for build EFI Applications"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="ftp://ftp.hpl.hp.com/pub/linux-ia64/gnu-efi-3.0a.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/gnu-efi-3.0a-lds-redhat.patch
+}
+
+src_compile() {
+ local iarch
+ case $ARCH in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ *) die "unknown architecture: $ARCH" ;;
+ esac
+ emake CC="$(tc-getCC)" ARCH=${iarch} -j1 || die "emake failed"
+}
+
+src_install() {
+ make install INSTALLROOT="${D}"/usr || die "install failed"
+ dodoc README* ChangeLog
+}