summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-05 01:32:59 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-05 01:32:59 +0000
commited7a8ae3fac232f41dd8e0c4be973fa67fbb344d (patch)
treeaffa4cf7d1d039761101d3d10fcbfd3dd044e95a /sys-boot
parentChange manifest to new hashes. (diff)
downloadgentoo-2-ed7a8ae3fac232f41dd8e0c4be973fa67fbb344d.tar.gz
gentoo-2-ed7a8ae3fac232f41dd8e0c4be973fa67fbb344d.tar.bz2
gentoo-2-ed7a8ae3fac232f41dd8e0c4be973fa67fbb344d.zip
Fix building with glibc-2.16 #424703 by Martin Jansa.
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/files/grub-2.00-no-gets.patch22
-rw-r--r--sys-boot/grub/grub-2.00.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 8a9264a05330..45f329c590e0 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.225 2012/07/01 22:11:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.226 2012/07/05 01:32:59 vapier Exp $
+
+ 05 Jul 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/grub-2.00-no-gets.patch, grub-2.00.ebuild:
+ Fix building with glibc-2.16 #424703 by Martin Jansa.
01 Jul 2012; Mike Gilbert <floppym@gentoo.org> grub-2.00.ebuild,
grub-9999.ebuild:
diff --git a/sys-boot/grub/files/grub-2.00-no-gets.patch b/sys-boot/grub/files/grub-2.00-no-gets.patch
new file mode 100644
index 000000000000..c21d4b976e2c
--- /dev/null
+++ b/sys-boot/grub/files/grub-2.00-no-gets.patch
@@ -0,0 +1,22 @@
+hack until gzip pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/grub-core/gnulib/stdio.in.h
++++ b/grub-core/gnulib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
diff --git a/sys-boot/grub/grub-2.00.ebuild b/sys-boot/grub/grub-2.00.ebuild
index 85ea67f6061b..844e1620bdaf 100644
--- a/sys-boot/grub/grub-2.00.ebuild
+++ b/sys-boot/grub/grub-2.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.10 2012/07/01 22:11:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.11 2012/07/05 01:32:59 vapier Exp $
EAPI=4
@@ -211,6 +211,7 @@ src_prepare() {
if [[ ${PV} != 9999 ]]; then
epatch "${FILESDIR}/${P}-manpage-race.patch"
+ epatch "${FILESDIR}/${P}-no-gets.patch" #424703
fi
# fix texinfo file name, bug 416035