summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-02-23 01:15:38 +0000
committerAron Griffis <agriffis@gentoo.org>2006-02-23 01:15:38 +0000
commitebc0084ffb8266f946808812598e2cb58dc2f9ca (patch)
treee38261f5e1b9a7825f268a07b7f24e7c5242aad5 /sys-boot
parentInitial import. (diff)
downloadgentoo-2-ebc0084ffb8266f946808812598e2cb58dc2f9ca.tar.gz
gentoo-2-ebc0084ffb8266f946808812598e2cb58dc2f9ca.tar.bz2
gentoo-2-ebc0084ffb8266f946808812598e2cb58dc2f9ca.zip
Move elilo script to mirrors
(Portage version: 2.0.54)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/elilo/ChangeLog6
-rw-r--r--sys-boot/elilo/elilo-3.4-r3.ebuild23
-rw-r--r--sys-boot/elilo/elilo-3.6.ebuild19
-rw-r--r--sys-boot/elilo/metadata.xml5
4 files changed, 32 insertions, 21 deletions
diff --git a/sys-boot/elilo/ChangeLog b/sys-boot/elilo/ChangeLog
index 3d309d0dffe7..9226f91a5241 100644
--- a/sys-boot/elilo/ChangeLog
+++ b/sys-boot/elilo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/elilo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.14 2006/02/14 21:50:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.15 2006/02/23 01:15:38 agriffis Exp $
+
+ 23 Feb 2006; Aron Griffis <agriffis@gentoo.org> +metadata.xml,
+ elilo-3.4-r3.ebuild, elilo-3.6.ebuild:
+ Move elilo script to mirrors
14 Feb 2006; Aron Griffis <agriffis@gentoo.org> elilo-3.6.ebuild:
Mark stable immediately since older versions can't boot with initramfs
diff --git a/sys-boot/elilo/elilo-3.4-r3.ebuild b/sys-boot/elilo/elilo-3.4-r3.ebuild
index 1dafed82919b..9d90867b42aa 100644
--- a/sys-boot/elilo/elilo-3.4-r3.ebuild
+++ b/sys-boot/elilo/elilo-3.4-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.4-r3.ebuild,v 1.2 2005/10/03 16:38:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.4-r3.ebuild,v 1.3 2006/02/23 01:15:38 agriffis Exp $
inherit eutils toolchain-funcs
@@ -21,10 +21,11 @@ PROVIDE="virtual/bootloader"
src_unpack() {
unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/elilo-3.4-makefile.patch
- epatch "${FILESDIR}"/elilo-3.4-proc-sigsetjmp.patch
- epatch "${FILESDIR}"/elilo-3.3a-devscheme.patch
+ cd ${S}
+ epatch ${FILESDIR}/elilo-3.4-makefile.patch
+ epatch ${FILESDIR}/elilo-3.4-proc-sigsetjmp.patch
+ epatch ${FILESDIR}/elilo-3.3a-devscheme.patch
+ gzip -dc ${DISTDIR}/elilo-3.4.gz > $T/elilo
}
src_compile() {
@@ -42,16 +43,16 @@ src_compile() {
}
src_install() {
- newsbin "${FILESDIR}"/elilo-${PV} elilo || die "elilo failed"
+ dosbin ${T}/elilo || die "elilo failed"
dosbin tools/eliloalt || die "eliloalt failed"
exeinto /usr/lib/elilo
doexe elilo.efi || die "elilo.efi failed"
insinto /etc
- newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+ newins ${FILESDIR}/elilo.conf.sample elilo.conf
- dodoc docs/* "${FILESDIR}"/elilo.conf.sample
- newman "${FILESDIR}"/elilo.8-${PV} elilo.8
- newman "${FILESDIR}"/eliloalt.8-${PV} eliloalt.8
+ dodoc docs/* ${FILESDIR}/elilo.conf.sample
+ newman ${FILESDIR}/elilo.8-${PV} elilo.8
+ newman ${FILESDIR}/eliloalt.8-${PV} eliloalt.8
}
diff --git a/sys-boot/elilo/elilo-3.6.ebuild b/sys-boot/elilo/elilo-3.6.ebuild
index dd4f8e8a22ed..1ba0a828adf9 100644
--- a/sys-boot/elilo/elilo-3.6.ebuild
+++ b/sys-boot/elilo/elilo-3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.6.ebuild,v 1.2 2006/02/14 21:50:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.6.ebuild,v 1.3 2006/02/23 01:15:38 agriffis Exp $
inherit eutils toolchain-funcs
@@ -23,9 +23,10 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/elilo-3.4-makefile.patch
- epatch "${FILESDIR}"/elilo-3.3a-devscheme.patch
+ cd ${S}
+ epatch ${FILESDIR}/elilo-3.4-makefile.patch
+ epatch ${FILESDIR}/elilo-3.3a-devscheme.patch
+ gzip -dc ${DISTDIR}/elilo-3.4.gz > $T/elilo
}
src_compile() {
@@ -43,16 +44,16 @@ src_compile() {
}
src_install() {
- newsbin "${FILESDIR}"/elilo-3.4 elilo || die "elilo failed"
+ dosbin ${T}/elilo || die "elilo failed"
dosbin tools/eliloalt || die "eliloalt failed"
exeinto /usr/lib/elilo
doexe elilo.efi || die "elilo.efi failed"
insinto /etc
- newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+ newins ${FILESDIR}/elilo.conf.sample elilo.conf
- dodoc docs/* "${FILESDIR}"/elilo.conf.sample
- newman "${FILESDIR}"/elilo.8-3.4 elilo.8
- newman "${FILESDIR}"/eliloalt.8-3.4 eliloalt.8
+ dodoc docs/* ${FILESDIR}/elilo.conf.sample
+ newman ${FILESDIR}/elilo.8-3.4 elilo.8
+ newman ${FILESDIR}/eliloalt.8-3.4 eliloalt.8
}
diff --git a/sys-boot/elilo/metadata.xml b/sys-boot/elilo/metadata.xml
new file mode 100644
index 000000000000..fe15722775f2
--- /dev/null
+++ b/sys-boot/elilo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ia64</herd>
+</pkgmetadata>