summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-07-15 17:09:03 +0000
committerJeroen Roovers <jer@gentoo.org>2010-07-15 17:09:03 +0000
commitea0f1a9b18e584d3751fd4c8ee0f344a9677eab9 (patch)
treeaf3bcab6f95f77965b4c325ea591b91154e37cf8 /sys-boot
parentUnmask USE=vala for net-libs/libproxy again (bug #320429). (diff)
downloadgentoo-2-ea0f1a9b18e584d3751fd4c8ee0f344a9677eab9.tar.gz
gentoo-2-ea0f1a9b18e584d3751fd4c8ee0f344a9677eab9.tar.bz2
gentoo-2-ea0f1a9b18e584d3751fd4c8ee0f344a9677eab9.zip
Version bump. Fix HOMEPAGE and SRC_URI (bug #304655). Add myself as maint.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/ChangeLog10
-rw-r--r--sys-boot/lilo/lilo-23.0.ebuild173
-rw-r--r--sys-boot/lilo/metadata.xml4
3 files changed, 185 insertions, 2 deletions
diff --git a/sys-boot/lilo/ChangeLog b/sys-boot/lilo/ChangeLog
index 20b225ebc21e..253516a2fd86 100644
--- a/sys-boot/lilo/ChangeLog
+++ b/sys-boot/lilo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/lilo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.55 2009/04/10 16:31:20 caleb Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.56 2010/07/15 17:09:03 jer Exp $
+
+*lilo-23.0 (15 Jul 2010)
+
+ 15 Jul 2010; Jeroen Roovers <jer@gentoo.org> +lilo-23.0.ebuild,
+ metadata.xml:
+ Version bump. Fix HOMEPAGE and SRC_URI (bug #304655). Add myself as maint.
10 Apr 2009; Caleb Tennis <caleb@gentoo.org> lilo-22.8-r2.ebuild:
fix device-mapper dep for lvm2, see #265599
diff --git a/sys-boot/lilo/lilo-23.0.ebuild b/sys-boot/lilo/lilo-23.0.ebuild
new file mode 100644
index 000000000000..7a061e4abde7
--- /dev/null
+++ b/sys-boot/lilo/lilo-23.0.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-23.0.ebuild,v 1.1 2010/07/15 17:09:03 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DOLILO_V="0.5"
+IUSE="static minimal pxeserial device-mapper"
+
+DESCRIPTION="Standard Linux boot loader"
+HOMEPAGE="https://alioth.debian.org/projects/lilo/"
+DOLILO_TAR="dolilo-${DOLILO_V}.tar.bz2"
+
+SRC_URI="
+ https://alioth.debian.org/frs/download.php/3315/${P}.tar.gz
+ mirror://gentoo/${DOLILO_TAR}
+"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="-* ~amd64 ~x86"
+
+DEPEND=">=sys-devel/bin86-0.15.5"
+RDEPEND="device-mapper? ( || (
+ >=sys-fs/lvm2-2.02.45
+ >=sys-fs/device-mapper-1.02.12 ) )"
+
+PROVIDE="virtual/bootloader"
+
+src_prepare() {
+ # this patch is needed when booting PXE and the device you're using
+ # emulates vga console via serial console.
+ # IE.. B.B.o.o.o.o.t.t.i.i.n.n.g.g....l.l.i.i.n.n.u.u.x.x and stair stepping.
+ use pxeserial && epatch "${FILESDIR}/${PN}-22.8-novga.patch"
+
+ # Do not strip
+ sed -i src/Makefile -e 's| -s | |g' -e '/strip/d' || die "sed strip failed"
+}
+
+src_compile() {
+ # lilo needs this. bug #140209
+ export LC_ALL=C
+
+ # hardened automatic PIC plus PIE building should be suppressed
+ # because of assembler instructions that cannot be compiled PIC
+ HARDENED_CFLAGS="`test-flags-CC -fno-pic -nopie`"
+
+ # we explicitly prevent the custom CFLAGS for stability reasons
+ if use static; then
+ emake CC="$(tc-getCC) ${LDFLAGS} ${HARDENED_CFLAGS}" alles || die
+ else
+ emake CC="$(tc-getCC) ${LDFLAGS} ${HARDENED_CFLAGS}" all || die
+ fi
+}
+
+src_install() {
+ keepdir /boot
+ emake DESTDIR="${D}" install || die
+
+ if use !minimal; then
+ into /
+ dosbin "${WORKDIR}"/dolilo/dolilo || die
+
+ into /usr
+ dosbin keytab-lilo.pl || die
+
+ insinto /etc
+ newins "${FILESDIR}"/lilo.conf lilo.conf.example || die
+
+ newconfd "${WORKDIR}"/dolilo/dolilo.conf.d dolilo.example || die
+
+ doman manPages/*.[5-8]
+ dodoc CHANGELOG* readme/README.* readme/INCOMPAT README
+ docinto samples ; dodoc sample/*
+ fi
+}
+
+# Check whether LILO is installed
+# This function is from /usr/sbin/mkboot from debianutils, with copyright:
+#
+# Debian GNU/Linux
+# Copyright 1996-1997 Guy Maor <maor@debian.org>
+#
+# Modified for Gentoo for use with the lilo ebuild by:
+# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
+#
+lilocheck() {
+ local bootpart=
+ local rootpart="$(mount | grep -v "tmpfs" | grep -v "rootfs" | grep "on / " | cut -f1 -d " ")"
+
+ echo
+ einfon "Checking for LILO ..."
+
+ if [ "$(whoami)" != "root" ]
+ then
+ echo; echo
+ eerror "Only root can check for LILO!"
+ return 1
+ fi
+
+ if [ -z "${rootpart}" ]
+ then
+ echo; echo
+ eerror "Could not determine root partition!"
+ return 1
+ fi
+
+ if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
+ then
+ echo " No"
+ return 1
+ fi
+
+ bootpart="$(sed -n "s:^boot[ ]*=[ ]*\(.*\)[ ]*:\1:p" /etc/lilo.conf)"
+
+ if [ -z "${bootpart}" ]
+ then
+ # lilo defaults to current root when 'boot=' is not present
+ bootpart="${rootpart}"
+ fi
+
+ if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
+ then
+ echo; echo
+ ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
+ ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
+ return 1
+ fi
+
+ echo " Yes, on ${bootpart}"
+
+ return 0
+}
+
+pkg_postinst() {
+ if [ ! -e "${ROOT}/boot/boot.b" -a ! -L "${ROOT}/boot/boot.b" ]
+ then
+ [ -f "${ROOT}/boot/boot-menu.b" ] && \
+ ln -snf boot-menu.b "${ROOT}/boot/boot.b"
+ fi
+
+ if [ "${ROOT}" = "/" ] && use !minimal;
+ then
+ if lilocheck
+ then
+ einfo "Running DOLILO to complete the install ..."
+ # do not redirect to /dev/null because it may display some input
+ # prompt
+ /sbin/dolilo
+ if [ "$?" -ne 0 ]
+ then
+ echo
+ ewarn "Running /sbin/dolilo failed! Please check what the problem is"
+ ewarn "before your next reboot."
+
+ ebeep 5
+ epause 5
+ fi
+ fi
+ echo
+ fi
+ if use !minimal; then
+ echo
+ einfo "Issue 'dolilo' instead of 'lilo' to have a friendly wrapper that"
+ einfo "handles mounting and unmounting /boot for you. It can do more then"
+ einfo "that when asked, edit /etc/conf.d/dolilo to harness it's full potential."
+ ebeep 5
+ epause 3
+ echo
+ fi
+}
diff --git a/sys-boot/lilo/metadata.xml b/sys-boot/lilo/metadata.xml
index 6471ad71ebd6..35b72ca24b6e 100644
--- a/sys-boot/lilo/metadata.xml
+++ b/sys-boot/lilo/metadata.xml
@@ -6,6 +6,10 @@
<email>chainsaw@gentoo.org</email>
<name>Tony Vroon</name>
</maintainer>
+<maintainer>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+</maintainer>
<use>
<flag name='device-mapper'>Enable support for
<pkg>sys-fs/device-mapper</pkg></flag>