summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-04-13 05:50:47 +0000
committerMike Frysinger <vapier@gentoo.org>2015-04-13 05:50:47 +0000
commite8a1a50cd6a28f72bef987d12c18c5f45c8898ee (patch)
treee284070b935bafb7c68522517817d320851f7b55 /sys-boot
parentVersion bump. (diff)
downloadgentoo-2-e8a1a50cd6a28f72bef987d12c18c5f45c8898ee.tar.gz
gentoo-2-e8a1a50cd6a28f72bef987d12c18c5f45c8898ee.tar.bz2
gentoo-2-e8a1a50cd6a28f72bef987d12c18c5f45c8898ee.zip
Version bump #537550 by David Holm.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gnu-efi/ChangeLog9
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0.2.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/sys-boot/gnu-efi/ChangeLog b/sys-boot/gnu-efi/ChangeLog
index 37c9046dd905..5f7bdf2ad3ef 100644
--- a/sys-boot/gnu-efi/ChangeLog
+++ b/sys-boot/gnu-efi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/gnu-efi
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/ChangeLog,v 1.25 2014/06/28 15:46:39 armin76 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/ChangeLog,v 1.26 2015/04/13 05:50:47 vapier Exp $
+
+*gnu-efi-3.0.2 (13 Apr 2015)
+
+ 13 Apr 2015; Mike Frysinger <vapier@gentoo.org> +gnu-efi-3.0.2.ebuild:
+ Version bump #537550 by David Holm.
28 Jun 2014; Raúl Porcel <armin76@gentoo.org> gnu-efi-3.0s.ebuild:
Add the fix from 3.0u to 3.0s since its stable, bug #503210
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.2.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.2.ebuild
new file mode 100644
index 000000000000..57bcfa777c82
--- /dev/null
+++ b/sys-boot/gnu-efi/gnu-efi-3.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/gnu-efi-3.0.2.ebuild,v 1.1 2015/04/13 05:50:47 vapier Exp $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Library for build EFI Applications"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="mirror://sourceforge/gnu-efi/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~ia64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+RDEPEND=""
+
+# These objects get run early boot (i.e. not inside of Linux),
+# so doing these QA checks on them doesn't make sense.
+QA_EXECSTACK="usr/*/lib*efi.a:* usr/*/crt*.o"
+
+_emake() {
+ emake \
+ prefix=${CHOST}- \
+ ARCH=${iarch} \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR='$(PREFIX)/'"$(get_libdir)" \
+ "$@"
+}
+
+src_compile() {
+ case ${ARCH} in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $ARCH" ;;
+ esac
+ # The lib subdir uses unsafe archive targets, and
+ # the apps subdir needs gnuefi subdir
+ _emake -j1
+}
+
+src_install() {
+ _emake install PREFIX=/usr INSTALLROOT="${D}"
+ dodoc README* ChangeLog
+}