summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-07-11 12:50:06 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-07-11 12:50:06 +0000
commite7b0120cf6f3e0af2febb14f5e32dcf72165c374 (patch)
tree23370f12f11b3b883593e918a80f4bec2332cdec /sys-boot
parentFixed dodoc call on dir wrt bug #367489 (diff)
downloadgentoo-2-e7b0120cf6f3e0af2febb14f5e32dcf72165c374.tar.gz
gentoo-2-e7b0120cf6f3e0af2febb14f5e32dcf72165c374.tar.bz2
gentoo-2-e7b0120cf6f3e0af2febb14f5e32dcf72165c374.zip
sys-boot/plymouth-openrc-plugin: ver-bump to 0.1.2; fixes bug #374025
(Portage version: 2.1.10.4/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/plymouth-openrc-plugin/ChangeLog13
-rw-r--r--sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild39
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-boot/plymouth-openrc-plugin/ChangeLog b/sys-boot/plymouth-openrc-plugin/ChangeLog
index d9655c291fe2..fac81eb4cc7c 100644
--- a/sys-boot/plymouth-openrc-plugin/ChangeLog
+++ b/sys-boot/plymouth-openrc-plugin/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-boot/plymouth-openrc-plugin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth-openrc-plugin/ChangeLog,v 1.3 2011/07/03 11:44:51 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth-openrc-plugin/ChangeLog,v 1.4 2011/07/11 12:50:06 aidecoe Exp $
+
+*plymouth-openrc-plugin-0.1.2 (11 Jul 2011)
+
+ 11 Jul 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +plymouth-openrc-plugin-0.1.2.ebuild:
+ Version bump to 0.1.2. Fixes bug #374025.
+
+ v0.1.2 changes:
+
+ * Checking at runtime if /run/plymouth subdirectory exists and if doesn't,
+ it's being created.
03 Jul 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
plymouth-openrc-plugin-0.1.1.ebuild:
diff --git a/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild
new file mode 100644
index 000000000000..db7492023e95
--- /dev/null
+++ b/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth-openrc-plugin/plymouth-openrc-plugin-0.1.2.ebuild,v 1.1 2011/07/11 12:50:06 aidecoe Exp $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Plymouth plugin for OpenRC"
+HOMEPAGE="https://github.com/aidecoe/plymouth-openrc-plugin"
+SRC_URI="
+http://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=sys-apps/openrc-0.8.2-r1
+ !<sys-boot/plymouth-0.8.3-r5
+ "
+RDEPEND="${DEPEND}
+ >=sys-boot/plymouth-0.8.3-r5
+ "
+
+src_install() {
+ insinto /$(get_libdir)/rc/plugins
+ doins plymouth.so
+}
+
+pkg_postinst() {
+ ewarn "You need to disable 'interactive' feature in /etc/rc.conf to make"
+ ewarn "Plymouth work properly with OpenRC init system."
+
+ if [[ ! -d /run ]]; then
+ eerror "/run doesn't exist! You need to create this directory."
+ echo
+ einfo "If you'd like to know more about purpose of /run, please read:"
+ einfo " https://lwn.net/Articles/436012/"
+ fi
+}