summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-02-01 11:56:25 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-02-01 11:56:25 +0000
commite0672f0873ae583930fea2f498798a2763a256ab (patch)
tree81a72214309f16b9eec5119ff699e1c3417eb4fa /sys-boot
parentclosing 23468 (tcl_version not being abided by during link phase), and 39119 ... (diff)
downloadgentoo-2-e0672f0873ae583930fea2f498798a2763a256ab.tar.gz
gentoo-2-e0672f0873ae583930fea2f498798a2763a256ab.tar.bz2
gentoo-2-e0672f0873ae583930fea2f498798a2763a256ab.zip
Added a patch to get LILO to compile on 2.6 headers; closes bug #32707.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/ChangeLog6
-rw-r--r--sys-boot/lilo/files/lilo-22.5.8.lvm.2-6headers.patch16
-rw-r--r--sys-boot/lilo/lilo-22.5.8-r1.ebuild3
3 files changed, 23 insertions, 2 deletions
diff --git a/sys-boot/lilo/ChangeLog b/sys-boot/lilo/ChangeLog
index 589dca8892a3..bdd50e1b6352 100644
--- a/sys-boot/lilo/ChangeLog
+++ b/sys-boot/lilo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/lilo
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.3 2004/01/19 18:34:01 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.4 2004/02/01 11:56:24 plasmaroo Exp $
+
+ 01 Feb 2004; <plasmaroo@gentoo.org> lilo-22.5.8-r1.ebuild,
+ files/lilo-22.5.8.lvm.2-6headers.patch:
+ Added a patch to get LILO to compile on 2.6 headers; closes bug #32707.
19 Jan 2004; Martin Schlemmer <azarah@gentoo.org> lilo-22.5.8-r1.ebuild:
Mark stable closing bug #38685.
diff --git a/sys-boot/lilo/files/lilo-22.5.8.lvm.2-6headers.patch b/sys-boot/lilo/files/lilo-22.5.8.lvm.2-6headers.patch
new file mode 100644
index 000000000000..7c93db0ae03c
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-22.5.8.lvm.2-6headers.patch
@@ -0,0 +1,16 @@
+--- lilo-22.5.8/geometry.c 2003-10-10 00:59:07.000000000 +0100
++++ lilo-22.5.8/geometry.c 2004-01-28 19:28:17.000000000 +0000
+@@ -99,6 +99,13 @@
+ #define HDIO_GETGEO HDIO_REQ
+ #endif
+
++/* plasmaroo@gentoo.org :: 2.6 Compatibility */
++
++#undef _IOR
++#undef _IOWR
++
++#define _IOR(type,nr,size) _IOC(_IOC_READ,(type),(nr),sizeof(size))
++#define _IOWR(type,nr,size) _IOC(_IOC_READ|_IOC_WRITE,(type),(nr),sizeof(size))
+
+ typedef struct _st_buf {
+ struct _st_buf *next;
diff --git a/sys-boot/lilo/lilo-22.5.8-r1.ebuild b/sys-boot/lilo/lilo-22.5.8-r1.ebuild
index 159ac8203b3b..c5a7c677608d 100644
--- a/sys-boot/lilo/lilo-22.5.8-r1.ebuild
+++ b/sys-boot/lilo/lilo-22.5.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.5.8-r1.ebuild,v 1.3 2004/01/19 18:34:01 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.5.8-r1.ebuild,v 1.4 2004/02/01 11:56:25 plasmaroo Exp $
inherit mount-boot eutils
@@ -42,6 +42,7 @@ src_unpack() {
# Fixup things for glibc-2.3.3 (and later CVS versions of 2.3.2)
cd ${S}; epatch ${FILESDIR}/${PN}-glibc233.patch
+ cd ${S}; epatch ${FILESDIR}/${P}.lvm.2-6headers.patch
}
src_compile() {