summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-16 09:17:54 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-16 09:17:54 +0000
commitdab8820e1fccdcd1b98d331f265d3511b72f0dfb (patch)
tree4b69c580082e2abb04000480a11e92518248fbce /sys-boot
parentold (diff)
downloadgentoo-2-dab8820e1fccdcd1b98d331f265d3511b72f0dfb.tar.gz
gentoo-2-dab8820e1fccdcd1b98d331f265d3511b72f0dfb.tar.bz2
gentoo-2-dab8820e1fccdcd1b98d331f265d3511b72f0dfb.zip
Version bump and add lzo to DEPEND as noted by Ron in #119149.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog9
-rw-r--r--sys-boot/grub/files/digest-grub-1.921
-rw-r--r--sys-boot/grub/grub-1.92.ebuild50
3 files changed, 58 insertions, 2 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 3aa1ff43c365..b0b562fabc62 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.55 2005/11/25 19:47:19 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.56 2006/01/16 09:17:54 vapier Exp $
+
+*grub-1.92 (16 Jan 2006)
+
+ 16 Jan 2006; Mike Frysinger <vapier@gentoo.org> +grub-1.92.ebuild:
+ Version bump and add lzo to DEPEND as noted by Ron in #119149.
*grub-1.91 (25 Nov 2005)
diff --git a/sys-boot/grub/files/digest-grub-1.92 b/sys-boot/grub/files/digest-grub-1.92
new file mode 100644
index 000000000000..9e266a86d1c8
--- /dev/null
+++ b/sys-boot/grub/files/digest-grub-1.92
@@ -0,0 +1 @@
+MD5 af7907e66613ea0733be4b429300d53d grub-1.92.tar.gz 422855
diff --git a/sys-boot/grub/grub-1.92.ebuild b/sys-boot/grub/grub-1.92.ebuild
new file mode 100644
index 000000000000..6e3d4d7ca1b0
--- /dev/null
+++ b/sys-boot/grub/grub-1.92.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.92.ebuild,v 1.1 2006/01/16 09:17:54 vapier Exp $
+
+inherit mount-boot eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="GNU GRUB 2 boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="-*"
+IUSE="static netboot custom-cflags"
+
+DEPEND=">=sys-libs/ncurses-5.2-r5
+ dev-libs/lzo"
+PROVIDE="virtual/bootloader"
+
+pkg_setup() {
+ if use amd64 ; then
+ if ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "If you are on amd64, make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit objects!"
+ fi
+
+ ABI_ALLOW="x86"
+ ABI="x86"
+ fi
+}
+
+src_compile() {
+ use custom-cflags || unset CFLAGS
+ use static && append-ldflags -static
+
+ econf \
+ --prefix=/ \
+ --datadir=/usr/lib \
+ || die "econf failed"
+ emake || die "making regular stuff"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}