summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-25 17:09:26 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-25 17:09:26 +0000
commitd8506580ca421efa5c5c9c94007555744fd87e56 (patch)
tree21073fa1059e30124b1dc01f350bb39874b256c5 /sys-boot
parentamd64 stable (diff)
downloadgentoo-2-d8506580ca421efa5c5c9c94007555744fd87e56.tar.gz
gentoo-2-d8506580ca421efa5c5c9c94007555744fd87e56.tar.bz2
gentoo-2-d8506580ca421efa5c5c9c94007555744fd87e56.zip
Fix from Kevin Lacquement for building in parallel #185361.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/files/grub-1.95-build.patch15
-rw-r--r--sys-boot/grub/grub-1.95.ebuild8
3 files changed, 27 insertions, 2 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 4e5dba042011..03b8bea4bc3d 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.73 2007/06/24 18:11:08 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.74 2007/08/25 17:09:26 vapier Exp $
+
+ 25 Aug 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/grub-1.95-build.patch, grub-1.95.ebuild:
+ Fix from Kevin Lacquement for building in parallel #185361.
24 Jun 2007; Piotr Jaroszyński <peper@gentoo.org> grub-1.95.ebuild:
(QA) Don't use KEYWORDS="-*". bug #160519.
diff --git a/sys-boot/grub/files/grub-1.95-build.patch b/sys-boot/grub/files/grub-1.95-build.patch
new file mode 100644
index 000000000000..fff11a5cbb07
--- /dev/null
+++ b/sys-boot/grub/files/grub-1.95-build.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/185361
+
+fix building in parallel
+
+--- grub-1.95/conf/i386-pc.mk
++++ grub-1.95/conf/i386-pc.mk
+@@ -739,7 +739,7 @@
+ $(CC) -Iutil -I$(srcdir)/util $(CPPFLAGS) $(CFLAGS) -DGRUB_UTIL=1 $(grub_emu_CFLAGS) -MD -c -o $@ $<
+ -include grub_emu-util_console.d
+
+-grub_emu-util_grub_emu.o: util/grub-emu.c
++grub_emu-util_grub_emu.o: util/grub-emu.c grub_modules_init.h
+ $(CC) -Iutil -I$(srcdir)/util $(CPPFLAGS) $(CFLAGS) -DGRUB_UTIL=1 $(grub_emu_CFLAGS) -MD -c -o $@ $<
+ -include grub_emu-util_grub_emu.d
+
diff --git a/sys-boot/grub/grub-1.95.ebuild b/sys-boot/grub/grub-1.95.ebuild
index def487ed4bad..f6f394f1b550 100644
--- a/sys-boot/grub/grub-1.95.ebuild
+++ b/sys-boot/grub/grub-1.95.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.95.ebuild,v 1.2 2007/06/24 18:11:08 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.95.ebuild,v 1.3 2007/08/25 17:09:26 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -18,6 +18,12 @@ DEPEND=">=sys-libs/ncurses-5.2-r5
dev-libs/lzo"
PROVIDE="virtual/bootloader"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch #185361
+}
+
src_compile() {
use amd64 && multilib_toolchain_setup x86
use custom-cflags || unset CFLAGS LDFLAGS