summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-10-27 06:30:48 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-10-27 06:30:48 +0000
commitd046db8e3acae1febecb90713348b4961405acdc (patch)
tree2205dae4047a56ed2754cc813ee9f7eb6c5681f5 /sys-boot
parent (Manifest recommit) (diff)
downloadgentoo-2-d046db8e3acae1febecb90713348b4961405acdc.tar.gz
gentoo-2-d046db8e3acae1febecb90713348b4961405acdc.tar.bz2
gentoo-2-d046db8e3acae1febecb90713348b4961405acdc.zip
Updated arcboot w/ a patch that shows current load progress of loading the kernel into memory, which is useful to inform users that the system has not stopped responding (arcboot is slow at loading kernels off disk). Patch credit: Kaj-Michael Lang - milang (at) tal dot org.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/arcboot/ChangeLog12
-rw-r--r--sys-boot/arcboot/Manifest8
-rw-r--r--sys-boot/arcboot/arcboot-0.3.8.4-r1.ebuild (renamed from sys-boot/arcboot/arcboot-0.3.8.4.ebuild)20
-rw-r--r--sys-boot/arcboot/files/arcboot-0.3.8.4-gentoo.patch82
-rw-r--r--sys-boot/arcboot/files/digest-arcboot-0.3.8.4-r1 (renamed from sys-boot/arcboot/files/digest-arcboot-0.3.8.4)0
5 files changed, 107 insertions, 15 deletions
diff --git a/sys-boot/arcboot/ChangeLog b/sys-boot/arcboot/ChangeLog
index 11ddd542fff0..aec3acf4aa08 100644
--- a/sys-boot/arcboot/ChangeLog
+++ b/sys-boot/arcboot/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-boot/arcboot
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcboot/ChangeLog,v 1.4 2004/10/19 05:52:21 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcboot/ChangeLog,v 1.5 2004/10/27 06:30:48 kumba Exp $
+
+*arcboot-0.3.8.4-r1 (27 Oct 2004)
+
+ 27 Oct 2004; Joshua Kinard <kumba@gentoo.org>
+ files/arcboot-0.3.8.4-gentoo.patch, +arcboot-0.3.8.4-r1.ebuild,
+ -arcboot-0.3.8.4.ebuild:
+ Updated arcboot w/ a patch that shows current load progress of loading the
+ kernel into memory, which is useful to inform users that the system has not
+ stopped responding (arcboot is slow at loading kernels off disk). Patch
+ credit: Kaj-Michael Lang - milang (at) tal dot org.
19 Oct 2004; Joshua Kinard <kumba@gentoo.org> arcboot-0.3.8.4.ebuild:
Forgot to add cobalt to IUSE.
diff --git a/sys-boot/arcboot/Manifest b/sys-boot/arcboot/Manifest
index 1f551540e4ad..bd340368c6ab 100644
--- a/sys-boot/arcboot/Manifest
+++ b/sys-boot/arcboot/Manifest
@@ -1,8 +1,8 @@
-MD5 82517fd437df41e030f7cfd665de0fc1 ChangeLog 827
+MD5 007d95a8c1815354ef141b5282187741 ChangeLog 1287
MD5 acc84630b73004cfe9c7acf158187164 arcboot-0.3.8.2.ebuild 3972
MD5 6fb572ed7959ebf0171d2e5e18b31831 metadata.xml 317
-MD5 09191cc07be3343d5e2da9764a192843 arcboot-0.3.8.4.ebuild 3872
+MD5 f92c371ec444300b45a9461e323b12e0 arcboot-0.3.8.4-r1.ebuild 3854
+MD5 48502666c968d002b7c270cfdf982800 files/arcboot-0.3.8.4-gentoo.patch 8052
MD5 ffbb46ff4240f217c96de74002a6e9eb files/arcboot-gentoo.patch 599
MD5 5993ec1e9bae04f3a57f094011601c4b files/digest-arcboot-0.3.8.2 67
-MD5 4a128a2a822242333bdb3de922c0b895 files/arcboot-0.3.8.4-gentoo.patch 336
-MD5 439138ebd60a5a26366ea044e4468b00 files/digest-arcboot-0.3.8.4 67
+MD5 439138ebd60a5a26366ea044e4468b00 files/digest-arcboot-0.3.8.4-r1 67
diff --git a/sys-boot/arcboot/arcboot-0.3.8.4.ebuild b/sys-boot/arcboot/arcboot-0.3.8.4-r1.ebuild
index 0ef785128f81..0d342b7eed27 100644
--- a/sys-boot/arcboot/arcboot-0.3.8.4.ebuild
+++ b/sys-boot/arcboot/arcboot-0.3.8.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcboot/arcboot-0.3.8.4.ebuild,v 1.2 2004/10/19 05:52:21 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcboot/arcboot-0.3.8.4-r1.ebuild,v 1.1 2004/10/27 06:30:48 kumba Exp $
inherit eutils
@@ -77,20 +77,20 @@ src_install() {
# Technically, we don't need tip22 (attaches initrd to kernel), as
# MIPS kernels support embedding initrd's into kernels at build time,
# But maybe this will be useful one day. Until then, we leave it out.
-## dodir /usr/lib/tip22
-## cp tip22/tip22 ${D}/usr/lib/tip22
-## cp tip22/tftpload.o ${D}/usr/lib/tip22
-## cp tip22/ld.kernel.script ${D}/usr/lib/tip22
-## cp tip22/ld.ramdisk.script ${D}/usr/lib/tip22
-## cp tip22/ld.script ${D}/usr/lib/tip22
-## cp arclib/libarc.a ${D}/usr/lib/tip22
+ dodir /usr/lib/tip22
+ cp tip22/tip22 ${D}/usr/lib/tip22
+ cp tip22/tftpload.o ${D}/usr/lib/tip22
+ cp tip22/ld.kernel.script ${D}/usr/lib/tip22
+ cp tip22/ld.ramdisk.script ${D}/usr/lib/tip22
+ cp tip22/ld.script ${D}/usr/lib/tip22
+ cp arclib/libarc.a ${D}/usr/lib/tip22
# Calling scripts for arcboot/tip22
# We also exclude these, since the logic in the debian script may not
# work correctly with a gentoo installation. All the information a
# user needs is provided in the example arcboot.conf, and in pkg_postinst().
## dosbin scripts/arcboot
-## dosbin tip22/tip22
+ dosbin tip22/tip22
# Conf file
dodir /etc
@@ -101,7 +101,7 @@ src_install() {
# also has info on setting the PROM option properly as well as arcboot.conf
# examples.
doman debian/arcboot.8
-## doman debian/tip22.8
+ doman debian/tip22.8
}
pkg_postinst() {
diff --git a/sys-boot/arcboot/files/arcboot-0.3.8.4-gentoo.patch b/sys-boot/arcboot/files/arcboot-0.3.8.4-gentoo.patch
index d29854977c6a..2131d7d71488 100644
--- a/sys-boot/arcboot/files/arcboot-0.3.8.4-gentoo.patch
+++ b/sys-boot/arcboot/files/arcboot-0.3.8.4-gentoo.patch
@@ -9,3 +9,85 @@
TARGETS = ext2load
+diff -u -r e2fslib/et/Makefile e2fslib/et/Makefile
+--- e2fslib/et/Makefile 2002-02-03 22:53:44.000000000 +0000
++++ e2fslib/et/Makefile 2004-08-14 06:24:59.000000000 +0000
+@@ -44,7 +44,7 @@
+ CC = cc
+ BUILD_CC = cc
+ DEFS = -DENABLE_SWAPFS=1 -DPACKAGE=\"e2fsprogs\" -DVERSION=\"1.25\" -DSTDC_HEADERS=1 -DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -DHAVE_UNISTD_H=1 -DHAVE_GETPAGESIZE=1 -DHAVE_MMAP=1 -DHAVE_ARGZ_H=1 -DHAVE_LIMITS_H=1 -DHAVE_LOCALE_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_STRING_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_GETCWD=1 -DHAVE_MUNMAP=1 -DHAVE_PUTENV=1 -DHAVE_SETENV=1 -DHAVE_SETLOCALE=1 -DHAVE_STRCHR=1 -DHAVE_STRCASECMP=1 -DHAVE_STRDUP=1 -DHAVE___ARGZ_COUNT=1 -DHAVE___ARGZ_STRINGIFY=1 -DHAVE___ARGZ_NEXT=1 -DHAVE_STPCPY=1 -DHAVE_STPCPY=1 -DHAVE_LC_MESSAGES=1 -DHAVE_STDLIB_H=1 -DHAVE_UNISTD_H=1 -DHAVE_STDARG_H=1 -DHAVE_ERRNO_H=1 -DHAVE_MALLOC_H=1 -DHAVE_MNTENT_H=1 -DHAVE_PATHS_H=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_SETJMP_H=1 -DHAVE_SIGNAL_H=1 -DHAVE_TERMIOS_H=1 -DHAVE_LINUX_FD_H=1 -DHAVE_LINUX_MAJOR_H=1 -DHAVE_SYS_IOCTL_H=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_SYS_SYSMACROS_H=1 -DHAVE_SYS_TIME_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_NET_IF_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_VPRINTF=1 -DHAVE_LSEEK64_PROTOTYPE=1 -DSIZEOF_SHORT=2 -DSIZEOF_INT=4 -DSIZEOF_LONG=4 -DSIZEOF_LONG_LONG=8 -DWORDS_BIGENDIAN=1 -DHAVE_GETRUSAGE=1 -DHAVE_LLSEEK=1 -DHAVE_LSEEK64=1 -DHAVE_OPEN64=1 -DHAVE_STRCASECMP=1 -DHAVE_SRANDOM=1 -DHAVE_FCHOWN=1 -DHAVE_MALLINFO=1 -DHAVE_FDATASYNC=1 -DHAVE_STRNLEN=1 -DHAVE_EXT2_IOCTLS=1
+-CFLAGS = -g -O2
++CFLAGS = -O2
+ CPPFLAGS =
+ ALL_CFLAGS = $(CPPFLAGS) $(DEFS) $(USE_WFLAGS) $(CFLAGS) $(XTRA_CFLAGS) \
+ -I$(top_builddir)/lib -I$(top_srcdir)/lib \
+diff -u -r e2fslib/fileio.c e2fslib/fileio.c
+--- e2fslib/fileio.c 2002-02-03 22:53:42.000000000 +0000
++++ e2fslib/fileio.c 2004-08-16 10:52:33.000000000 +0000
+@@ -226,7 +226,14 @@
+ ptr += c;
+ count += c;
+ wanted -= c;
++
++ /* Show only if we load more than a couple of blocks */
++ if (wanted>4*fs->blocksize) {
++ printf("0x%lx\r", count);
++ }
++
+ }
++ printf("\n\r");
+
+ fail:
+ if (got)
+diff -u -r e2fslib/Makefile e2fslib/Makefile
+--- e2fslib/Makefile 2002-02-03 22:53:42.000000000 +0000
++++ e2fslib/Makefile 2004-08-14 06:24:59.000000000 +0000
+@@ -38,7 +38,7 @@
+ CC = cc
+ BUILD_CC = cc
+ DEFS = -DENABLE_SWAPFS=1 -DPACKAGE=\"e2fsprogs\" -DVERSION=\"1.25\" -DSTDC_HEADERS=1 -DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -DHAVE_UNISTD_H=1 -DHAVE_GETPAGESIZE=1 -DHAVE_MMAP=1 -DHAVE_ARGZ_H=1 -DHAVE_LIMITS_H=1 -DHAVE_LOCALE_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_STRING_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_GETCWD=1 -DHAVE_MUNMAP=1 -DHAVE_PUTENV=1 -DHAVE_SETENV=1 -DHAVE_SETLOCALE=1 -DHAVE_STRCHR=1 -DHAVE_STRCASECMP=1 -DHAVE_STRDUP=1 -DHAVE___ARGZ_COUNT=1 -DHAVE___ARGZ_STRINGIFY=1 -DHAVE___ARGZ_NEXT=1 -DHAVE_STPCPY=1 -DHAVE_STPCPY=1 -DHAVE_LC_MESSAGES=1 -DHAVE_STDLIB_H=1 -DHAVE_UNISTD_H=1 -DHAVE_STDARG_H=1 -DHAVE_ERRNO_H=1 -DHAVE_MALLOC_H=1 -DHAVE_MNTENT_H=1 -DHAVE_PATHS_H=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_SETJMP_H=1 -DHAVE_SIGNAL_H=1 -DHAVE_TERMIOS_H=1 -DHAVE_LINUX_FD_H=1 -DHAVE_LINUX_MAJOR_H=1 -DHAVE_SYS_IOCTL_H=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_SYS_SYSMACROS_H=1 -DHAVE_SYS_TIME_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_NET_IF_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_VPRINTF=1 -DHAVE_LSEEK64_PROTOTYPE=1 -DSIZEOF_SHORT=2 -DSIZEOF_INT=4 -DSIZEOF_LONG=4 -DSIZEOF_LONG_LONG=8 -DWORDS_BIGENDIAN=1 -DHAVE_GETRUSAGE=1 -DHAVE_LLSEEK=1 -DHAVE_LSEEK64=1 -DHAVE_OPEN64=1 -DHAVE_STRCASECMP=1 -DHAVE_SRANDOM=1 -DHAVE_FCHOWN=1 -DHAVE_MALLINFO=1 -DHAVE_FDATASYNC=1 -DHAVE_STRNLEN=1 -DHAVE_EXT2_IOCTLS=1
+-CFLAGS = -g -O -G 0 -fno-pic -mno-abicalls
++CFLAGS = -O -G 0 -fno-pic -mno-abicalls
+ CPPFLAGS =
+ ALL_CFLAGS = $(CPPFLAGS) $(DEFS) $(USE_WFLAGS) $(CFLAGS) $(XTRA_CFLAGS) \
+ -I. $(LINUX_INCLUDE)
+diff -u -r e2fslib/MCONFIG e2fslib/MCONFIG
+--- e2fslib/MCONFIG 2002-02-03 22:53:42.000000000 +0000
++++ e2fslib/MCONFIG 2004-08-14 06:24:59.000000000 +0000
+@@ -30,7 +30,7 @@
+ CC = cc
+ BUILD_CC = cc
+ DEFS = -DENABLE_SWAPFS=1 -DPACKAGE=\"e2fsprogs\" -DVERSION=\"1.25\" -DSTDC_HEADERS=1 -DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -DHAVE_UNISTD_H=1 -DHAVE_GETPAGESIZE=1 -DHAVE_MMAP=1 -DHAVE_ARGZ_H=1 -DHAVE_LIMITS_H=1 -DHAVE_LOCALE_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_STRING_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_GETCWD=1 -DHAVE_MUNMAP=1 -DHAVE_PUTENV=1 -DHAVE_SETENV=1 -DHAVE_SETLOCALE=1 -DHAVE_STRCHR=1 -DHAVE_STRCASECMP=1 -DHAVE_STRDUP=1 -DHAVE___ARGZ_COUNT=1 -DHAVE___ARGZ_STRINGIFY=1 -DHAVE___ARGZ_NEXT=1 -DHAVE_STPCPY=1 -DHAVE_STPCPY=1 -DHAVE_LC_MESSAGES=1 -DHAVE_STDLIB_H=1 -DHAVE_UNISTD_H=1 -DHAVE_STDARG_H=1 -DHAVE_ERRNO_H=1 -DHAVE_MALLOC_H=1 -DHAVE_MNTENT_H=1 -DHAVE_PATHS_H=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_SETJMP_H=1 -DHAVE_SIGNAL_H=1 -DHAVE_TERMIOS_H=1 -DHAVE_LINUX_FD_H=1 -DHAVE_LINUX_MAJOR_H=1 -DHAVE_SYS_IOCTL_H=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_SYS_SYSMACROS_H=1 -DHAVE_SYS_TIME_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_NET_IF_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_VPRINTF=1 -DHAVE_LSEEK64_PROTOTYPE=1 -DSIZEOF_SHORT=2 -DSIZEOF_INT=4 -DSIZEOF_LONG=4 -DSIZEOF_LONG_LONG=8 -DWORDS_BIGENDIAN=1 -DHAVE_GETRUSAGE=1 -DHAVE_LLSEEK=1 -DHAVE_LSEEK64=1 -DHAVE_OPEN64=1 -DHAVE_STRCASECMP=1 -DHAVE_SRANDOM=1 -DHAVE_FCHOWN=1 -DHAVE_MALLINFO=1 -DHAVE_FDATASYNC=1 -DHAVE_STRNLEN=1 -DHAVE_EXT2_IOCTLS=1
+-CFLAGS = -g -O2
++CFLAGS = -O2
+ CPPFLAGS =
+ ALL_CFLAGS = $(CPPFLAGS) $(DEFS) $(USE_WFLAGS) $(CFLAGS) $(XTRA_CFLAGS) \
+ -I$(top_builddir)/lib -I$(top_srcdir)/lib \
+diff -u -r e2fslib/util/Makefile e2fslib/util/Makefile
+--- e2fslib/util/Makefile 2002-02-03 22:53:44.000000000 +0000
++++ e2fslib/util/Makefile 2004-08-14 06:24:59.000000000 +0000
+@@ -44,7 +44,7 @@
+ CC = cc
+ BUILD_CC = cc
+ DEFS = -DENABLE_SWAPFS=1 -DPACKAGE=\"e2fsprogs\" -DVERSION=\"1.25\" -DSTDC_HEADERS=1 -DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -DHAVE_UNISTD_H=1 -DHAVE_GETPAGESIZE=1 -DHAVE_MMAP=1 -DHAVE_ARGZ_H=1 -DHAVE_LIMITS_H=1 -DHAVE_LOCALE_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_STRING_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_GETCWD=1 -DHAVE_MUNMAP=1 -DHAVE_PUTENV=1 -DHAVE_SETENV=1 -DHAVE_SETLOCALE=1 -DHAVE_STRCHR=1 -DHAVE_STRCASECMP=1 -DHAVE_STRDUP=1 -DHAVE___ARGZ_COUNT=1 -DHAVE___ARGZ_STRINGIFY=1 -DHAVE___ARGZ_NEXT=1 -DHAVE_STPCPY=1 -DHAVE_STPCPY=1 -DHAVE_LC_MESSAGES=1 -DHAVE_STDLIB_H=1 -DHAVE_UNISTD_H=1 -DHAVE_STDARG_H=1 -DHAVE_ERRNO_H=1 -DHAVE_MALLOC_H=1 -DHAVE_MNTENT_H=1 -DHAVE_PATHS_H=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_SETJMP_H=1 -DHAVE_SIGNAL_H=1 -DHAVE_TERMIOS_H=1 -DHAVE_LINUX_FD_H=1 -DHAVE_LINUX_MAJOR_H=1 -DHAVE_SYS_IOCTL_H=1 -DHAVE_SYS_MOUNT_H=1 -DHAVE_SYS_SYSMACROS_H=1 -DHAVE_SYS_TIME_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_NET_IF_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_VPRINTF=1 -DHAVE_LSEEK64_PROTOTYPE=1 -DSIZEOF_SHORT=2 -DSIZEOF_INT=4 -DSIZEOF_LONG=4 -DSIZEOF_LONG_LONG=8 -DWORDS_BIGENDIAN=1 -DHAVE_GETRUSAGE=1 -DHAVE_LLSEEK=1 -DHAVE_LSEEK64=1 -DHAVE_OPEN64=1 -DHAVE_STRCASECMP=1 -DHAVE_SRANDOM=1 -DHAVE_FCHOWN=1 -DHAVE_MALLINFO=1 -DHAVE_FDATASYNC=1 -DHAVE_STRNLEN=1 -DHAVE_EXT2_IOCTLS=1
+-CFLAGS = -g -O2
++CFLAGS = -O2
+ CPPFLAGS =
+ ALL_CFLAGS = $(CPPFLAGS) $(DEFS) $(USE_WFLAGS) $(CFLAGS) $(XTRA_CFLAGS) \
+ -I$(top_builddir)/lib -I$(top_srcdir)/lib \
+diff -u -r ext2load/loader.c ext2load/loader.c
+--- ext2load/loader.c 2004-03-01 11:31:15.000000000 +0000
++++ ext2load/loader.c 2004-08-16 09:14:40.000000000 +0000
+@@ -193,6 +193,11 @@
+ size = (size_t) (header->header64.e_phentsize *
+ header->header64.e_phnum);
+
++ if (header->e_ident[EI_CLASS] == ELFCLASS32)
++ printf("Header says 32-bit\n\r");
++ else
++ printf("Header says 64-bit\n\r");
++
+ if (size <= 0)
+ Fatal("No program segments\n\r");
+
+
diff --git a/sys-boot/arcboot/files/digest-arcboot-0.3.8.4 b/sys-boot/arcboot/files/digest-arcboot-0.3.8.4-r1
index 1ac02a74fb00..1ac02a74fb00 100644
--- a/sys-boot/arcboot/files/digest-arcboot-0.3.8.4
+++ b/sys-boot/arcboot/files/digest-arcboot-0.3.8.4-r1