summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2010-07-24 15:39:17 +0000
committerRaúl Porcel <armin76@gentoo.org>2010-07-24 15:39:17 +0000
commitc480eefdff560a19a8101535fa419350a084d2c6 (patch)
treed10d6e5d4b0f8ce639f717ce3fdcd3bcfe3221ab /sys-boot
parentAdd missing 'emake -j1' for install, as per bug #277644. (diff)
downloadgentoo-2-c480eefdff560a19a8101535fa419350a084d2c6.tar.gz
gentoo-2-c480eefdff560a19a8101535fa419350a084d2c6.tar.bz2
gentoo-2-c480eefdff560a19a8101535fa419350a084d2c6.zip
ia64 stable
(Portage version: 2.1.8.3/cvs/Linux ia64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/elilo/ChangeLog6
-rw-r--r--sys-boot/elilo/elilo-3.12.ebuild4
-rw-r--r--sys-boot/elilo/elilo-3.8.ebuild74
3 files changed, 7 insertions, 77 deletions
diff --git a/sys-boot/elilo/ChangeLog b/sys-boot/elilo/ChangeLog
index 4c888beca9a3..2a7cc735ecd8 100644
--- a/sys-boot/elilo/ChangeLog
+++ b/sys-boot/elilo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/elilo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.24 2010/01/10 16:37:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.25 2010/07/24 15:39:17 armin76 Exp $
+
+ 24 Jul 2010; Raúl Porcel <armin76@gentoo.org> -elilo-3.8.ebuild,
+ elilo-3.12.ebuild:
+ ia64 stable
*elilo-3.12 (10 Jan 2010)
diff --git a/sys-boot/elilo/elilo-3.12.ebuild b/sys-boot/elilo/elilo-3.12.ebuild
index 536601d6d27f..73fa8db8ed45 100644
--- a/sys-boot/elilo/elilo-3.12.ebuild
+++ b/sys-boot/elilo/elilo-3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.12.ebuild,v 1.1 2010/01/10 16:37:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.12.ebuild,v 1.2 2010/07/24 15:39:17 armin76 Exp $
inherit toolchain-funcs eutils
@@ -11,7 +11,7 @@ SRC_URI="${SRC_URI} mirror://debian/pool/main/e/elilo/elilo_3.12-1.diff.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ia64 ~x86 ~amd64"
+KEYWORDS="~amd64 ia64 ~x86"
IUSE=""
# gnu-efi contains only static libs, so there's no run-time dep on it
diff --git a/sys-boot/elilo/elilo-3.8.ebuild b/sys-boot/elilo/elilo-3.8.ebuild
deleted file mode 100644
index d21121f5e990..000000000000
--- a/sys-boot/elilo/elilo-3.8.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.8.ebuild,v 1.3 2009/05/06 18:36:06 maekke Exp $
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
-HOMEPAGE="http://elilo.sourceforge.net/"
-SRC_URI="mirror://sourceforge/elilo/${P}.tar.gz"
-SRC_URI="${SRC_URI} mirror://debian/pool/main/e/elilo/elilo_3.8-1.diff.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ia64 ~x86 ~amd64"
-IUSE=""
-
-# gnu-efi contains only static libs, so there's no run-time dep on it
-DEPEND=">=sys-boot/gnu-efi-3.0d
- sys-devel/patch
- dev-util/patchutils"
-RDEPEND="sys-boot/efibootmgr
- sys-fs/dosfstools"
-PROVIDE="virtual/bootloader"
-
-S="${WORKDIR}/${PN}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- ebegin Applying ../*.diff
- # Using epatch on this is annoying because it wants to create the elilo-3.6/
- # directory. Since all the files are new, it doesn't know better.
- filterdiff -p1 -i debian/\* ../*.diff | patch -s -p1
- eend $? || return
-
- # Now Gentooize it
- sed -i "
- 1s:/bin/sh:/bin/bash:;
- s/##VERSION##/$PV/;
- s/Debian GNU\//Gentoo /g;
- s/Debian/Gentoo/g;
- s/debian/gentoo/g;
- s/dpkg --print-installation-architecture/uname -m/" debian/elilo.sh
-}
-
-src_compile() {
- local iarch
- case $(tc-arch) in
- ia64) iarch=ia64 ;;
- x86) iarch=ia32 ;;
- amd64) iarch=x86_64 ;;
- *) die "unknown architecture: $(tc-arch)" ;;
- esac
-
- # "prefix" on the next line specifies where to find gcc, as, ld,
- # etc. It's not the usual meaning of "prefix". By blanking it we
- # allow PATH to be searched.
- emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
-}
-
-src_install() {
- exeinto /usr/lib/elilo
- doexe elilo.efi || die "elilo.efi failed"
-
- newsbin debian/elilo.sh elilo || die "elilo failed"
- dosbin tools/eliloalt || die "eliloalt failed"
-
- insinto /etc
- newins "${FILESDIR}"/elilo.conf.sample elilo.conf
-
- dodoc docs/* "${FILESDIR}"/elilo.conf.sample
- doman debian/*.[0-9]
-}