summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2011-04-16 15:32:21 +0000
committerJonathan Callen <abcd@gentoo.org>2011-04-16 15:32:21 +0000
commitc473c178f8fbf12cd7a94cc04efeef20f6b60bfe (patch)
tree4c4fd4858fe0553a46e3eee1dbd5257efdbc851b /sys-boot
parentAdding myself as maintainer (diff)
downloadgentoo-2-c473c178f8fbf12cd7a94cc04efeef20f6b60bfe.tar.gz
gentoo-2-c473c178f8fbf12cd7a94cc04efeef20f6b60bfe.tar.bz2
gentoo-2-c473c178f8fbf12cd7a94cc04efeef20f6b60bfe.zip
Version bump, bump EAPI
(Portage version: 2.2.0_alpha29_p11/cvs/Linux i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/os-prober/ChangeLog9
-rw-r--r--sys-boot/os-prober/os-prober-1.44.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/sys-boot/os-prober/ChangeLog b/sys-boot/os-prober/ChangeLog
index b24b771b26bb..4fd7e8402846 100644
--- a/sys-boot/os-prober/ChangeLog
+++ b/sys-boot/os-prober/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/os-prober
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.5 2010/07/26 11:00:51 lxnay Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.6 2011/04/16 15:32:21 abcd Exp $
+
+*os-prober-1.44 (16 Apr 2011)
+
+ 16 Apr 2011; Jonathan Callen <abcd@gentoo.org> +os-prober-1.44.ebuild:
+ Version bump, bump EAPI
*os-prober-1.39 (26 Jul 2010)
diff --git a/sys-boot/os-prober/os-prober-1.44.ebuild b/sys-boot/os-prober/os-prober-1.44.ebuild
new file mode 100644
index 000000000000..445d0a21f2e4
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.44.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/os-prober-1.44.ebuild,v 1.1 2011/04/16 15:32:21 abcd Exp $
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e "s:/lib/udev:/$(get_libdir)/udev:g" common.sh || die "sed failed on common.sh"
+ find "${S}" -type f -exec sed -i -e "s:/usr/lib/:/usr/libexec/:g" {} + || die "failed on find and sed lib->libexec"
+ sed -i -e "s:/lib/ld\*\.so\*:/lib*/ld*.so*:g" os-probes/mounted/common/90linux-distro || die "sed failed on 90linux-distro"
+
+ # Just use the default rules provided by GNU Make
+ rm Makefile
+}
+
+src_compile() {
+ tc-export CC
+ emake newns
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober
+
+ exeinto /usr/libexec/os-prober
+ doexe newns
+
+ insinto /usr/share/os-prober
+ doins common.sh
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/libexec/$dir
+ doexe $dir/common/*
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/*
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/libexec/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx
+ fi
+
+ dodoc README TODO debian/changelog
+}
+
+pkg_postinst() {
+ elog "If you intend for os-prober to detect versions of Windows installed on"
+ elog "NTFS-formatted partitions, your system must be capable of reading the"
+ elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}