summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-04-28 22:03:26 +0000
committerUlrich Müller <ulm@gentoo.org>2007-04-28 22:03:26 +0000
commita30faa117370024d690770ff36881e57c071d4a6 (patch)
tree5101686b991159667408e84cc0e75532244ea4b5 /sys-boot
parentFix emerging with JAVA_PKG_STRICT and migrate to splitted ant. (diff)
downloadgentoo-2-a30faa117370024d690770ff36881e57c071d4a6.tar.gz
gentoo-2-a30faa117370024d690770ff36881e57c071d4a6.tar.bz2
gentoo-2-a30faa117370024d690770ff36881e57c071d4a6.zip
Introduced device-mapper local USE flag.
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/ChangeLog9
-rw-r--r--sys-boot/lilo/files/digest-lilo-22.8-r16
-rw-r--r--sys-boot/lilo/files/lilo-22.8-nodevmapper.patch13
-rw-r--r--sys-boot/lilo/lilo-22.8-r1.ebuild183
4 files changed, 210 insertions, 1 deletions
diff --git a/sys-boot/lilo/ChangeLog b/sys-boot/lilo/ChangeLog
index ee09c50ddc92..2ca5869193fa 100644
--- a/sys-boot/lilo/ChangeLog
+++ b/sys-boot/lilo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/lilo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.49 2007/04/21 20:54:56 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.50 2007/04/28 22:03:26 ulm Exp $
+
+*lilo-22.8-r1 (28 Apr 2007)
+
+ 28 Apr 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/lilo-22.8-nodevmapper.patch, +lilo-22.8-r1.ebuild:
+ Don't detect libdevmapper automatically but control via new USE flag
+ device-mapper. Resolves bug #172167.
21 Apr 2007; Tony Vroon <chainsaw@gentoo.org> lilo-22.7.3-r1.ebuild,
lilo-22.8.ebuild:
diff --git a/sys-boot/lilo/files/digest-lilo-22.8-r1 b/sys-boot/lilo/files/digest-lilo-22.8-r1
new file mode 100644
index 000000000000..84eb7c6deec8
--- /dev/null
+++ b/sys-boot/lilo/files/digest-lilo-22.8-r1
@@ -0,0 +1,6 @@
+MD5 08243e46598d6f457e8e4135f1fa8d52 dolilo-0.4.tar.bz2 3753
+RMD160 e63d7d258461346620d012d8e89b22b3f969b089 dolilo-0.4.tar.bz2 3753
+SHA256 812f7cb7a9c93eade7afaa8f12955723c4bdaede1c61f90162390dedfc37bd2e dolilo-0.4.tar.bz2 3753
+MD5 72765f2aafd20e23ecf07ebd22baeec7 lilo-22.8.src.tar.gz 437555
+RMD160 b452f4821cbc917b29cf168587652a6f1efd33e1 lilo-22.8.src.tar.gz 437555
+SHA256 bad5907c212c0b2b15de5e852787a1ad2129a702f113b26345eec1c917c4edcb lilo-22.8.src.tar.gz 437555
diff --git a/sys-boot/lilo/files/lilo-22.8-nodevmapper.patch b/sys-boot/lilo/files/lilo-22.8-nodevmapper.patch
new file mode 100644
index 000000000000..f81cbfe92ef5
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-22.8-nodevmapper.patch
@@ -0,0 +1,13 @@
+--- Makefile~ 2007-04-28 22:04:23.000000000 +0200
++++ Makefile 2007-04-28 22:21:46.000000000 +0200
+@@ -91,8 +91,8 @@
+ sed 's/-D/-DLCF_/g'`
+ LILO=-DLILO=0xbb920890
+ KVER=`if [ -f /usr/include/linux/version.h ]; then echo -DHAS_VERSION_H; fi`
+-HDM=`if [ -f /usr/include/libdevmapper.h ]; then echo -DHAS_LIBDEVMAPPER_H; fi`
+-DEVMAPPER=`if [ -f /usr/include/libdevmapper.h ]; then echo "-ldevmapper"; fi`
++HDM=
++DEVMAPPER=
+
+ TMP=_TmP_
+
diff --git a/sys-boot/lilo/lilo-22.8-r1.ebuild b/sys-boot/lilo/lilo-22.8-r1.ebuild
new file mode 100644
index 000000000000..7ddac71cc628
--- /dev/null
+++ b/sys-boot/lilo/lilo-22.8-r1.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.8-r1.ebuild,v 1.1 2007/04/28 22:03:26 ulm Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DOLILO_V="0.4"
+IUSE="static minimal pxeserial device-mapper"
+
+DESCRIPTION="Standard Linux boot loader"
+HOMEPAGE="http://lilo.go.dyndns.org/pub/linux/lilo/"
+DOLILO_TAR="dolilo-${DOLILO_V}.tar.bz2"
+MY_P=${P}.src
+
+SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/${MY_P}.tar.gz
+ ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${MY_P}.tar.gz
+ ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/obsolete/${MY_P}.tar.gz
+ mirror://gentoo/${DOLILO_TAR}"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="-* ~x86 ~amd64"
+
+DEPEND=">=sys-devel/bin86-0.15.5
+ device-mapper? ( >=sys-fs/device-mapper-1.02.12 )"
+
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd ${S}
+
+ # Correctly document commandline options -v and -V, bug #43554
+ epatch ${FILESDIR}/${P}-correct-usage-info.patch
+ # Install manpages to correct location, do not rely on incorrect manpath output, bug #117135
+ # Do not strip the main binary, it upsets portage, bug #140210
+ # Do not install diag1.img, bug #149887
+ epatch ${FILESDIR}/${P}-makefile.patch
+
+ # this patch is needed when booting PXE and the device you're using
+ # emulates vga console via serial console.
+ # IE.. B.B.o.o.o.o.t.t.i.i.n.n.g.g....l.l.i.i.n.n.u.u.x.x and stair stepping.
+ use pxeserial && epatch ${FILESDIR}/${P}-novga.patch
+ use device-mapper || epatch ${FILESDIR}/${P}-nodevmapper.patch
+
+ unpack ${DOLILO_TAR}
+}
+
+src_compile() {
+ # lilo needs this. bug 140209
+ export LC_ALL=C
+
+ # hardened automatic PIC plus PIE building should be suppressed
+ # because of assembler instructions that cannot be compiled PIC
+ HARDENED_CFLAGS="`test-flags-CC -fno-pic -nopie`"
+
+ # we explicitly prevent the custom CFLAGS for stability reasons
+ if use static; then
+ emake CC="$(tc-getCC) ${HARDENED_CFLAGS}" lilo.static || die
+ mv lilo.static lilo || die
+ else
+ emake CC="$(tc-getCC) ${HARDENED_CFLAGS}" lilo || die
+ fi
+}
+
+src_install() {
+ keepdir /boot
+ make ROOT=${D} install || die
+
+ if use !minimal; then
+ into /
+ dosbin ${S}/dolilo/dolilo
+
+ into /usr
+ dosbin keytab-lilo.pl
+
+ insinto /etc
+ newins ${FILESDIR}/lilo.conf lilo.conf.example
+
+ newconfd ${S}/dolilo/dolilo.conf.d dolilo.example
+
+ doman manPages/*.[5-8]
+ dodoc CHANGES COPYING INCOMPAT README*
+ docinto samples ; dodoc sample/*
+ fi
+}
+
+# Check whether LILO is installed
+# This function is from /usr/sbin/mkboot from debianutils, with copyright:
+#
+# Debian GNU/Linux
+# Copyright 1996-1997 Guy Maor <maor@debian.org>
+#
+# Modified for Gentoo for use with the lilo ebuild by:
+# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
+#
+lilocheck () {
+ local bootpart=
+ local rootpart="$(mount | grep -v "tmpfs" | grep -v "rootfs" | grep "on / " | cut -f1 -d " ")"
+
+ echo
+ einfon "Checking for LILO ..."
+
+ if [ "$(whoami)" != "root" ]
+ then
+ echo; echo
+ eerror "Only root can check for LILO!"
+ return 1
+ fi
+
+ if [ -z "${rootpart}" ]
+ then
+ echo; echo
+ eerror "Could not determine root partition!"
+ return 1
+ fi
+
+ if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
+ then
+ echo " No"
+ return 1
+ fi
+
+ bootpart="$(sed -n "s:^boot[ ]*=[ ]*\(.*\)[ ]*:\1:p" /etc/lilo.conf)"
+
+ if [ -z "${bootpart}" ]
+ then
+ # lilo defaults to current root when 'boot=' is not present
+ bootpart="${rootpart}"
+ fi
+
+ if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
+ then
+ echo; echo
+ ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
+ ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
+ return 1
+ fi
+
+ echo " Yes, on ${bootpart}"
+
+ return 0
+}
+
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
+ then
+ [ -f "${ROOT}/boot/boot-menu.b" ] && \
+ ln -snf boot-menu.b ${ROOT}/boot/boot.b
+ fi
+
+ if [ "${ROOT}" = "/" ] && use !minimal;
+ then
+ if lilocheck
+ then
+ einfo "Running DOLILO to complete the install ..."
+ # do not redirect to /dev/null because it may display some input
+ # prompt
+ /sbin/dolilo
+ if [ "$?" -ne 0 ]
+ then
+ echo
+ ewarn "Running /sbin/dolilo failed! Please check what the problem is"
+ ewarn "before your next reboot."
+
+ ebeep 5
+ epause 5
+ fi
+ fi
+ echo
+ fi
+ if use !minimal; then
+ echo
+ einfo "Issue 'dolilo' instead of 'lilo' to have a friendly wrapper that"
+ einfo "handles mounting and unmounting /boot for you. It can do more then"
+ einfo "that when asked, edit /etc/conf.d/dolilo to harness it's full potential."
+ ebeep 5
+ epause 3
+ echo
+ fi
+}