summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-02-18 21:52:04 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-02-18 21:52:04 +0000
commit9a46671aeacc1ee35e7aabb134253b84e7423cd3 (patch)
tree05c4a98e64e22330807a112af6bda84879fcebd4 /sys-boot
parentmask prerelease versions of syslinux (diff)
downloadgentoo-2-9a46671aeacc1ee35e7aabb134253b84e7423cd3.tar.gz
gentoo-2-9a46671aeacc1ee35e7aabb134253b84e7423cd3.tar.bz2
gentoo-2-9a46671aeacc1ee35e7aabb134253b84e7423cd3.zip
syslinux-4.00_pre24 version bump
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog9
-rw-r--r--sys-boot/syslinux/files/syslinux-4.00-nopie.patch12
-rw-r--r--sys-boot/syslinux/syslinux-3.84.ebuild4
-rw-r--r--sys-boot/syslinux/syslinux-4.00_pre24.ebuild60
4 files changed, 81 insertions, 4 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index df04c7dec054..bd7d84ae7830 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.52 2010/02/18 18:27:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.53 2010/02/18 21:52:04 chithanh Exp $
+
+*syslinux-4.00_pre24 (18 Feb 2010)
+
+ 18 Feb 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ syslinux-3.84.ebuild, +syslinux-4.00_pre24.ebuild,
+ +files/syslinux-4.00-nopie.patch:
+ version bump, drop nostrip patches (bug #305783)
18 Feb 2010; Jeroen Roovers <jer@gentoo.org> syslinux-3.84.ebuild:
Switch to IUSE=custom-cflags (bug #305783).
diff --git a/sys-boot/syslinux/files/syslinux-4.00-nopie.patch b/sys-boot/syslinux/files/syslinux-4.00-nopie.patch
new file mode 100644
index 000000000000..1db5d1d882fd
--- /dev/null
+++ b/sys-boot/syslinux/files/syslinux-4.00-nopie.patch
@@ -0,0 +1,12 @@
+diff -ur a/com32/MCONFIG b/com32/MCONFIG
+--- a/com32/MCONFIG 2010-02-16 23:53:51.000000000 +0100
++++ b/com32/MCONFIG 2010-02-18 22:28:18.791609195 +0100
+@@ -24,6 +24,8 @@
+ GCCOPT += $(call gcc_ok,-freg-struct-return,)
+ GCCOPT += -mregparm=3 -DREGPARM=3 -march=i386 -Os
+ GCCOPT += $(call gcc_ok,-fPIE,-fPIC)
++GCCOPT += $(call gcc_ok,-nopie,)
++GCCOPT += $(call gcc_ok,-fno-pie,)
+ GCCOPT += $(call gcc_ok,-fno-exceptions,)
+ GCCOPT += $(call gcc_ok,-fno-asynchronous-unwind-tables,)
+ GCCOPT += $(call gcc_ok,-fno-strict-aliasing,)
diff --git a/sys-boot/syslinux/syslinux-3.84.ebuild b/sys-boot/syslinux/syslinux-3.84.ebuild
index 229e601d55d8..3341a47d1346 100644
--- a/sys-boot/syslinux/syslinux-3.84.ebuild
+++ b/sys-boot/syslinux/syslinux-3.84.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.84.ebuild,v 1.3 2010/02/18 18:27:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.84.ebuild,v 1.4 2010/02/18 21:52:04 chithanh Exp $
inherit eutils toolchain-funcs
@@ -29,8 +29,6 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-3.72-nopie.patch
- # Don't prestrip, makes portage angry
- epatch "${FILESDIR}"/${PN}-3.72-nostrip.patch
rm -f gethostip #bug 137081
diff --git a/sys-boot/syslinux/syslinux-4.00_pre24.ebuild b/sys-boot/syslinux/syslinux-4.00_pre24.ebuild
new file mode 100644
index 000000000000..2f2b67f173d3
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-4.00_pre24.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-4.00_pre24.ebuild,v 1.1 2010/02/18 21:52:04 chithanh Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/Testing/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="custom-cflags"
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+S=${WORKDIR}/${P/_/-}
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix building on hardened
+ epatch "${FILESDIR}"/${PN}-4.00-nopie.patch
+
+ rm -f gethostip #bug 137081
+
+ # Don't prestrip or override user LDFLAGS, bug #305783
+ local SYSLINUX_MAKEFILES="extlinux/Makefile linux/Makefile mtools/Makefile \
+ sample/Makefile utils/Makefile"
+ sed -i ${SYSLINUX_MAKEFILES} -e '/^LDFLAGS/d' || die "sed failed"
+
+ if use custom-cflags; then
+ sed -i ${SYSLINUX_MAKEFILES} \
+ -e 's|-g -Os||g' \
+ -e 's|-Os||g' \
+ -e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
+ || die "sed custom-cflags failed"
+ fi
+
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) installer || die
+}
+
+src_install() {
+ emake INSTALLSUBDIRS=utils INSTALLROOT="${D}" MANDIR=/usr/share/man install || die
+ dodoc README NEWS doc/* || die
+}