summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-02-29 01:52:23 +0000
committerMike Gilbert <floppym@gentoo.org>2012-02-29 01:52:23 +0000
commit952812dcdc2025b31612a218749e0012fdcfb686 (patch)
tree3e1698c52ace21cc21835a8ba838bbcf6d5d69ae /sys-boot
parentStable for HPPA (bug #406037). (diff)
downloadgentoo-2-952812dcdc2025b31612a218749e0012fdcfb686.tar.gz
gentoo-2-952812dcdc2025b31612a218749e0012fdcfb686.tar.bz2
gentoo-2-952812dcdc2025b31612a218749e0012fdcfb686.zip
Updates for grub-2.00_beta0 release.
* Move binaries to /usr. * If GRUB_PLATFORMS is set, install binaries as grub2-${platform}-foo. * Add mount and libzfs USE flags. * Drop pkg_config. Need to figure out if this is feasible with multiple platforms. (Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog11
-rw-r--r--sys-boot/grub/files/grub.default6
-rw-r--r--sys-boot/grub/grub-2.00_beta0.ebuild258
-rw-r--r--sys-boot/grub/grub-9999.ebuild223
-rw-r--r--sys-boot/grub/metadata.xml13
5 files changed, 360 insertions, 151 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index ffc0df2e9f7c..ab0beed8c5e6 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.177 2012/01/30 09:14:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.178 2012/02/29 01:52:22 floppym Exp $
+
+*grub-2.00_beta0 (29 Feb 2012)
+
+ 29 Feb 2012; Mike Gilbert <floppym@gentoo.org> +grub-2.00_beta0.ebuild,
+ files/grub.default, grub-9999.ebuild, metadata.xml:
+ Updates for grub-2.00_beta0 release. * Move binaries to /usr. * If
+ GRUB_PLATFORMS is set, install binaries as grub2-${platform}-foo. * Add mount
+ and libzfs USE flags. * Drop pkg_config. Need to figure out if this is
+ feasible with multiple platforms.
30 Jan 2012; Tomáš Chvátal <scarabeus@gentoo.org> grub-1.99-r2.ebuild,
grub-9999.ebuild:
diff --git a/sys-boot/grub/files/grub.default b/sys-boot/grub/files/grub.default
index 580d27580fa3..061e4d1b9de7 100644
--- a/sys-boot/grub/files/grub.default
+++ b/sys-boot/grub/files/grub.default
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/files/grub.default,v 1.2 2011/08/30 06:45:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/files/grub.default,v 1.3 2012/02/29 01:52:23 floppym Exp $
#
# To populate all changes in this file you need to regenerate your
# grub configuration file afterwards:
@@ -9,6 +9,8 @@
# See the grub info page for documentation on possible variables and
# their associated values.
+GRUB_DISTRIBUTOR="Gentoo"
+
GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
diff --git a/sys-boot/grub/grub-2.00_beta0.ebuild b/sys-boot/grub/grub-2.00_beta0.ebuild
new file mode 100644
index 000000000000..e71083dbffd2
--- /dev/null
+++ b/sys-boot/grub/grub-2.00_beta0.ebuild
@@ -0,0 +1,258 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00_beta0.ebuild,v 1.1 2012/02/29 01:52:22 floppym Exp $
+
+EAPI=4
+
+if [[ ${PV} == "9999" ]] ; then
+ EBZR_REPO_URI="http://bzr.savannah.gnu.org/r/grub/trunk/grub/"
+ LIVE_ECLASS="bzr"
+ SRC_URI=""
+ DO_AUTORECONF="true"
+else
+ MY_P=${P/_/\~}
+ if [[ ${PV} == *_alpha* || ${PV} == *_beta* ]]; then
+ SRC_URI="http://alpha.gnu.org/gnu/${PN}/${MY_P}.tar.xz"
+ else
+ SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.xz
+ mirror://gentoo/${MY_P}.tar.xz"
+ fi
+ # Masked until documentation guys consolidate the guide and approve
+ # it for usage.
+ #KEYWORDS="~amd64 ~mips ~x86"
+ S=${WORKDIR}/${MY_P}
+fi
+
+inherit eutils flag-o-matic pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
+unset LIVE_ECLASS
+
+DESCRIPTION="GNU GRUB boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+
+LICENSE="GPL-3"
+SLOT="2"
+IUSE="custom-cflags debug device-mapper efiemu mount nls static sdl truetype libzfs"
+
+GRUB_PLATFORMS=(
+ # everywhere:
+ emu
+ # mips only:
+ qemu-mips yeeloong
+ # amd64, x86, ppc, ppc64:
+ ieee1275
+ # amd64, x86:
+ coreboot multiboot efi-32 pc qemu
+ # amd64:
+ efi-64
+)
+IUSE+=" ${GRUB_PLATFORMS[@]/#/grub_platforms_}"
+
+# os-prober: Used on runtime to detect other OSes
+# xorriso (dev-libs/libisoburn): Used on runtime for mkrescue
+RDEPEND="
+ dev-libs/libisoburn
+ dev-libs/lzo
+ sys-boot/os-prober
+ >=sys-libs/ncurses-5.2-r5
+ debug? (
+ sdl? ( media-libs/libsdl )
+ )
+ device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+ libzfs? ( sys-fs/zfs )
+ mount? ( sys-fs/fuse )
+ truetype? ( media-libs/freetype >=media-fonts/unifont-5 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/python-2.5.2
+ sys-devel/flex
+ virtual/yacc
+ sys-apps/texinfo
+"
+if [[ -n ${DO_AUTORECONF} ]] ; then
+ DEPEND+=" >=sys-devel/autogen-5.10 sys-apps/help2man"
+else
+ DEPEND+=" app-arch/xz-utils"
+fi
+
+export STRIP_MASK="*/grub/*/*.{mod,img}"
+
+QA_EXECSTACK="
+ usr/bin/grub*
+ usr/sbin/grub*
+ usr/lib*/grub/*/*.mod
+ usr/lib*/grub/*/kernel.exec
+ usr/lib*/grub/*/kernel.img
+ usr/lib*/grub/*/setjmp.module
+"
+
+QA_WX_LOAD="
+ usr/lib*/grub/*/kernel.exec
+ usr/lib*/grub/*/kernel.img
+ usr/lib*/grub/*/*.image
+"
+
+QA_PRESTRIPPED="
+ usr/lib.*/grub/.*/kernel.img
+"
+
+grub_run_phase() {
+ local phase=$1
+ local platform=$2
+ [[ -z ${phase} || -z ${platform} ]] && die "${FUNCNAME} [phase] [platform]"
+
+ [[ -d "${WORKDIR}/build-${platform}" ]] || \
+ { mkdir "${WORKDIR}/build-${platform}" || die ; }
+ pushd "${WORKDIR}/build-${platform}" > /dev/null || die
+
+ echo ">>> Running ${phase} for platform \"${platform}\""
+ echo ">>> Working in: \"${WORKDIR}/build-${platform}\""
+
+ grub_${phase} ${platform}
+
+ popd > /dev/null || die
+}
+
+grub_src_configure() {
+ local platform=$1
+ local target
+ local transform="grub2"
+ local with_platform
+
+ [[ -z ${platform} ]] && die "${FUNCNAME} [platform]"
+
+ if [[ ${platform} != "guessed" ]]; then
+ transform="grub2-${platform}"
+ fi
+
+ # check if we have to specify the target (EFI)
+ # or just append correct --with-platform
+ if [[ ${platform} == efi* ]]; then
+ # EFI platform hack
+ [[ ${platform/*-} == 32 ]] && target=i386
+ [[ ${platform/*-} == 64 ]] && target=x86_64
+ # program-prefix is required empty because otherwise it is equal to
+ # target variable, which we do not want at all
+ with_platform="
+ --with-platform=${platform/-*}
+ --target=${target}
+ --program-prefix=
+ "
+ elif [[ ${platform} != "guessed" ]]; then
+ with_platform=" --with-platform=${platform}"
+ fi
+
+ ECONF_SOURCE="${S}" \
+ econf \
+ --disable-werror \
+ --program-transform-name="s,grub,${transform}," \
+ --with-grubdir=grub2 \
+ $(use_enable debug mm-debug) \
+ $(use_enable debug grub-emu-usb) \
+ $(use_enable device-mapper) \
+ $(use_enable efiemu) \
+ $(use_enable mount grub-mount) \
+ $(use_enable nls) \
+ $(use_enable truetype grub-mkfont) \
+ $(use_enable libzfs) \
+ $(use sdl && use_enable debug grub-emu-sdl) \
+ ${with_platform}
+}
+
+grub_src_compile() {
+ default_src_compile
+ pax-mark -mpes "${grub_binaries[@]}"
+}
+
+grub_src_install() {
+ default_src_install
+}
+
+src_prepare() {
+ local i j
+
+ epatch_user
+
+ # fix texinfo file name, as otherwise the grub2.info file will be
+ # useless
+ sed -i \
+ -e '/setfilename/s:grub.info:grub2.info:' \
+ -e 's:(grub):(grub2):' \
+ docs/grub.texi
+
+ # autogen.sh does more than just run autotools
+ if [[ -n ${DO_AUTORECONF} ]] ; then
+ sed -i -e '/^autoreconf/s:^:set +e; e:' autogen.sh || die
+ (. ./autogen.sh) || die
+ fi
+
+ # install into the right dir for eselect #372735
+ sed -i \
+ -e '/^bashcompletiondir =/s:=.*:= $(datarootdir)/bash-completion:' \
+ util/bash-completion.d/Makefile.in || die
+
+ # get enabled platforms
+ GRUB_ENABLED_PLATFORMS=""
+ for i in ${GRUB_PLATFORMS[@]}; do
+ use grub_platforms_${i} && GRUB_ENABLED_PLATFORMS+=" ${i}"
+ done
+ [[ -z ${GRUB_ENABLED_PLATFORMS} ]] && GRUB_ENABLED_PLATFORMS="guessed"
+ elog "Going to build following platforms: ${GRUB_ENABLED_PLATFORMS}"
+}
+
+src_configure() {
+ local i
+
+ use custom-cflags || unset CFLAGS CPPFLAGS LDFLAGS
+ use libzfs && addpredict /etc/dfs
+ use static && append-ldflags -static
+
+ for i in ${GRUB_ENABLED_PLATFORMS}; do
+ grub_run_phase ${FUNCNAME} ${i}
+ done
+}
+
+src_compile() {
+ # Used for pax marking in grub_src_compile
+ local grub_binaries=(
+ grub-editenv
+ grub-fstest
+ grub-menulst2cfg
+ grub-mkimage
+ grub-mklayout
+ grub-mkpasswd-pbkdf2
+ grub-mkrelpath
+ grub-script-check
+ grub-bios-setup
+ grub-ofpathname
+ grub-probe
+ grub-sparc64-setup
+ )
+ use mount && grub_binaries+=( grub-mount )
+ use truetype && grub_binaries+=( grub-mkfont )
+
+ local i
+
+ for i in ${GRUB_ENABLED_PLATFORMS}; do
+ grub_run_phase ${FUNCNAME} ${i}
+ done
+}
+
+src_install() {
+ local i
+
+ for i in ${GRUB_ENABLED_PLATFORMS}; do
+ grub_run_phase ${FUNCNAME} ${i}
+ done
+
+ mv "${ED}"usr/share/info/grub{,2}.info || die
+
+ # can't be in docs array as we use default_src_install in different builddir
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ insinto /etc/default
+ newins "${FILESDIR}"/grub.default grub
+}
+
+pkg_postinst() {
+ # display the link to guide
+ elog "For information on how to configure grub-2 please refer to the guide:"
+ elog " http://dev.gentoo.org/~scarabeus/grub-2-guide.xml"
+}
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index c3aaddfe4630..19136334da1a 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.49 2012/01/30 09:14:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.50 2012/02/29 01:52:22 floppym Exp $
EAPI=4
@@ -11,15 +11,19 @@ if [[ ${PV} == "9999" ]] ; then
DO_AUTORECONF="true"
else
MY_P=${P/_/\~}
- SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.xz
+ if [[ ${PV} == *_alpha* || ${PV} == *_beta* ]]; then
+ SRC_URI="http://alpha.gnu.org/gnu/${PN}/${MY_P}.tar.xz"
+ else
+ SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.xz
mirror://gentoo/${MY_P}.tar.xz"
+ fi
# Masked until documentation guys consolidate the guide and approve
# it for usage.
#KEYWORDS="~amd64 ~mips ~x86"
S=${WORKDIR}/${MY_P}
fi
-inherit mount-boot eutils flag-o-matic pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
+inherit eutils flag-o-matic pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
unset LIVE_ECLASS
DESCRIPTION="GNU GRUB boot loader"
@@ -27,7 +31,7 @@ HOMEPAGE="http://www.gnu.org/software/grub/"
LICENSE="GPL-3"
SLOT="2"
-IUSE="custom-cflags debug device-mapper efiemu nls static sdl truetype"
+IUSE="custom-cflags debug device-mapper efiemu mount nls static sdl truetype libzfs"
GRUB_PLATFORMS=(
# everywhere:
@@ -54,6 +58,8 @@ RDEPEND="
sdl? ( media-libs/libsdl )
)
device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+ libzfs? ( sys-fs/zfs )
+ mount? ( sys-fs/fuse )
truetype? ( media-libs/freetype >=media-fonts/unifont-5 )"
DEPEND="${RDEPEND}
>=dev-lang/python-2.5.2
@@ -67,27 +73,25 @@ else
DEPEND+=" app-arch/xz-utils"
fi
-export STRIP_MASK="*/grub*/*/*.{mod,img}"
+export STRIP_MASK="*/grub/*/*.{mod,img}"
+
QA_EXECSTACK="
- lib64/grub2/*/setjmp.mod
- lib64/grub2/*/kernel.img
- sbin/grub2-probe
- sbin/grub2-setup
- sbin/grub2-mkdevicemap
- bin/grub2-script-check
- bin/grub2-fstest
- bin/grub2-mklayout
- bin/grub2-menulst2cfg
- bin/grub2-mkrelpath
- bin/grub2-mkpasswd-pbkdf2
- bin/grub2-mkfont
- bin/grub2-editenv
- bin/grub2-mkimage
+ usr/bin/grub*
+ usr/sbin/grub*
+ usr/lib*/grub/*/*.mod
+ usr/lib*/grub/*/kernel.exec
+ usr/lib*/grub/*/kernel.img
+ usr/lib*/grub/*/setjmp.module
"
QA_WX_LOAD="
- lib*/grub2/*/kernel.img
- lib*/grub2/*/setjmp.mod
+ usr/lib*/grub/*/kernel.exec
+ usr/lib*/grub/*/kernel.img
+ usr/lib*/grub/*/*.image
+"
+
+QA_PRESTRIPPED="
+ usr/lib.*/grub/.*/kernel.img
"
grub_run_phase() {
@@ -110,50 +114,52 @@ grub_run_phase() {
grub_src_configure() {
local platform=$1
local target
+ local transform="grub2"
+ local with_platform
[[ -z ${platform} ]] && die "${FUNCNAME} [platform]"
- # if we have no platform then --with-platform=guessed does not work
- [[ ${platform} == "guessed" ]] && platform=""
+ if [[ ${platform} != "guessed" ]]; then
+ transform="grub2-${platform}"
+ fi
# check if we have to specify the target (EFI)
# or just append correct --with-platform
- if [[ -n ${platform} ]]; then
- if [[ ${platform} == efi* ]]; then
- # EFI platform hack
- [[ ${platform/*-} == 32 ]] && target=i386
- [[ ${platform/*-} == 64 ]] && target=x86_64
- # program-prefix is required empty because otherwise it is equal to
- # target variable, which we do not want at all
- platform="
- --with-platform=${platform/-*}
- --target=${target}
- --program-prefix=
- "
- else
- platform=" --with-platform=${platform}"
- fi
+ if [[ ${platform} == efi* ]]; then
+ # EFI platform hack
+ [[ ${platform/*-} == 32 ]] && target=i386
+ [[ ${platform/*-} == 64 ]] && target=x86_64
+ # program-prefix is required empty because otherwise it is equal to
+ # target variable, which we do not want at all
+ with_platform="
+ --with-platform=${platform/-*}
+ --target=${target}
+ --program-prefix=
+ "
+ elif [[ ${platform} != "guessed" ]]; then
+ with_platform=" --with-platform=${platform}"
fi
- ECONF_SOURCE="${WORKDIR}/${P}/" \
+ ECONF_SOURCE="${S}" \
econf \
--disable-werror \
- --sbindir=/sbin \
- --bindir=/bin \
- --libdir=/$(get_libdir) \
- --program-transform-name=s,grub,grub2, \
+ --program-transform-name="s,grub,${transform}," \
+ --with-grubdir=grub2 \
$(use_enable debug mm-debug) \
$(use_enable debug grub-emu-usb) \
$(use_enable device-mapper) \
$(use_enable efiemu) \
+ $(use_enable mount grub-mount) \
$(use_enable nls) \
$(use_enable truetype grub-mkfont) \
+ $(use_enable libzfs) \
$(use sdl && use_enable debug grub-emu-sdl) \
- ${platform}
+ ${with_platform}
}
grub_src_compile() {
default_src_compile
+ pax-mark -mpes "${grub_binaries[@]}"
}
grub_src_install() {
@@ -161,7 +167,7 @@ grub_src_install() {
}
src_prepare() {
- local i j archs
+ local i j
epatch_user
@@ -170,7 +176,7 @@ src_prepare() {
sed -i \
-e '/setfilename/s:grub.info:grub2.info:' \
-e 's:(grub):(grub2):' \
- "${S}"/docs/grub.texi
+ docs/grub.texi
# autogen.sh does more than just run autotools
if [[ -n ${DO_AUTORECONF} ]] ; then
@@ -196,6 +202,7 @@ src_configure() {
local i
use custom-cflags || unset CFLAGS CPPFLAGS LDFLAGS
+ use libzfs && addpredict /etc/dfs
use static && append-ldflags -static
for i in ${GRUB_ENABLED_PLATFORMS}; do
@@ -204,6 +211,24 @@ src_configure() {
}
src_compile() {
+ # Used for pax marking in grub_src_compile
+ local grub_binaries=(
+ grub-editenv
+ grub-fstest
+ grub-menulst2cfg
+ grub-mkimage
+ grub-mklayout
+ grub-mkpasswd-pbkdf2
+ grub-mkrelpath
+ grub-script-check
+ grub-bios-setup
+ grub-ofpathname
+ grub-probe
+ grub-sparc64-setup
+ )
+ use mount && grub_binaries+=( grub-mount )
+ use truetype && grub_binaries+=( grub-mkfont )
+
local i
for i in ${GRUB_ENABLED_PLATFORMS}; do
@@ -218,114 +243,16 @@ src_install() {
grub_run_phase ${FUNCNAME} ${i}
done
- # No need to move the info file with the live ebuild since we
- # already changed the generated file name during the preparation
- # phase.
- if [[ ${PV} != "9999" ]]; then
- # slot all collisions with grub legacy
- mv "${ED}"/usr/share/info/grub.info \
- "${ED}"/usr/share/info/grub2.info || die
- fi
-
- # Do pax marking
- local PAX=(
- "sbin/grub2-probe"
- "sbin/grub2-setup"
- "sbin/grub2-mkdevicemap"
- "bin/grub2-script-check"
- "bin/grub2-fstest"
- "bin/grub2-mklayout"
- "bin/grub2-menulst2cfg"
- "bin/grub2-mkrelpath"
- "bin/grub2-mkpasswd-pbkdf2"
- "bin/grub2-editenv"
- "bin/grub2-mkimage"
- )
- for e in ${PAX[@]}; do
- pax-mark -mpes "${ED}/${e}"
- done
+ mv "${ED}"usr/share/info/grub{,2}.info || die
# can't be in docs array as we use default_src_install in different builddir
dodoc AUTHORS ChangeLog NEWS README THANKS TODO
insinto /etc/default
newins "${FILESDIR}"/grub.default grub
- cat <<EOF >> "${ED}"/lib*/grub2/grub-mkconfig_lib
- GRUB_DISTRIBUTOR="Gentoo"
-EOF
-
- elog
- elog "To configure GRUB 2, check the defaults in /etc/default/grub and"
- elog "then run 'emerge --config =${CATEGORY}/${PF}'."
-
- # display the link to guide
- show_doc_url
}
-show_doc_url() {
- elog
- elog "For informations how to configure grub-2 please refer to the guide:"
+pkg_postinst() {
+ # display the link to guide
+ elog "For information on how to configure grub-2 please refer to the guide:"
elog " http://dev.gentoo.org/~scarabeus/grub-2-guide.xml"
}
-
-setup_boot_dir() {
- local dir=$1
- local use_legacy='n'
-
- # Make sure target directory exists
- mkdir -p "${dir}"
-
- if [[ -e ${dir/2/}/menu.lst ]] ; then
- # Legacy config exists, ask user what to do
- einfo "Found legacy GRUB configuration. Do you want to convert it"
- einfo "instead of using autoconfig (y/N)?"
- read use_legacy
-
- use_legacy=${use_legacy,,[A-Z]}
- fi
-
- if [[ ${use_legacy} == y* ]] ; then
- grub1_cfg=${dir/2/}/menu.lst
- grub2_cfg=${dir}/grub.cfg
-
- # GRUB legacy configuration exists. Use it instead of doing
- # our normal autoconfigure.
- #
-
- einfo "Converting legacy config at '${grub1_cfg}' for use by GRUB2."
- ebegin "Running: grub2-menulst2cfg '${grub1_cfg}' '${grub2_cfg}'"
- grub2-menulst2cfg "${grub1_cfg}" "${grub2_cfg}" &> /dev/null
- eend $?
-
- ewarn
- ewarn "Even though the conversion above succeeded, you are STRONGLY"
- ewarn "URGED to upgrade to the new GRUB2 configuration format."
-
- # Remind the user about the documentation
- show_doc_url
- else
- # Run GRUB 2 autoconfiguration
- einfo "Running GRUB 2 autoconfiguration."
- ebegin "grub2-mkconfig -o '${dir}/grub.cfg'"
- grub2-mkconfig -o "${dir}/grub.cfg" &> /dev/null
- eend $?
- fi
-
- einfo
- einfo "Remember to run grub2-install to activate GRUB2 as your default"
- einfo "bootloader."
-}
-
-pkg_config() {
- local dir
-
- mount-boot_mount_boot_partition
-
- einfo "Enter the directory where you want to setup grub2 ('${ROOT}boot/grub2/'):"
- read dir
-
- [[ -z ${dir} ]] && dir="${ROOT}"boot/grub2
-
- setup_boot_dir "${dir}"
-
- mount-boot_pkg_postinst
-}
diff --git a/sys-boot/grub/metadata.xml b/sys-boot/grub/metadata.xml
index dca555ea2852..2cf8c3a38a43 100644
--- a/sys-boot/grub/metadata.xml
+++ b/sys-boot/grub/metadata.xml
@@ -2,6 +2,13 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>base-system</herd>
+<maintainer>
+ <email>base-system@gentoo.org</email>
+</maintainer>
+<maintainer restrict="&gt;=sys-boot/grub-2">
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+</maintainer>
<use>
<flag name='device-mapper'>
Enable support for <pkg>sys-fs/device-mapper</pkg>
@@ -9,5 +16,11 @@
<flag name='efiemu'>
Build and install the efiemu runtimes
</flag>
+ <flag name='mount'>
+ Build and install the grub-mount utility
+ </flag>
+ <flag name='libzfs'>
+ Enable support for <pkg>sys-fs/zfs</pkg>
+ </flag>
</use>
</pkgmetadata>