summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2012-08-20 18:54:40 +0000
committerRaúl Porcel <armin76@gentoo.org>2012-08-20 18:54:40 +0000
commit8f6abbd17221db60b9dabf502ef6cd6656efbc2f (patch)
treee69e20a83e987c64e4bb6f4b1a62288310a51a29 /sys-boot
parentStable for x86, wrt bug #429042 (diff)
downloadgentoo-2-8f6abbd17221db60b9dabf502ef6cd6656efbc2f.tar.gz
gentoo-2-8f6abbd17221db60b9dabf502ef6cd6656efbc2f.tar.bz2
gentoo-2-8f6abbd17221db60b9dabf502ef6cd6656efbc2f.zip
Version bump, straight to stable since it fixes issues with the previous version
(Portage version: 2.1.11.5/cvs/Linux ia64, RepoMan options: --force)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/silo/ChangeLog9
-rw-r--r--sys-boot/silo/silo-1.4.14_p20120226.ebuild4
-rw-r--r--sys-boot/silo/silo-1.4.14_p20120819.ebuild64
3 files changed, 74 insertions, 3 deletions
diff --git a/sys-boot/silo/ChangeLog b/sys-boot/silo/ChangeLog
index 8ed27363e6af..8f65f8d28919 100644
--- a/sys-boot/silo/ChangeLog
+++ b/sys-boot/silo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/silo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.51 2012/07/29 16:30:58 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.52 2012/08/20 18:54:40 armin76 Exp $
+
+*silo-1.4.14_p20120819 (20 Aug 2012)
+
+ 20 Aug 2012; Raúl Porcel <armin76@gentoo.org> silo-1.4.14_p20120226.ebuild,
+ +silo-1.4.14_p20120819.ebuild:
+ Version bump, straight to stable since it fixes issues with the previous
+ version
29 Jul 2012; Raúl Porcel <armin76@gentoo.org> silo-1.4.14_p20120226.ebuild:
Add RDEPEND
diff --git a/sys-boot/silo/silo-1.4.14_p20120226.ebuild b/sys-boot/silo/silo-1.4.14_p20120226.ebuild
index 5effa2ad00d3..0e091f679895 100644
--- a/sys-boot/silo/silo-1.4.14_p20120226.ebuild
+++ b/sys-boot/silo/silo-1.4.14_p20120226.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.14_p20120226.ebuild,v 1.2 2012/07/29 16:30:58 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.14_p20120226.ebuild,v 1.3 2012/08/20 18:54:40 armin76 Exp $
inherit mount-boot flag-o-matic toolchain-funcs eutils
@@ -33,7 +33,7 @@ src_unpack() {
cd "${S}"
#Set the correct version
- sed -i -e "s/1.4.14/1.4.14_git2012226_p1/g" Rules.make
+ sed -i -e "s/1.4.14/1.4.14_git20120226_p1/g" Rules.make
# Fix build failure
sed -i -e "s/-fno-strict-aliasing/-fno-strict-aliasing -U_FORTIFY_SOURCE -mcpu=v9/g" Rules.make
diff --git a/sys-boot/silo/silo-1.4.14_p20120819.ebuild b/sys-boot/silo/silo-1.4.14_p20120819.ebuild
new file mode 100644
index 000000000000..7045cc247ee8
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.14_p20120819.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.14_p20120819.ebuild,v 1.1 2012/08/20 18:54:40 armin76 Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs eutils
+
+DEB_PL="1"
+MY_PV="${PV##*_p}"
+MY_GIT="git${MY_PV%%_*}"
+MY_PV="${PV%%_*}"
+MY_P="${PN}_${MY_PV}+${MY_GIT}"
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/s/${PN}/${MY_P}-${DEB_PL}.diff.gz"
+HOMEPAGE="http://git.kernel.org/?p=linux/kernel/git/davem/silo.git;a=summary"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* sparc"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+RDEPEND=""
+
+ABI_ALLOW="sparc32"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #Set the correct version
+ sed -i -e "s/1.4.14/1.4.14_git2012226_p1/g" Rules.make
+
+ # Fix build failure
+ sed -i -e "s/-fno-strict-aliasing/-fno-strict-aliasing -U_FORTIFY_SOURCE -mcpu=v9/g" Rules.make
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ make ${MAKEOPTS} CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm "${D}"/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ mount-boot_pkg_postinst
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+ ewarn
+}