summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-06-02 15:55:21 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-06-02 15:55:21 +0000
commit843c7f34f66e2a611dc48f89711dd5093243bf41 (patch)
tree7c97157472ff83243a1c970ac1b45fe2aa433dc3 /sys-boot
parentremove old (diff)
downloadgentoo-2-843c7f34f66e2a611dc48f89711dd5093243bf41.tar.gz
gentoo-2-843c7f34f66e2a611dc48f89711dd5093243bf41.tar.bz2
gentoo-2-843c7f34f66e2a611dc48f89711dd5093243bf41.zip
Version bump
(Portage version: 2.1.6.11/cvs/Linux ia64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gnu-efi/ChangeLog9
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0g.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/sys-boot/gnu-efi/ChangeLog b/sys-boot/gnu-efi/ChangeLog
index 64aac3afa670..ea6a5d975f58 100644
--- a/sys-boot/gnu-efi/ChangeLog
+++ b/sys-boot/gnu-efi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/gnu-efi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/ChangeLog,v 1.14 2008/02/23 02:05:41 robbat2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/ChangeLog,v 1.15 2009/06/02 15:55:21 armin76 Exp $
+
+*gnu-efi-3.0g (02 Jun 2009)
+
+ 02 Jun 2009; Raúl Porcel <armin76@gentoo.org> +gnu-efi-3.0g.ebuild:
+ Version bump
23 Feb 2008; Robin H. Johnson <robbat2@gentoo.org> gnu-efi-3.0e.ebuild:
This builds on amd64 too! Add ~amd64.
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0g.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0g.ebuild
new file mode 100644
index 000000000000..0a8766deb7ce
--- /dev/null
+++ b/sys-boot/gnu-efi/gnu-efi-3.0g.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/gnu-efi-3.0g.ebuild,v 1.1 2009/06/02 15:55:21 armin76 Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Library for build EFI Applications"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="mirror://sourceforge/gnu-efi/${MY_P}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+
+S="${WORKDIR}"/${PN}-3.0
+
+src_compile() {
+ local iarch
+ case $ARCH in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $ARCH" ;;
+ esac
+ emake CC="$(tc-getCC)" ARCH=${iarch} -j1 || die "emake failed"
+}
+
+src_install() {
+ make install INSTALLROOT="${D}"/usr || die "install failed"
+ dodoc README* ChangeLog
+}