summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-14 17:57:08 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-14 17:57:08 +0000
commit58d69cf886953108009fd074b30ae347bd4e21eb (patch)
tree11bf8bf76a181884de1ab7a99aa9b9b66021ad9b /sys-boot
parentFix building with libpng15 wrt #378349 by Diego Elio Pettenò (diff)
downloadgentoo-2-58d69cf886953108009fd074b30ae347bd4e21eb.tar.gz
gentoo-2-58d69cf886953108009fd074b30ae347bd4e21eb.tar.bz2
gentoo-2-58d69cf886953108009fd074b30ae347bd4e21eb.zip
Run the configure phase for the package only in the pkg_config. Fixes bug #382769.
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-1.99-r2.ebuild24
-rw-r--r--sys-boot/grub/grub-9999.ebuild24
3 files changed, 36 insertions, 19 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 3a19abb8dbd2..b9dbc571a2e6 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.166 2011/09/10 02:33:59 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.167 2011/09/14 17:57:08 scarabeus Exp $
+
+ 14 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org> grub-1.99-r2.ebuild,
+ grub-9999.ebuild:
+ Run the configure phase for the package only in the pkg_config. Fixes bug
+ #382769.
10 Sep 2011; Ryan Hill <dirtyepic@gentoo.org> grub-0.97-r10.ebuild:
Release patchset 1.11 to work around miscompilation with gcc-4.6 (bug
diff --git a/sys-boot/grub/grub-1.99-r2.ebuild b/sys-boot/grub/grub-1.99-r2.ebuild
index e4b4d285551d..a459df8060d3 100644
--- a/sys-boot/grub/grub-1.99-r2.ebuild
+++ b/sys-boot/grub/grub-1.99-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.99-r2.ebuild,v 1.2 2011/09/06 15:31:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.99-r2.ebuild,v 1.3 2011/09/14 17:57:08 scarabeus Exp $
EAPI=4
@@ -245,12 +245,15 @@ src_install() {
cat <<EOF >> "${ED}"/lib*/grub2/grub-mkconfig_lib
GRUB_DISTRIBUTOR="Gentoo"
EOF
+
+ elog "Remember to run emerge --config =${CATEGORY}/${P} in order"
+ elog "to set up basic settings for this package."
}
setup_boot_dir() {
local dir=$1
- # display the link to guide if user didn't set up anything yet.
+ # display the link to guide
elog "For informations how to configure grub-2 please reffer to the guide:"
elog " http://dev.gentoo.org/~scarabeus/grub-2-guide.xml"
@@ -265,7 +268,7 @@ setup_boot_dir() {
einfo "Even if we just created configuration for your grub2 using old"
einfo "grub-legacy configuration file you should migrate to use new style"
- einfo "configuration in '${ROOT}/etc/grub.d'."
+ einfo "configuration in '${ROOT}/etc/grub.d' and '${ROOT}/etc/defaults/grub'."
einfo
else
@@ -275,18 +278,21 @@ setup_boot_dir() {
ewarn "Running grub2-mkconfig failed! Check your configuration files!"
fi
- elog "Remember to run \"grub2-mkconfig -o '${dir}/grub.cfg'\" every time"
- elog "you update the configuration files!"
-
elog "Remember to run grub2-install to install your grub every time"
elog "you update this package!"
}
-pkg_postinst() {
+pkg_config() {
+ local dir
+
mount-boot_mount_boot_partition
- setup_boot_dir "${ROOT}"boot/grub2
+ einfo "Enter the directory where you want to setup grub2 ('${ROOT}boot/grub2/'):"
+ read dir
+
+ [[ -z ${dir} ]] && dir="${ROOT}"boot/grub2
+
+ setup_boot_dir "${dir}"
- # needs to be called after we call setup_boot_dir
mount-boot_pkg_postinst
}
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 2040fd4ec7b5..697bef02927a 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.41 2011/09/06 15:31:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.42 2011/09/14 17:57:08 scarabeus Exp $
EAPI=4
@@ -241,12 +241,15 @@ src_install() {
cat <<EOF >> "${ED}"/lib*/grub2/grub-mkconfig_lib
GRUB_DISTRIBUTOR="Gentoo"
EOF
+
+ elog "Remember to run emerge --config =${CATEGORY}/${P} in order"
+ elog "to set up basic settings for this package."
}
setup_boot_dir() {
local dir=$1
- # display the link to guide if user didn't set up anything yet.
+ # display the link to guide
elog "For informations how to configure grub-2 please reffer to the guide:"
elog " http://dev.gentoo.org/~scarabeus/grub-2-guide.xml"
@@ -261,7 +264,7 @@ setup_boot_dir() {
einfo "Even if we just created configuration for your grub2 using old"
einfo "grub-legacy configuration file you should migrate to use new style"
- einfo "configuration in '${ROOT}/etc/grub.d'."
+ einfo "configuration in '${ROOT}/etc/grub.d' and '${ROOT}/etc/defaults/grub'."
einfo
else
@@ -271,18 +274,21 @@ setup_boot_dir() {
ewarn "Running grub2-mkconfig failed! Check your configuration files!"
fi
- elog "Remember to run \"grub2-mkconfig -o '${dir}/grub.cfg'\" every time"
- elog "you update the configuration files!"
-
elog "Remember to run grub2-install to install your grub every time"
elog "you update this package!"
}
-pkg_postinst() {
+pkg_config() {
+ local dir
+
mount-boot_mount_boot_partition
- setup_boot_dir "${ROOT}"boot/grub2
+ einfo "Enter the directory where you want to setup grub2 ('${ROOT}boot/grub2/'):"
+ read dir
+
+ [[ -z ${dir} ]] && dir="${ROOT}"boot/grub2
+
+ setup_boot_dir "${dir}"
- # needs to be called after we call setup_boot_dir
mount-boot_pkg_postinst
}