summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-17 04:25:12 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-17 04:25:12 +0000
commit504470bef7aa5bba1afe64caf55171997dd5bcdb (patch)
tree62bfeccaca4debb1492ef410210e37c5d57cc6ee /sys-boot
parentUse `sed -i` like we do in newer versions. (diff)
downloadgentoo-2-504470bef7aa5bba1afe64caf55171997dd5bcdb.tar.gz
gentoo-2-504470bef7aa5bba1afe64caf55171997dd5bcdb.tar.bz2
gentoo-2-504470bef7aa5bba1afe64caf55171997dd5bcdb.zip
Update to EAPI=5.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/yaboot/ChangeLog6
-rw-r--r--sys-boot/yaboot/yaboot-1.3.14-r2.ebuild21
-rw-r--r--sys-boot/yaboot/yaboot-1.3.16.ebuild21
-rw-r--r--sys-boot/yaboot/yaboot-1.3.17-r2.ebuild19
4 files changed, 41 insertions, 26 deletions
diff --git a/sys-boot/yaboot/ChangeLog b/sys-boot/yaboot/ChangeLog
index 37cf08269c71..731ca6003b2d 100644
--- a/sys-boot/yaboot/ChangeLog
+++ b/sys-boot/yaboot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/yaboot
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.49 2015/05/17 04:20:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.50 2015/05/17 04:25:12 vapier Exp $
+
+ 17 May 2015; Mike Frysinger <vapier@gentoo.org> yaboot-1.3.14-r2.ebuild,
+ yaboot-1.3.16.ebuild, yaboot-1.3.17-r2.ebuild:
+ Update to EAPI=5.
17 May 2015; Mike Frysinger <vapier@gentoo.org> yaboot-1.3.14-r2.ebuild:
Use `sed -i` like we do in newer versions.
diff --git a/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
index cbb35b9bf20f..e3c1320ac440 100644
--- a/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
@@ -1,14 +1,17 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild,v 1.9 2015/05/17 04:20:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild,v 1.10 2015/05/17 04:25:12 vapier Exp $
+
+EAPI="5"
inherit eutils toolchain-funcs
DESCRIPTION="PPC Bootloader"
-SRC_URI="http://yaboot.ozlabs.org/releases/${P}.tar.gz"
HOMEPAGE="http://yaboot.ozlabs.org"
-SLOT="0"
+SRC_URI="http://yaboot.ozlabs.org/releases/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="-* ppc -ppc64"
IUSE="ibm"
@@ -20,9 +23,7 @@ RDEPEND="!sys-boot/yaboot-static
sys-fs/mac-fdisk
)"
-src_compile() {
- unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
-
+src_prepare() {
# No need to hardcode this path -- the compiler already knows to use it.
sed -i \
-e 's:-I/usr/include::' \
@@ -38,10 +39,14 @@ src_compile() {
epatch "${FILESDIR}/yaboot-nopiessp-gcc4.patch"
fi
epatch "${FILESDIR}/sysfs-ofpath.patch"
- emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" LD="$(tc-getLD)" || die
+}
+
+src_compile() {
+ unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" LD="$(tc-getLD)"
}
src_install() {
sed -i -e 's/\/local//' etc/yaboot.conf
- make ROOT="${D}" PREFIX=/usr MANDIR=share/man install || die
+ emake ROOT="${D}" PREFIX=/usr MANDIR=share/man install
}
diff --git a/sys-boot/yaboot/yaboot-1.3.16.ebuild b/sys-boot/yaboot/yaboot-1.3.16.ebuild
index b9e3d36289d6..53e065b8cdd4 100644
--- a/sys-boot/yaboot/yaboot-1.3.16.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.16.ebuild
@@ -1,14 +1,17 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.16.ebuild,v 1.9 2015/05/17 04:18:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.16.ebuild,v 1.10 2015/05/17 04:25:12 vapier Exp $
+
+EAPI="5"
inherit eutils toolchain-funcs
DESCRIPTION="PPC Bootloader"
-SRC_URI="http://yaboot.ozlabs.org/releases/${P}.tar.gz"
HOMEPAGE="http://yaboot.ozlabs.org"
-SLOT="0"
+SRC_URI="http://yaboot.ozlabs.org/releases/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="-* ppc -ppc64"
IUSE="ibm"
@@ -21,10 +24,12 @@ RDEPEND="!sys-boot/yaboot-static
)"
src_unpack() {
- unpack ${A}
+ default
cd "${S}"
cp "${FILESDIR}/new-ofpath" "${S}/ybin/ofpath"
+}
+src_prepare() {
# No need to hardcode this path -- the compiler already knows to use it.
sed -i \
-e 's:-I/usr/include::' \
@@ -46,11 +51,11 @@ src_unpack() {
src_compile() {
unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
- emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" LD="$(tc-getLD)" || die
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" LD="$(tc-getLD)"
}
src_install() {
- sed -i -e 's/\/local//' etc/yaboot.conf
- make ROOT="${D}" PREFIX=/usr MANDIR=share/man install || die
- mv "${D}/etc/yaboot.conf" "${D}/etc/yaboot.conf.sample"
+ sed -i -e 's/\/local//' etc/yaboot.conf || die
+ emake ROOT="${D}" PREFIX=/usr MANDIR=share/man install
+ mv "${ED}"/etc/yaboot.conf{,.sample} || die
}
diff --git a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
index 476d8125f359..55c8883e29cd 100644
--- a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.6 2015/05/17 04:18:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.7 2015/05/17 04:25:12 vapier Exp $
-EAPI=2
+EAPI="5"
inherit eutils toolchain-funcs
DESCRIPTION="PPC Bootloader"
-SRC_URI="http://yaboot.ozlabs.org/releases/${P}.tar.gz"
HOMEPAGE="http://yaboot.ozlabs.org"
-SLOT="0"
+SRC_URI="http://yaboot.ozlabs.org/releases/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="-* ppc -ppc64"
IUSE="ibm"
@@ -24,7 +25,7 @@ RDEPEND="!sys-boot/yaboot-static
)"
src_unpack() {
- unpack ${A}
+ default
cd "${S}"
cp "${FILESDIR}/new-ofpath" "${S}/ybin/ofpath"
}
@@ -57,11 +58,11 @@ src_prepare() {
src_compile() {
unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
- emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" LD="$(tc-getLD)" || die
+ emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" LD="$(tc-getLD)"
}
src_install() {
- sed -i -e 's/\/local//' etc/yaboot.conf
- make ROOT="${D}" PREFIX=/usr MANDIR=share/man install || die
- mv "${D}/etc/yaboot.conf" "${D}/etc/yaboot.conf.sample"
+ sed -i -e 's/\/local//' etc/yaboot.conf || die
+ emake ROOT="${D}" PREFIX=/usr MANDIR=share/man install
+ mv "${ED}"/etc/yaboot.conf{,.sample} || die
}