summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-07-11 14:18:30 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-07-11 14:18:30 +0000
commit38a7ed6bd5486a1911182ad091ebc0acf703f631 (patch)
tree90d05b5fe8eacec1d254fe8e56d28192926bd0d7 /sys-boot
parentStable on sparc wrt #181322 (diff)
downloadgentoo-2-38a7ed6bd5486a1911182ad091ebc0acf703f631.tar.gz
gentoo-2-38a7ed6bd5486a1911182ad091ebc0acf703f631.tar.bz2
gentoo-2-38a7ed6bd5486a1911182ad091ebc0acf703f631.zip
Fix build failure if pciutils is built with zlib, thanks to Alexander Færøy <eroyf at eroyf dot org> for the fix, bug #184005
(Portage version: 2.1.3_rc7)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/efibootmgr/ChangeLog6
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild10
2 files changed, 12 insertions, 4 deletions
diff --git a/sys-boot/efibootmgr/ChangeLog b/sys-boot/efibootmgr/ChangeLog
index c6eb82512006..9a6d18202744 100644
--- a/sys-boot/efibootmgr/ChangeLog
+++ b/sys-boot/efibootmgr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/efibootmgr
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/ChangeLog,v 1.13 2007/02/22 00:56:35 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/ChangeLog,v 1.14 2007/07/11 14:18:30 armin76 Exp $
+
+ 11 Jul 2007; Raúl Porcel <armin76@gentoo.org> efibootmgr-0.5.3.ebuild:
+ Fix build failure if pciutils is built with zlib, thanks to Alexander
+ Færøy <eroyf at eroyf dot org> for the fix, bug #184005
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild b/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild
index b17a2c2427fa..32e86eeac8b9 100644
--- a/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild
+++ b/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild,v 1.2 2006/04/01 03:56:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild,v 1.3 2007/07/11 14:18:30 armin76 Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Interact with the EFI Boot Manager on IA-64 Systems"
HOMEPAGE="http://developer.intel.com/technology/efi"
@@ -17,6 +17,10 @@ DEPEND="virtual/libc
sys-apps/pciutils"
src_compile() {
+ if built_with_use sys-apps/pciutils zlib ; then
+ append-ldflags -lz
+ fi
+
emake || die "emake failed"
}