summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2010-01-10 16:34:24 +0000
committerRaúl Porcel <armin76@gentoo.org>2010-01-10 16:34:24 +0000
commit1ccdb66a107abf99127e637bcfbfc91e43b0af3e (patch)
treeb02758e8e25e7fe206c02c31439e6074388398cd /sys-boot
parentFixup manifest :/ (diff)
downloadgentoo-2-1ccdb66a107abf99127e637bcfbfc91e43b0af3e.tar.gz
gentoo-2-1ccdb66a107abf99127e637bcfbfc91e43b0af3e.tar.bz2
gentoo-2-1ccdb66a107abf99127e637bcfbfc91e43b0af3e.zip
ia64 stable, version bump
(Portage version: 2.1.6.13/cvs/Linux ia64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gnu-efi/ChangeLog10
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0g.ebuild6
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0i.ebuild46
3 files changed, 57 insertions, 5 deletions
diff --git a/sys-boot/gnu-efi/ChangeLog b/sys-boot/gnu-efi/ChangeLog
index ea6a5d975f58..53e3d3bd4463 100644
--- a/sys-boot/gnu-efi/ChangeLog
+++ b/sys-boot/gnu-efi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/gnu-efi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/ChangeLog,v 1.15 2009/06/02 15:55:21 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/ChangeLog,v 1.16 2010/01/10 16:34:24 armin76 Exp $
+
+*gnu-efi-3.0i (10 Jan 2010)
+
+ 10 Jan 2010; Raúl Porcel <armin76@gentoo.org> gnu-efi-3.0g.ebuild,
+ +gnu-efi-3.0i.ebuild:
+ ia64 stable, version bump
*gnu-efi-3.0g (02 Jun 2009)
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0g.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0g.ebuild
index 0a8766deb7ce..6b1c1a0275e2 100644
--- a/sys-boot/gnu-efi/gnu-efi-3.0g.ebuild
+++ b/sys-boot/gnu-efi/gnu-efi-3.0g.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/gnu-efi-3.0g.ebuild,v 1.1 2009/06/02 15:55:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/gnu-efi-3.0g.ebuild,v 1.2 2010/01/10 16:34:24 armin76 Exp $
inherit eutils toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/gnu-efi/${MY_P}.orig.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
+KEYWORDS="~amd64 ia64 ~x86"
IUSE=""
DEPEND="sys-apps/pciutils"
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0i.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0i.ebuild
new file mode 100644
index 000000000000..e8af985675f2
--- /dev/null
+++ b/sys-boot/gnu-efi/gnu-efi-3.0i.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/gnu-efi-3.0i.ebuild,v 1.1 2010/01/10 16:34:24 armin76 Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Library for build EFI Applications"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="mirror://sourceforge/gnu-efi/${MY_P}.orig.tar.gz"
+SRC_URI="${SRC_URI} mirror://debian/pool/main/g/gnu-efi/gnu-efi_3.0i-2.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ ebegin Applying ../*.diff
+ # Using epatch on this is annoying because it wants to create the elilo-3.6/
+ # directory. Since all the files are new, it doesn't know better.
+ filterdiff -p1 -i debian/\* ../*.diff | patch -s -p1
+ eend $? || return
+}
+
+src_compile() {
+ local iarch
+ case $ARCH in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $ARCH" ;;
+ esac
+ emake CC="$(tc-getCC)" ARCH=${iarch} -j1 || die "emake failed"
+}
+
+src_install() {
+ make install INSTALLROOT="${D}"/usr || die "install failed"
+ dodoc README* ChangeLog
+}