summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2004-06-10 17:49:47 +0000
committerTony Vroon <chainsaw@gentoo.org>2004-06-10 17:49:47 +0000
commit1ac46eb5f5d3033131bdd744a0c1590462031b8c (patch)
tree0241d9bb2063af48eea0a4afe8c6ee421f5633c5 /sys-boot
parentUpdated devmapper patch by Christophe Saout (#53413) and dolilo config file i... (diff)
downloadgentoo-2-1ac46eb5f5d3033131bdd744a0c1590462031b8c.tar.gz
gentoo-2-1ac46eb5f5d3033131bdd744a0c1590462031b8c.tar.bz2
gentoo-2-1ac46eb5f5d3033131bdd744a0c1590462031b8c.zip
Removing old ebuilds up to the current stable 22.5.8-r1. And one botched one.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/files/digest-lilo-22.5.11
-rw-r--r--sys-boot/lilo/files/digest-lilo-22.5.6-r21
-rw-r--r--sys-boot/lilo/files/digest-lilo-22.5.7.21
-rw-r--r--sys-boot/lilo/files/digest-lilo-22.5.92
-rw-r--r--sys-boot/lilo/lilo-22.5.1.ebuild188
-rw-r--r--sys-boot/lilo/lilo-22.5.6-r2.ebuild140
-rw-r--r--sys-boot/lilo/lilo-22.5.7.2.ebuild164
-rw-r--r--sys-boot/lilo/lilo-22.5.9.ebuild200
8 files changed, 0 insertions, 697 deletions
diff --git a/sys-boot/lilo/files/digest-lilo-22.5.1 b/sys-boot/lilo/files/digest-lilo-22.5.1
deleted file mode 100644
index 6bca071889e6..000000000000
--- a/sys-boot/lilo/files/digest-lilo-22.5.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 246415f158a3f6d5a00f8882c217b600 lilo-22.5.1.tar.gz 382497
diff --git a/sys-boot/lilo/files/digest-lilo-22.5.6-r2 b/sys-boot/lilo/files/digest-lilo-22.5.6-r2
deleted file mode 100644
index 5cd39211f2f0..000000000000
--- a/sys-boot/lilo/files/digest-lilo-22.5.6-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 fd85e0cd157e77c1f565dbe649cbaaab lilo-22.5.6.tar.gz 406705
diff --git a/sys-boot/lilo/files/digest-lilo-22.5.7.2 b/sys-boot/lilo/files/digest-lilo-22.5.7.2
deleted file mode 100644
index 08d2fc4c8d86..000000000000
--- a/sys-boot/lilo/files/digest-lilo-22.5.7.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 01117bffb9f452796d44ab9c7620901a lilo-22.5.7.2.tar.gz 410234
diff --git a/sys-boot/lilo/files/digest-lilo-22.5.9 b/sys-boot/lilo/files/digest-lilo-22.5.9
deleted file mode 100644
index f9cdd0591159..000000000000
--- a/sys-boot/lilo/files/digest-lilo-22.5.9
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 d5b561190cbe0968d50e09e0031edb79 lilo-22.5.9.tar.gz 415378
-MD5 fc344efe42e541a11a0972fa418780ce dolilo-0.1.tar.bz2 3930
diff --git a/sys-boot/lilo/lilo-22.5.1.ebuild b/sys-boot/lilo/lilo-22.5.1.ebuild
deleted file mode 100644
index be6771b7112f..000000000000
--- a/sys-boot/lilo/lilo-22.5.1.ebuild
+++ /dev/null
@@ -1,188 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.5.1.ebuild,v 1.4 2004/05/12 12:11:54 pappy Exp $
-
-inherit mount-boot eutils flag-o-matic
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Standard Linux boot loader"
-SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/obsolete/${P}.tar.gz"
-HOMEPAGE="http://brun.dyndns.org/pub/linux/lilo/"
-
-SLOT="0"
-LICENSE="BSD GPL-2"
-KEYWORDS="-* x86"
-
-DEPEND=">=sys-apps/sed-4
- dev-lang/nasm
- >=sys-devel/bin86-0.15.5"
-
-PROVIDE="virtual/bootloader"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # Get all the loaders to install
- sed -i 's:# $(BOOTS): $(BOOTS):' Makefile
-}
-
-src_compile() {
-
- # hardened automatic PIC plus PIE building should be suppressed
- # because of assembler instructions that cannot be compiled PIC
- HARDENED_CFLAGS="`test_flag -fno-pic` `test_flag -nopie`"
-
- # we explicitly prevent the custom CFLAGS for stability reasons
- emake CC="${CC:=gcc} ${HARDENED_CFLAGS}" OPT="-O1" || die
-}
-
-src_install() {
- into /
- dosbin lilo activate mkrescue
- into /usr
- dosbin keytab-lilo.pl
-
- dodir /boot
- insinto /boot
- doins boot-text.b boot-menu.b boot-bmp.b chain.b mbr.b os2_d.b
-
- insinto /etc
- newins ${FILESDIR}/lilo.conf lilo.conf.example
-
- doman manPages/*.[5-8]
- dodoc CHANGES COPYING INCOMPAT README*
- docinto samples ; dodoc sample/*
-}
-
-pkg_preinst() {
- mount-boot_mount_boot_partition
-
- if [ ! -L ${ROOT}/boot/boot.b -a -f ${ROOT}/boot/boot.b ]
- then
- einfo "Saving old boot.b..."
- mv -f ${ROOT}/boot/boot.b ${ROOT}/boot/boot.old
- fi
-
- if [ ! -L ${ROOT}/boot/boot-text.b -a -f ${ROOT}/boot/boot-text.b ]
- then
- einfo "Saving old boot-text.b..."
- mv -f ${ROOT}/boot/boot-text.b ${ROOT}/boot/boot-text.old
- fi
-
- if [ ! -L ${ROOT}/boot/boot-menu.b -a -f ${ROOT}/boot/boot-menu.b ]
- then
- einfo "Saving old boot-menu.b..."
- mv -f ${ROOT}/boot/boot-menu.b ${ROOT}/boot/boot-menu.old
- fi
-
- if [ ! -L ${ROOT}/boot/boot-bmp.b -a -f ${ROOT}/boot/boot-bmp.b ]
- then
- einfo "Saving old boot-bmp.b..."
- mv -f ${ROOT}/boot/boot-bmp.b ${ROOT}/boot/boot-bmp.old
- fi
-
- if [ ! -L ${ROOT}/boot/chain.b -a -f ${ROOT}/boot/chain.b ]
- then
- einfo "Saving old chain.b..."
- mv -f ${ROOT}/boot/chain.b ${ROOT}/boot/chain.old
- fi
-
- if [ ! -L ${ROOT}/boot/mbr.b -a -f ${ROOT}/boot/mbr.b ]
- then
- einfo "Saving old mbr.b..."
- mv -f ${ROOT}/boot/mbr.b ${ROOT}/boot/mbr.old
- fi
-
- if [ ! -L ${ROOT}/boot/os2_d.b -a -f ${ROOT}/boot/os2_d.b ]
- then
- einfo "Saving old os2_d.b..."
- mv -f ${ROOT}/boot/os2_d.b ${ROOT}/boot/os2_d.old
- fi
-}
-
-# Check whether LILO is installed
-# This function is from /usr/sbin/mkboot from debianutils, with copyright:
-#
-# Debian GNU/Linux
-# Copyright 1996-1997 Guy Maor <maor@debian.org>
-#
-# Modified for Gentoo for use with the lilo ebuild by:
-# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
-#
-lilocheck () {
- local bootpart=
- local rootpart="$(rdev 2> /dev/null | cut -d ' ' -f 1 2> /dev/null)"
-
- echo
- einfon "Checking for LILO ..."
-
- if [ "$(whoami)" != "root" ]
- then
- echo; echo
- eerror "Only root can check for LILO!"
- return 1
- fi
-
- if [ -z "${rootpart}" ]
- then
- echo; echo
- eerror "Could not determine root partition!"
- return 1
- fi
-
- if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
- then
- echo " No"
- return 1
- fi
-
- bootpart="$(perl -ne 'print $1 if /^\s*boot\s*=\s*(\S*)/' /etc/lilo.conf)"
-
- if [ -z "${bootpart}" ]
- then
- # lilo defaults to current root when 'boot=' is not present
- bootpart="${rootpart}"
- fi
-
- if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
- then
- echo; echo
- ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
- ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
- return 1
- fi
-
- echo " Yes, on ${bootpart}"
-
- return 0
-}
-
-
-pkg_postinst() {
- if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
- then
- ln -snf boot-menu.b ${ROOT}/boot/boot.b
- fi
-
- if [ "${ROOT}" = "/" ]
- then
- if lilocheck
- then
- einfo "Running LILO to complete the install ..."
- /sbin/lilo &> /dev/null
- if [ "$?" -ne 0 ]
- then
- echo
- ewarn "Running /sbin/lilo failed! Please check what the problem is"
- ewarn "before your next reboot."
-
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- sleep 5
- fi
- fi
- echo
- fi
-}
-
diff --git a/sys-boot/lilo/lilo-22.5.6-r2.ebuild b/sys-boot/lilo/lilo-22.5.6-r2.ebuild
deleted file mode 100644
index accd3a2d05f0..000000000000
--- a/sys-boot/lilo/lilo-22.5.6-r2.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.5.6-r2.ebuild,v 1.3 2004/01/19 18:35:20 azarah Exp $
-
-inherit mount-boot eutils
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Standard Linux boot loader"
-SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${P}.tar.gz
- ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/obsolete/${P}.tar.gz"
-# mirror://gentoo/${P}-gentoo.diff.bz2"
-HOMEPAGE="http://brun.dyndns.org/pub/linux/lilo/"
-
-SLOT="0"
-LICENSE="BSD GPL-2"
-KEYWORDS="-* ~x86"
-
-DEPEND="dev-lang/nasm
- >=sys-devel/bin86-0.15.5"
-
-PROVIDE="virtual/bootloader"
-
-
-src_compile() {
- emake CC="${CC:=gcc}" lilo || die
-}
-
-src_install() {
- keepdir /boot
- make ROOT=${D} install || die
- into /usr
- dosbin keytab-lilo.pl
-
- insinto /etc
- newins ${FILESDIR}/lilo.conf lilo.conf.example
-
- doman manPages/*.[5-8]
- dodoc CHANGES COPYING INCOMPAT README*
- docinto samples ; dodoc sample/*
-}
-
-pkg_preinst() {
- mount-boot_mount_boot_partition
-}
-
-# Check whether LILO is installed
-# This function is from /usr/sbin/mkboot from debianutils, with copyright:
-#
-# Debian GNU/Linux
-# Copyright 1996-1997 Guy Maor <maor@debian.org>
-#
-# Modified for Gentoo for use with the lilo ebuild by:
-# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
-#
-lilocheck () {
- local bootpart=
- local rootpart="$(rdev 2> /dev/null | cut -d ' ' -f 1 2> /dev/null)"
-
- echo
- einfon "Checking for LILO ..."
-
- if [ "$(whoami)" != "root" ]
- then
- echo; echo
- eerror "Only root can check for LILO!"
- return 1
- fi
-
- if [ -z "${rootpart}" ]
- then
- echo; echo
- eerror "Could not determine root partition!"
- return 1
- fi
-
- if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
- then
- echo " No"
- return 1
- fi
-
- bootpart="$(perl -ne 'print $1 if /^\s*boot\s*=\s*(\S*)/' /etc/lilo.conf)"
-
- if [ -z "${bootpart}" ]
- then
- # lilo defaults to current root when 'boot=' is not present
- bootpart="${rootpart}"
- fi
-
- if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
- then
- echo; echo
- ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
- ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
- return 1
- fi
-
- echo " Yes, on ${bootpart}"
-
- return 0
-}
-
-
-pkg_postinst() {
- if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
- then
- [ -f "${ROOT}/boot/boot-menu.b" ] && \
- ln -snf boot-menu.b ${ROOT}/boot/boot.b
- fi
-
- if [ "${ROOT}" = "/" ]
- then
- if lilocheck
- then
- einfo "Running LILO to complete the install ..."
- # do not redirect to /dev/null because it may display some input
- # prompt
- /sbin/lilo
- if [ "$?" -ne 0 ]
- then
- echo
- ewarn "Running /sbin/lilo failed! Please check what the problem is"
- ewarn "before your next reboot."
-
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- sleep 5
- fi
- fi
- echo
- fi
-
- echo
- einfo "Please note that all the loader files (/boot/*.b) is now linked"
- einfo "into LILO, and thus no longer installed."
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- sleep 3
- echo
-}
-
diff --git a/sys-boot/lilo/lilo-22.5.7.2.ebuild b/sys-boot/lilo/lilo-22.5.7.2.ebuild
deleted file mode 100644
index cb2e9c1e59d1..000000000000
--- a/sys-boot/lilo/lilo-22.5.7.2.ebuild
+++ /dev/null
@@ -1,164 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.5.7.2.ebuild,v 1.4 2004/05/12 12:11:54 pappy Exp $
-
-inherit mount-boot eutils flag-o-matic
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Standard Linux boot loader"
-HOMEPAGE="http://brun.dyndns.org/pub/linux/lilo/"
-SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${P}.tar.gz
- ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/obsolete/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD GPL-2"
-KEYWORDS="-* ~x86"
-
-DEPEND="dev-lang/nasm
- >=sys-devel/bin86-0.15.5"
-
-PROVIDE="virtual/bootloader"
-
-
-src_unpack() {
- unpack ${A}
-
- # This bootlogo patch is borrowed from SuSE Linux.
- # You should see Raphaël Quinet's (quinet@gamers.org) website,
- # http://www.gamers.org/~quinet/lilo/index.html
- #
- # Update for 22.5 by Quequero (bug #19397):
- #
- # I've adapted and edited this patch from and older version
- # For problems email me.
- # Quequero <quequerp@bitchx.it>
- #
-# cd ${S}; epatch ${FILESDIR}/${P}-animated-menu.patch
-
- # Fixup things for glibc-2.3.3 (and later CVS versions of 2.3.2)
- cd ${S}; epatch ${FILESDIR}/${PN}-glibc233.patch
-}
-
-src_compile() {
-
- # hardened automatic PIC plus PIE building should be suppressed
- # because of assembler instructions that cannot be compiled PIC
- HARDENED_CFLAGS="`test_flag -fno-pic` `test_flag -nopie`"
-
- # we explicitly prevent the custom CFLAGS for stability reasons
- emake CC="${CC:=gcc} ${HARDENED_CFLAGS}" lilo || die
-}
-
-src_install() {
- keepdir /boot
- make ROOT=${D} install || die
- into /usr
- dosbin keytab-lilo.pl
-
- insinto /etc
- newins ${FILESDIR}/lilo.conf lilo.conf.example
-
- doman manPages/*.[5-8]
- dodoc CHANGES COPYING INCOMPAT README*
- docinto samples ; dodoc sample/*
-}
-
-pkg_preinst() {
- mount-boot_mount_boot_partition
-}
-
-# Check whether LILO is installed
-# This function is from /usr/sbin/mkboot from debianutils, with copyright:
-#
-# Debian GNU/Linux
-# Copyright 1996-1997 Guy Maor <maor@debian.org>
-#
-# Modified for Gentoo for use with the lilo ebuild by:
-# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
-#
-lilocheck () {
- local bootpart=
- local rootpart="$(rdev 2> /dev/null | cut -d ' ' -f 1 2> /dev/null)"
-
- echo
- einfon "Checking for LILO ..."
-
- if [ "$(whoami)" != "root" ]
- then
- echo; echo
- eerror "Only root can check for LILO!"
- return 1
- fi
-
- if [ -z "${rootpart}" ]
- then
- echo; echo
- eerror "Could not determine root partition!"
- return 1
- fi
-
- if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
- then
- echo " No"
- return 1
- fi
-
- bootpart="$(perl -ne 'print $1 if /^\s*boot\s*=\s*(\S*)/' /etc/lilo.conf)"
-
- if [ -z "${bootpart}" ]
- then
- # lilo defaults to current root when 'boot=' is not present
- bootpart="${rootpart}"
- fi
-
- if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
- then
- echo; echo
- ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
- ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
- return 1
- fi
-
- echo " Yes, on ${bootpart}"
-
- return 0
-}
-
-
-pkg_postinst() {
- if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
- then
- [ -f "${ROOT}/boot/boot-menu.b" ] && \
- ln -snf boot-menu.b ${ROOT}/boot/boot.b
- fi
-
- if [ "${ROOT}" = "/" ]
- then
- if lilocheck
- then
- einfo "Running LILO to complete the install ..."
- # do not redirect to /dev/null because it may display some input
- # prompt
- /sbin/lilo
- if [ "$?" -ne 0 ]
- then
- echo
- ewarn "Running /sbin/lilo failed! Please check what the problem is"
- ewarn "before your next reboot."
-
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- sleep 5
- fi
- fi
- echo
- fi
-
- echo
- einfo "Please note that all the loader files (/boot/*.b) is now linked"
- einfo "into LILO, and thus no longer installed."
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- sleep 3
- echo
-}
-
diff --git a/sys-boot/lilo/lilo-22.5.9.ebuild b/sys-boot/lilo/lilo-22.5.9.ebuild
deleted file mode 100644
index 5ce80f71c839..000000000000
--- a/sys-boot/lilo/lilo-22.5.9.ebuild
+++ /dev/null
@@ -1,200 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.5.9.ebuild,v 1.1 2004/06/09 16:40:40 chainsaw Exp $
-
-inherit eutils flag-o-matic
-
-DOLILO_V="0.1"
-IUSE="devmap static"
-
-DESCRIPTION="Standard Linux boot loader"
-HOMEPAGE="http://lilo.go.dyndns.org/pub/linux/lilo/"
-DOLILO_TAR="dolilo-${DOLILO_V}.tar.bz2"
-SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/${P}.tar.gz
- ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${P}.tar.gz
- ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/obsolete/${P}.tar.gz
- mirror://gentoo/${DOLILO_TAR}"
-
-SLOT="0"
-LICENSE="BSD GPL-2"
-KEYWORDS="-* ~x86"
-
-RDEPEND=">=sys-apps/sed-4
- devmap? ( >=sys-libs/device-mapper-1.00.08 )"
-DEPEND="${RDEPEND}
- dev-lang/nasm
- >=sys-devel/bin86-0.15.5"
-
-PROVIDE="virtual/bootloader"
-
-src_unpack() {
- einfo
- einfo "If you want to use lilo with device mapper, please enable the"
- einfo "\"devmap\" USE flag."
- einfo
-
- unpack ${P}.tar.gz
-
- # Do not try and build the dos crap.
- sed -i -e 's|^all:.*$|all: lilo|' ${S}/Makefile
-
- # The bootlogo patch from SuSE linux, which was originally in
- # here, has been dropped because it's no longer compatible
- # with lilo since the 22.5.x series.
- # Quequero has done a good attempt to port the patch in bug
- # #19397, but unfortunately that breaks the timeout at boot.
- # If you can overcome these problems, a patch is very welcome.
-
- if [ `use devmap` ]; then
- # devmapper-patch (boot on evms/lvm2)
- cd ${S}; epatch ${FILESDIR}/${P}-devmapper_gentoo.patch
- fi
-
- cd ${S}
- unpack ${DOLILO_TAR}
-
- # Fixup things for glibc-2.3.3 (and later CVS versions of 2.3.2)
- epatch ${FILESDIR}/${P}-glibc233.patch
- # Fix building against 2.6 headers
- epatch ${FILESDIR}/${P}-lvm.2-6headers.patch
- # Fix creating install dirs, bug #39405
- epatch ${FILESDIR}/${P}-create-install-dirs.patch
- # Correctly document commandline options -v and -V, bug #43554
- epatch ${FILESDIR}/${P}-correct-usage-info.patch
-}
-
-src_compile() {
-
- # hardened automatic PIC plus PIE building should be suppressed
- # because of assembler instructions that cannot be compiled PIC
- HARDENED_CFLAGS="`test_flag -fno-pic` `test_flag -nopie`"
-
- # we explicitly prevent the custom CFLAGS for stability reasons
- if [ `use static` ]; then
- emake CC="${CC:=gcc} ${HARDENED_CFLAGS}" lilo-static || die
- mv lilo-static lilo || die
- else
- emake CC="${CC:=gcc} ${HARDENED_CFLAGS}" lilo || die
- fi
-}
-
-src_install() {
- keepdir /boot
- make ROOT=${D} install || die
-
- into /
- dosbin ${S}/dolilo/dolilo
-
- into /usr
- dosbin keytab-lilo.pl
-
- insinto /etc
- newins ${FILESDIR}/lilo.conf lilo.conf.example
-
- insinto /etc/conf.d
- newins ${S}/dolilo/dolilo.conf.d dolilo
-
- doman manPages/*.[5-8]
- dodoc CHANGES COPYING INCOMPAT README*
- docinto samples ; dodoc sample/*
-}
-
-# Check whether LILO is installed
-# This function is from /usr/sbin/mkboot from debianutils, with copyright:
-#
-# Debian GNU/Linux
-# Copyright 1996-1997 Guy Maor <maor@debian.org>
-#
-# Modified for Gentoo for use with the lilo ebuild by:
-# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
-#
-lilocheck () {
- local bootpart=
- local rootpart="$(rdev 2> /dev/null | cut -d ' ' -f 1 2> /dev/null)"
-
- echo
- einfon "Checking for LILO ..."
-
- if [ "$(whoami)" != "root" ]
- then
- echo; echo
- eerror "Only root can check for LILO!"
- return 1
- fi
-
- if [ -z "${rootpart}" ]
- then
- echo; echo
- eerror "Could not determine root partition!"
- return 1
- fi
-
- if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
- then
- echo " No"
- return 1
- fi
-
- bootpart="$(perl -ne 'print $1 if /^\s*boot\s*=\s*(\S*)/' /etc/lilo.conf)"
-
- if [ -z "${bootpart}" ]
- then
- # lilo defaults to current root when 'boot=' is not present
- bootpart="${rootpart}"
- fi
-
- if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
- then
- echo; echo
- ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
- ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
- return 1
- fi
-
- echo " Yes, on ${bootpart}"
-
- return 0
-}
-
-
-pkg_postinst() {
- if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
- then
- [ -f "${ROOT}/boot/boot-menu.b" ] && \
- ln -snf boot-menu.b ${ROOT}/boot/boot.b
- fi
-
- if [ "${ROOT}" = "/" ]
- then
- if lilocheck
- then
- einfo "Running DOLILO to complete the install ..."
- # do not redirect to /dev/null because it may display some input
- # prompt
- /sbin/dolilo
- if [ "$?" -ne 0 ]
- then
- echo
- ewarn "Running /sbin/dolilo failed! Please check what the problem is"
- ewarn "before your next reboot."
-
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- sleep 5
- fi
- fi
- echo
- fi
-
- echo
- einfo "Please note that all the loader files (/boot/*.b) are now linked"
- einfo "into LILO, and thus no longer installed."
- einfo "Issue 'dolilo' instead of 'lilo' to have a friendly wrapper that"
- einfo "handles mounting and unmounting /boot for you, and automatically"
- einfo "copies the newest available bzImage in place."
- einfo "Edit /etc/conf.d/dolilo to harness it's full potential."
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- sleep 3
- echo
-}
-