summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-10-23 21:29:46 +0000
committerMike Gilbert <floppym@gentoo.org>2013-10-23 21:29:46 +0000
commit0adbcdec7c58a947fb33489024fe75143e1a2444 (patch)
treefa47c57f5a6ae242c9d80f4f33099706fa689b23 /sys-boot
parentFix USE semantic-desktop by Duncan <1i5t5.duncan@cox.net> wrt bug #489186. (diff)
downloadgentoo-2-0adbcdec7c58a947fb33489024fe75143e1a2444.tar.gz
gentoo-2-0adbcdec7c58a947fb33489024fe75143e1a2444.tar.bz2
gentoo-2-0adbcdec7c58a947fb33489024fe75143e1a2444.zip
Remove build-time dependency on dejavu and unifont by downloading our own copies. Add GRUB_AUTOGEN variable to control autogen separately from autoreconf.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild44
2 files changed, 39 insertions, 12 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index bf0dabf51b63..6f24cb206c86 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.289 2013/10/22 20:44:38 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.290 2013/10/23 21:29:46 floppym Exp $
+
+ 23 Oct 2013; Mike Gilbert <floppym@gentoo.org> grub-9999-r1.ebuild:
+ Remove build-time dependency on dejavu and unifont by downloading our own
+ copies. Add GRUB_AUTOGEN variable to control autogen separately from
+ autoreconf.
*grub-9999-r1 (22 Oct 2013)
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index d969ef069ec1..b36ac3c5e53f 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.1 2013/10/22 20:44:38 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.2 2013/10/23 21:29:46 floppym Exp $
EAPI=5
if [[ ${PV} == 9999 ]]; then
AUTOTOOLS_AUTORECONF=1
+ GRUB_AUTOGEN=1
fi
inherit autotools-utils bash-completion-r1 eutils flag-o-matic mount-boot multibuild pax-utils toolchain-funcs versionator
@@ -29,10 +30,18 @@ else
http://git.savannah.gnu.org/r/grub.git"
fi
+DEJAVU=dejavu-sans-ttf-2.34
+UNIFONT=unifont-5.1.20080820.pcf
+SRC_URI+=" truetype? (
+ mirror://sourceforge/dejavu/${DEJAVU}.zip
+ http://unifoundry.com/${UNIFONT}.gz
+)"
+
DESCRIPTION="GNU GRUB boot loader"
HOMEPAGE="http://www.gnu.org/software/grub/"
-LICENSE="GPL-3"
+# Includes licenses for dejavu and unifont
+LICENSE="GPL-3 truetype? ( BitstreamVera GPL-2-with-font-exception )"
SLOT="2"
IUSE="custom-cflags debug device-mapper doc efiemu mount +multislot nls static sdl test truetype libzfs"
@@ -64,9 +73,7 @@ RDEPEND="
device-mapper? ( >=sys-fs/lvm2-2.02.45 )
libzfs? ( sys-fs/zfs )
mount? ( sys-fs/fuse )
- truetype? (
- media-libs/freetype
- )
+ truetype? ( media-libs/freetype )
ppc? ( sys-apps/ibm-powerpc-utils sys-apps/powerpc-utils )
ppc64? ( sys-apps/ibm-powerpc-utils sys-apps/powerpc-utils )
"
@@ -89,10 +96,6 @@ DEPEND="${RDEPEND}
dev-libs/libisoburn
app-emulation/qemu
)
- truetype? (
- media-fonts/dejavu
- >=media-fonts/unifont-5
- )
"
RDEPEND+="
kernel_linux? (
@@ -102,7 +105,7 @@ RDEPEND+="
!multislot? ( !sys-boot/grub:0 )
"
-if [[ -n ${AUTOTOOLS_AUTORECONF} ]]; then
+if [[ -n ${GRUB_AUTOGEN} ]]; then
DEPEND+=" >=sys-devel/autogen-5.10"
fi
@@ -140,6 +143,13 @@ pkg_pretend() {
fi
}
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ fi
+ default_src_unpack
+}
+
src_prepare() {
[[ ${PATCHES} ]] && epatch "${PATCHES[@]}"
sed -i -e /autoreconf/d autogen.sh || die
@@ -148,13 +158,20 @@ src_prepare() {
sed -i -e 's/^\* GRUB:/* GRUB2:/' -e 's/(grub)/(grub2)/' docs/grub.texi || die
fi
epatch_user
- if [[ -n ${AUTOTOOLS_AUTORECONF} ]]; then
+ if [[ -n ${GRUB_AUTOGEN} ]]; then
bash autogen.sh || die
+ fi
+ if [[ -n ${AUTOTOOLS_AUTORECONF} ]]; then
autopoint() { return 0; }
eautoreconf
fi
}
+setup_fonts() {
+ ln -s "${WORKDIR}/${DEJAVU}/ttf/DejaVuSans.ttf" DejaVuSans.ttf || die
+ ln -s "${WORKDIR}/${UNIFONT}" unifont.pcf || die
+}
+
grub_configure() {
local platform
@@ -199,6 +216,11 @@ grub_configure() {
myeconfargs+=( --program-transform-name="s,grub,grub2," )
fi
+ if use truetype; then
+ mkdir -p "${BUILD_DIR}" || die
+ run_in_build_dir setup_fonts
+ fi
+
autotools-utils_src_configure
}