summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2012-06-20 13:54:25 +0000
committerJoseph Jezak <josejx@gentoo.org>2012-06-20 13:54:25 +0000
commitc79afcb41551c9759e39203b8f91c81200eaecdd (patch)
treedc54518dcf959842c34f03de3ebb36360154a058 /sys-boot/yaboot
parentVersion bump. (diff)
downloadgentoo-2-c79afcb41551c9759e39203b8f91c81200eaecdd.tar.gz
gentoo-2-c79afcb41551c9759e39203b8f91c81200eaecdd.tar.bz2
gentoo-2-c79afcb41551c9759e39203b8f91c81200eaecdd.zip
Added more stub functions for newer e2fsprogs, marked stable.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/yaboot')
-rw-r--r--sys-boot/yaboot/ChangeLog6
-rw-r--r--sys-boot/yaboot/files/yaboot-stubfuncs.patch47
-rw-r--r--sys-boot/yaboot/yaboot-1.3.17-r2.ebuild4
3 files changed, 44 insertions, 13 deletions
diff --git a/sys-boot/yaboot/ChangeLog b/sys-boot/yaboot/ChangeLog
index 264ed9bf3d2c..71a2dd9084d0 100644
--- a/sys-boot/yaboot/ChangeLog
+++ b/sys-boot/yaboot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/yaboot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.43 2012/05/15 15:17:48 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.44 2012/06/20 13:54:25 josejx Exp $
+
+ 20 Jun 2012; Joseph Jezak <josejx@gentoo.org> yaboot-1.3.17-r2.ebuild,
+ files/yaboot-stubfuncs.patch:
+ Added more stub functions for newer e2fsprogs, marked stable.
15 May 2012; Joseph Jezak <josejx@gentoo.org> yaboot-1.3.17-r1.ebuild:
Marked ppc stable quickly to fix build problems in the stable tree.
diff --git a/sys-boot/yaboot/files/yaboot-stubfuncs.patch b/sys-boot/yaboot/files/yaboot-stubfuncs.patch
index ae78202bde37..55724c3edda2 100644
--- a/sys-boot/yaboot/files/yaboot-stubfuncs.patch
+++ b/sys-boot/yaboot/files/yaboot-stubfuncs.patch
@@ -1,7 +1,5 @@
-diff --git a/lib/malloc.c b/lib/malloc.c
-index 0121112..e6b29c4 100644
---- a/lib/malloc.c
-+++ b/lib/malloc.c
+--- lib/malloc.c
++++ lib/malloc.c
@@ -64,6 +64,15 @@ void *malloc (unsigned int size)
return caddr;
}
@@ -18,11 +16,9 @@ index 0121112..e6b29c4 100644
/* Do not fall back to the malloc above as posix_memalign is needed by
* external libraries not yaboot */
int posix_memalign(void **memptr, size_t alignment, size_t size)
-diff --git a/lib/nonstd.c b/lib/nonstd.c
-index 5aeb0cb..b536180 100644
---- a/lib/nonstd.c
-+++ b/lib/nonstd.c
-@@ -65,3 +65,147 @@ char *getenv(const char *name)
+--- lib/nonstd.c 2012-06-20 09:38:54.000000000 -0400
++++ lib/nonstd.c 2012-06-20 09:38:57.000000000 -0400
+@@ -65,3 +65,178 @@
{
return NULL;
}
@@ -44,14 +40,22 @@ index 5aeb0cb..b536180 100644
+ return prom_read((void *)fd, buf, count);
+}
+
++int write(int fd, void *buf, size_t count) {
++ return prom_write((void *)fd, buf, count);
++}
++
+int close(int fd) {
+ prom_close((void *)fd);
+ return 0;
+}
+
++// No fsync, just assume we've sync'd
++int fsync(int fd) {
++ return 0;
++}
++
+void exit(int status) {
+ prom_exit();
-+ return;
+}
+
+int __printf_chk(int flag, const char *format, ...) {
@@ -167,6 +171,29 @@ index 5aeb0cb..b536180 100644
+ return 0;
+}
+
++int ioctl(int d, int request, ...) {
++ return 0;
++}
++
++int fallocate(int fd, int mode, unsigned int offset, unsigned int len) {
++ return 0;
++}
++
++int uname(void *buf) {
++ return 0;
++}
++
++int setrlimit(int resource, void *rlim) {
++ return 0;
++}
++
++unsigned long long int strtoull(const char *nptr, char **endptr, int base) {
++ return 0;
++}
++
++int getrlimit(int resource, void *rlim) {
++ return 0;
++}
+
+int stderr = 0;
+int perror = 0;
diff --git a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
index 10a60ac85ac8..b499e2de1cd0 100644
--- a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.1 2012/05/12 03:08:26 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.2 2012/06/20 13:54:25 josejx Exp $
EAPI=2
@@ -11,7 +11,7 @@ SRC_URI="http://yaboot.ozlabs.org/releases/${P}.tar.gz"
HOMEPAGE="http://yaboot.ozlabs.org"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="-* ~ppc -ppc64"
+KEYWORDS="-* ppc -ppc64"
IUSE="ibm"
DEPEND="sys-apps/powerpc-utils