summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-05-15 18:33:46 +0000
committerJeroen Roovers <jer@gentoo.org>2009-05-15 18:33:46 +0000
commit5720ac3f6cfca57a7a0fade4c5edd8fa73cd110d (patch)
treeeab277c29ef31302bbb14977993c2f0d1968e9f8 /sys-boot/syslinux
parentx11-libs/qt-webkit-4.5.1 does not compile on alpha (bug 269739), the meta ebu... (diff)
downloadgentoo-2-5720ac3f6cfca57a7a0fade4c5edd8fa73cd110d.tar.gz
gentoo-2-5720ac3f6cfca57a7a0fade4c5edd8fa73cd110d.tar.bz2
gentoo-2-5720ac3f6cfca57a7a0fade4c5edd8fa73cd110d.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/ChangeLog7
-rw-r--r--sys-boot/syslinux/syslinux-3.80.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index e40bf3eb1cb0..61455355f15f 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.43 2009/04/29 15:51:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.44 2009/05/15 18:33:46 jer Exp $
+
+*syslinux-3.80 (15 May 2009)
+
+ 15 May 2009; Jeroen Roovers <jer@gentoo.org> +syslinux-3.80.ebuild:
+ Version bump.
*syslinux-3.75 (29 Apr 2009)
diff --git a/sys-boot/syslinux/syslinux-3.80.ebuild b/sys-boot/syslinux/syslinux-3.80.ebuild
new file mode 100644
index 000000000000..69fec3892343
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.80.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.80.ebuild,v 1.1 2009/05/15 18:33:46 jer Exp $
+
+inherit eutils
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.72-nopie.patch
+ # Don't prestrip, makes portage angry
+ epatch "${FILESDIR}"/${PN}-3.72-nostrip.patch
+
+ rm -f gethostip #bug 137081
+}
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" MANDIR=/usr/share/man local-install || die
+ dodoc README NEWS TODO doc/*
+}