summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2007-07-24 15:18:29 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2007-07-24 15:18:29 +0000
commite57bb3cbd6ee10010fff939428c8f4a5326ff47f (patch)
tree17706185e7d06da5395700c1e23605d31c0859a1 /sys-boot/silo
parentMight as well use correct CC, CFLAGS and dep on pkgconfig while at it. Talkin... (diff)
downloadgentoo-2-e57bb3cbd6ee10010fff939428c8f4a5326ff47f.tar.gz
gentoo-2-e57bb3cbd6ee10010fff939428c8f4a5326ff47f.tar.bz2
gentoo-2-e57bb3cbd6ee10010fff939428c8f4a5326ff47f.zip
Revbump wrt #181174 and #186204
(Portage version: 2.1.2.9)
Diffstat (limited to 'sys-boot/silo')
-rw-r--r--sys-boot/silo/ChangeLog8
-rw-r--r--sys-boot/silo/files/digest-silo-1.4.13-r13
-rw-r--r--sys-boot/silo/silo-1.4.13-r1.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-boot/silo/ChangeLog b/sys-boot/silo/ChangeLog
index 7bb886adfef4..5c245a154269 100644
--- a/sys-boot/silo/ChangeLog
+++ b/sys-boot/silo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/silo
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.35 2007/02/07 14:40:05 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.36 2007/07/24 15:18:29 gustavoz Exp $
+
+*silo-1.4.13-r1 (24 Jul 2007)
+
+ 24 Jul 2007; Gustavo Zacarias <gustavoz@gentoo.org>
+ +silo-1.4.13-r1.ebuild:
+ Revbump wrt #181174 and #186204
07 Feb 2007; Gustavo Zacarias <gustavoz@gentoo.org> silo-1.4.13.ebuild:
Fix build bug #162537
diff --git a/sys-boot/silo/files/digest-silo-1.4.13-r1 b/sys-boot/silo/files/digest-silo-1.4.13-r1
new file mode 100644
index 000000000000..e372756a69a4
--- /dev/null
+++ b/sys-boot/silo/files/digest-silo-1.4.13-r1
@@ -0,0 +1,3 @@
+MD5 4db19e2835c27683fcae46ed93358f3c silo-1.4.13-r1.tar.bz2 148563
+RMD160 bb34e3d1f2c5377833ac0a590af56bb29311a797 silo-1.4.13-r1.tar.bz2 148563
+SHA256 d1b9964f3305e0f4e808d6a836322f0ad9cd474336b5ee252de889eb9d1a4605 silo-1.4.13-r1.tar.bz2 148563
diff --git a/sys-boot/silo/silo-1.4.13-r1.ebuild b/sys-boot/silo/silo-1.4.13-r1.ebuild
new file mode 100644
index 000000000000..8194e24e849a
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.13-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.13-r1.ebuild,v 1.1 2007/07/24 15:18:29 gustavoz Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://dev.gentoo.org/~gustavoz/dist/${PF}.tar.bz2"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* sparc"
+IUSE="hardened"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+ABI_ALLOW="sparc32"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/silo-1.4.x-noglibc_time.patch
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ if use hardened
+ then
+ make ${MAKEOPTS} CC="$(tc-getCC) -fno-stack-protector -fno-pic"
+ else
+ make ${MAKEOPTS} CC="$(tc-getCC)" || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm ${D}/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+}