summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2012-07-29 16:26:30 +0000
committerRaúl Porcel <armin76@gentoo.org>2012-07-29 16:26:30 +0000
commitca87a8efd76aeedafd7902989145f2d707e4ce5d (patch)
tree3f77c6545475deefa67ed0d55ff2fe7f100bfc3a /sys-boot/silo
parentAdd missing slot dependencies on Qt. (diff)
downloadgentoo-2-ca87a8efd76aeedafd7902989145f2d707e4ce5d.tar.gz
gentoo-2-ca87a8efd76aeedafd7902989145f2d707e4ce5d.tar.bz2
gentoo-2-ca87a8efd76aeedafd7902989145f2d707e4ce5d.zip
Verion bump, bug #412197, straight to stable
(Portage version: 2.1.11.5/cvs/Linux ia64, RepoMan options: --force)
Diffstat (limited to 'sys-boot/silo')
-rw-r--r--sys-boot/silo/ChangeLog7
-rw-r--r--sys-boot/silo/silo-1.4.14_p20120226.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/sys-boot/silo/ChangeLog b/sys-boot/silo/ChangeLog
index d8c2c5e37104..69fd692199d7 100644
--- a/sys-boot/silo/ChangeLog
+++ b/sys-boot/silo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/silo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.48 2012/05/24 05:12:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.49 2012/07/29 16:26:30 armin76 Exp $
+
+*silo-1.4.14_p20120226 (29 Jul 2012)
+
+ 29 Jul 2012; Raúl Porcel <armin76@gentoo.org> +silo-1.4.14_p20120226.ebuild:
+ Verion bump, bug #412197, straight to stable
24 May 2012; Mike Frysinger <vapier@gentoo.org> silo-1.4.14_p20100228.ebuild:
Inherit eutils for epatch.
diff --git a/sys-boot/silo/silo-1.4.14_p20120226.ebuild b/sys-boot/silo/silo-1.4.14_p20120226.ebuild
new file mode 100644
index 000000000000..a06585701483
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.14_p20120226.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.14_p20120226.ebuild,v 1.1 2012/07/29 16:26:30 armin76 Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs eutils
+
+DEB_PL="1"
+MY_PV="${PV##*_p}"
+MY_GIT="git${MY_PV%%_*}"
+MY_PV="${PV%%_*}"
+MY_P="${PN}_${MY_PV}+${MY_GIT}"
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/s/${PN}/${MY_P}-${DEB_PL}.diff.gz"
+HOMEPAGE="http://git.kernel.org/?p=linux/kernel/git/davem/silo.git;a=summary"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* sparc"
+IUSE="hardened"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+ABI_ALLOW="sparc32"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #Set the correct version
+ sed -i -e "s/1.4.14/1.4.14_git2012226_p1/g" Rules.make
+
+ # Fix build failure
+ sed -i -e "s/-fno-strict-aliasing/-fno-strict-aliasing -U_FORTIFY_SOURCE -mcpu=v9/g" Rules.make
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ if use hardened
+ then
+ make ${MAKEOPTS} CC="$(tc-getCC) -fno-stack-protector -fno-pic"
+ else
+ make ${MAKEOPTS} CC="$(tc-getCC)" || die
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm "${D}"/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ mount-boot_pkg_postinst
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+ ewarn
+ ewarn "Support for EXT4 is broken, you've been warned!!"
+}