summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-05-15 15:00:51 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-05-15 15:00:51 +0000
commitaf797755c14c98fa7531a9281205c805ceb9636e (patch)
tree204ffcad2143bfdd53410196b12610b4deec0ff7 /sys-boot/silo
parentremoved python-fuse, a bit early admitted. (diff)
downloadgentoo-2-af797755c14c98fa7531a9281205c805ceb9636e.tar.gz
gentoo-2-af797755c14c98fa7531a9281205c805ceb9636e.tar.bz2
gentoo-2-af797755c14c98fa7531a9281205c805ceb9636e.zip
Version bump, using debian patchset and snapshot from git
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'sys-boot/silo')
-rw-r--r--sys-boot/silo/ChangeLog11
-rw-r--r--sys-boot/silo/files/sanitized-linuxheaders.patch13
-rw-r--r--sys-boot/silo/silo-1.4.13-r1.ebuild14
-rw-r--r--sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild70
4 files changed, 99 insertions, 9 deletions
diff --git a/sys-boot/silo/ChangeLog b/sys-boot/silo/ChangeLog
index 5c245a154269..a949727c4c6a 100644
--- a/sys-boot/silo/ChangeLog
+++ b/sys-boot/silo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/silo
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.36 2007/07/24 15:18:29 gustavoz Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.37 2008/05/15 15:00:51 armin76 Exp $
+
+*silo-1.4.13a_pre20070930_p2 (15 May 2008)
+
+ 15 May 2008; Raúl Porcel <armin76@gentoo.org>
+ +files/sanitized-linuxheaders.patch, silo-1.4.13-r1.ebuild,
+ +silo-1.4.13a_pre20070930_p2.ebuild:
+ Version bump, using debian patchset and snapshot from git
*silo-1.4.13-r1 (24 Jul 2007)
diff --git a/sys-boot/silo/files/sanitized-linuxheaders.patch b/sys-boot/silo/files/sanitized-linuxheaders.patch
new file mode 100644
index 000000000000..3de1c0331e0b
--- /dev/null
+++ b/sys-boot/silo/files/sanitized-linuxheaders.patch
@@ -0,0 +1,13 @@
+diff -ur silo.orig/second/main.c silo/second/main.c
+--- silo.orig/second/main.c 2008-05-04 20:44:35.493619781 +0000
++++ silo/second/main.c 2008-05-04 20:44:50.113166947 +0000
+@@ -25,8 +25,7 @@
+ /* TODO: This file is a good candidate for rewrite from scratch. */
+
+ #include <silo.h>
+-#include <asm/page.h>
+-#include <linux/elf.h>
++#include <elf.h>
+ #include <stringops.h>
+
+ #ifndef NULL
diff --git a/sys-boot/silo/silo-1.4.13-r1.ebuild b/sys-boot/silo/silo-1.4.13-r1.ebuild
index 8194e24e849a..620ef8851cdb 100644
--- a/sys-boot/silo/silo-1.4.13-r1.ebuild
+++ b/sys-boot/silo/silo-1.4.13-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.13-r1.ebuild,v 1.1 2007/07/24 15:18:29 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.13-r1.ebuild,v 1.2 2008/05/15 15:00:51 armin76 Exp $
inherit mount-boot flag-o-matic toolchain-funcs
@@ -22,8 +22,8 @@ ABI_ALLOW="sparc32"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/silo-1.4.x-noglibc_time.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/silo-1.4.x-noglibc_time.patch
}
src_compile() {
@@ -38,11 +38,11 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+ make DESTDIR="${D}" install || die
+ dodoc first-isofs/README.SILO_ISOFS docs/README*
# Fix maketilo manpage
- rm ${D}/usr/share/man/man1/maketilo.1
+ rm "${D}"/usr/share/man/man1/maketilo.1
dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
}
diff --git a/sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild b/sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild
new file mode 100644
index 000000000000..a905333d0d93
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild,v 1.1 2008/05/15 15:00:51 armin76 Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs
+
+DEB_PL="${P##*_p}"
+MY_PV="${PV##*_pre}"
+MY_GIT="git${MY_PV%%_*}"
+MY_PV="${PV%%_*}"
+MY_P="${PN}_${MY_PV}+${MY_GIT}"
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/s/${PN}/${MY_P}-${DEB_PL}.diff.gz"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+IUSE="hardened"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+ABI_ALLOW="sparc32"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${MY_P}-${DEB_PL}.diff
+
+ cd "${S}"
+ epatch "${WORKDIR}"/${MY_P/_/-}/debian/patches/*.patch
+ epatch "${FILESDIR}"/sanitized-linuxheaders.patch
+
+ #Set the correct version
+ sed -i -e "s/1.4.13/1.4.13_git20070830_p2/g" Rules.make
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ if use hardened
+ then
+ make ${MAKEOPTS} CC="$(tc-getCC) -fno-stack-protector -fno-pic"
+ else
+ make ${MAKEOPTS} CC="$(tc-getCC)" || die
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm "${D}"/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+}