summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFriedrich Oslage <bluebird@gentoo.org>2008-08-06 19:13:53 +0000
committerFriedrich Oslage <bluebird@gentoo.org>2008-08-06 19:13:53 +0000
commit570e3e23c62a01807f2a6a09f6f5c21e0f3e705d (patch)
treeee5a533b5ceb2e9a4dc1505896f165ad5860fc7b /sys-boot/silo
parentadd GLEP 56 USE flag desc from use.local.desc (diff)
downloadgentoo-2-570e3e23c62a01807f2a6a09f6f5c21e0f3e705d.tar.gz
gentoo-2-570e3e23c62a01807f2a6a09f6f5c21e0f3e705d.tar.bz2
gentoo-2-570e3e23c62a01807f2a6a09f6f5c21e0f3e705d.zip
Version bump, set HOMEPAGE to something more useful
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r7 sparc64)
Diffstat (limited to 'sys-boot/silo')
-rw-r--r--sys-boot/silo/ChangeLog8
-rw-r--r--sys-boot/silo/files/qa-no-strip.patch11
-rw-r--r--sys-boot/silo/silo-1.4.14.ebuild67
3 files changed, 85 insertions, 1 deletions
diff --git a/sys-boot/silo/ChangeLog b/sys-boot/silo/ChangeLog
index 6ceedaf63bd0..edbd29c03c96 100644
--- a/sys-boot/silo/ChangeLog
+++ b/sys-boot/silo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/silo
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.39 2008/06/12 20:33:51 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.40 2008/08/06 19:13:53 bluebird Exp $
+
+*silo-1.4.14 (06 Aug 2008)
+
+ 06 Aug 2008; Friedrich Oslage <bluebird@gentoo.org>
+ +files/qa-no-strip.patch, +silo-1.4.14.ebuild:
+ Version bump, set HOMEPAGE to something more useful
12 Jun 2008; Friedrich Oslage <bluebird@gentoo.org>
+files/gcc-4.3-compile.patch, silo-1.4.13-r1.ebuild,
diff --git a/sys-boot/silo/files/qa-no-strip.patch b/sys-boot/silo/files/qa-no-strip.patch
new file mode 100644
index 000000000000..ea01e2ed10b7
--- /dev/null
+++ b/sys-boot/silo/files/qa-no-strip.patch
@@ -0,0 +1,11 @@
+--- Rules.make
++++ Rules.make
+@@ -6,7 +6,7 @@
+ CC=gcc -m32
+ LD=ld -m elf32_sparc
+ AS=as
+-STRIP=strip
++STRIP=true
+ NM=nm
+ ELFTOAOUT=elftoaout
+ BIN2H=../common/bin2h
diff --git a/sys-boot/silo/silo-1.4.14.ebuild b/sys-boot/silo/silo-1.4.14.ebuild
new file mode 100644
index 000000000000..05865d4b6ed0
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.14.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.14.ebuild,v 1.1 2008/08/06 19:13:53 bluebird Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="mirror://ubuntu/pool/main/s/${PN}/${PN}_${PV}.orig.tar.gz"
+
+# the sourceforge project is dead. there is no homepage other than gitweb :(
+HOMEPAGE="http://git.kernel.org/?p=linux/kernel/git/bcollins/silo.git;a=summary"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+IUSE="hardened"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+ABI_ALLOW="sparc32"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # Sanitized headers bug #162537
+ epatch "${FILESDIR}"/sanitized-linuxheaders.patch
+
+ epatch "${FILESDIR}"/silo-1.4.x-noglibc_time.patch
+
+ # make it compile with gcc 4.3
+ epatch "${FILESDIR}"/gcc-4.3-compile.patch
+
+ # don't strip binaries, let portage handle it!
+ epatch "${FILESDIR}"/qa-no-strip.patch
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ if use hardened
+ then
+ make ${MAKEOPTS} CC="$(tc-getCC) -fno-stack-protector -fno-pic"
+ else
+ make ${MAKEOPTS} CC="$(tc-getCC)" || die
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm "${D}"/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+}