summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-12-29 04:22:44 +0000
committerJason Wever <weeve@gentoo.org>2003-12-29 04:22:44 +0000
commit6e88aac0d0e179991a9c1430a4137c0f00d24902 (patch)
tree4778fb73fd9821605997c750fafb8377b9c37de3 /sys-boot/silo/silo-1.3.1-r1.ebuild
parentAdded the mount-boot eclass to the silo ebuilds. Thanks for fo0bar from #gen... (diff)
downloadgentoo-2-6e88aac0d0e179991a9c1430a4137c0f00d24902.tar.gz
gentoo-2-6e88aac0d0e179991a9c1430a4137c0f00d24902.tar.bz2
gentoo-2-6e88aac0d0e179991a9c1430a4137c0f00d24902.zip
Added the mount-boot eclass to the silo ebuilds. Thanks for fo0bar from #gentoo-sparc for pointing this out. Also fixed ebuilds so maketilo manpage gets installed in such a fashion that it's usable.
Diffstat (limited to 'sys-boot/silo/silo-1.3.1-r1.ebuild')
-rw-r--r--sys-boot/silo/silo-1.3.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-boot/silo/silo-1.3.1-r1.ebuild b/sys-boot/silo/silo-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..b08bcba8326b
--- /dev/null
+++ b/sys-boot/silo/silo-1.3.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.3.1-r1.ebuild,v 1.1 2003/12/29 04:22:36 weeve Exp $
+
+inherit mount-boot
+
+S=${WORKDIR}/${P}
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://www.sparc-boot.org/pub/silo/${P}.tar.gz"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* sparc"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+src_compile() {
+ make ${MAKEOPTS} || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm ${D}/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}