summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-07-23 06:20:20 +0000
committerMichael Weber <xmw@gentoo.org>2013-07-23 06:20:20 +0000
commit9eef3f756f9cffeaa71e2085af803d9c7d7222d3 (patch)
tree68920ccc22b84e0659e3cf79d81244c264bc36cf /sys-boot/raspberrypi-firmware
parentVersion bump (diff)
downloadgentoo-2-9eef3f756f9cffeaa71e2085af803d9c7d7222d3.tar.gz
gentoo-2-9eef3f756f9cffeaa71e2085af803d9c7d7222d3.tar.bz2
gentoo-2-9eef3f756f9cffeaa71e2085af803d9c7d7222d3.zip
Version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sys-boot/raspberrypi-firmware')
-rw-r--r--sys-boot/raspberrypi-firmware/ChangeLog8
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1_pre20130720.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/sys-boot/raspberrypi-firmware/ChangeLog b/sys-boot/raspberrypi-firmware/ChangeLog
index 58f4bb26902a..fef7f13882e8 100644
--- a/sys-boot/raspberrypi-firmware/ChangeLog
+++ b/sys-boot/raspberrypi-firmware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/raspberrypi-firmware
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/ChangeLog,v 1.5 2013/07/23 06:14:33 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/ChangeLog,v 1.6 2013/07/23 06:20:20 xmw Exp $
+
+*raspberrypi-firmware-1_pre20130720 (23 Jul 2013)
+
+ 23 Jul 2013; Michael Weber <xmw@gentoo.org>
+ +raspberrypi-firmware-1_pre20130720.ebuild:
+ Version bump
*raspberrypi-firmware-0_p20130722 (23 Jul 2013)
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1_pre20130720.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1_pre20130720.ebuild
new file mode 100644
index 000000000000..de5e59557c2c
--- /dev/null
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1_pre20130720.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1_pre20130720.ebuild,v 1.1 2013/07/23 06:20:20 xmw Exp $
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="Raspberry PI boot loader and firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_COMMIT="9e9acf8978"
+MY_COMMIT="ff57475a21"
+SRC_URI=""
+for my_src_uri in bootcode.bin fixup{,_cd,_x}.dat start{,_cd,_x}.elf ; do
+ SRC_URI="${SRC_URI} https://github.com/raspberrypi/firmware/raw/${MY_COMMIT}/boot/${my_src_uri} -> ${PN}-${MY_COMMIT}-${my_src_uri}"
+done
+
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="~arm -*"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!sys-boot/raspberrypi-loader"
+
+S=${WORKDIR}
+
+RESTRICT="binchecks strip"
+
+src_unpack() { :; }
+
+pkg_preinst() {
+ if [ -z "${REPLACING_VERSIONS}" ] ; then
+ local msg=""
+ if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
+ msg+="/boot/cmdline.txt "
+ fi
+ if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
+ msg+="/boot/config.txt "
+ fi
+ if [ -n "${msg}" ] ; then
+ msg="This package installs following files: ${msg}."
+ msg="${msg} Please remove(backup) your copies durning install"
+ msg="${msg} and merge settings afterwards."
+ msg="${msg} Further updates will be CONFIG_PROTECTed."
+ die "${msg}"
+ fi
+ fi
+}
+
+src_install() {
+ insinto /boot
+ local a
+ for a in ${A} ; do
+ newins "${DISTDIR}"/${a} ${a#${PN}-${MY_COMMIT}-}
+ done
+ newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
+ newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
+ newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"