summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-08-15 18:29:55 +0000
committerMichael Weber <xmw@gentoo.org>2013-08-15 18:29:55 +0000
commit726f47c77554cdb1ac52921ffbaabec9f528f74e (patch)
treeaab1bc4db35e96e9b16f5aebf772b39733fdd91c /sys-boot/raspberrypi-firmware
parentImproving multilib for libsepol, see bug #480960 (diff)
downloadgentoo-2-726f47c77554cdb1ac52921ffbaabec9f528f74e.tar.gz
gentoo-2-726f47c77554cdb1ac52921ffbaabec9f528f74e.tar.bz2
gentoo-2-726f47c77554cdb1ac52921ffbaabec9f528f74e.zip
Version bump to newest master version.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sys-boot/raspberrypi-firmware')
-rw-r--r--sys-boot/raspberrypi-firmware/ChangeLog8
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130815.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/sys-boot/raspberrypi-firmware/ChangeLog b/sys-boot/raspberrypi-firmware/ChangeLog
index 621836d6e00d..998103a4c9d0 100644
--- a/sys-boot/raspberrypi-firmware/ChangeLog
+++ b/sys-boot/raspberrypi-firmware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/raspberrypi-firmware
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/ChangeLog,v 1.8 2013/08/15 18:21:47 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/ChangeLog,v 1.9 2013/08/15 18:29:55 xmw Exp $
+
+*raspberrypi-firmware-0_p20130815 (15 Aug 2013)
+
+ 15 Aug 2013; Michael Weber <xmw@gentoo.org>
+ +raspberrypi-firmware-0_p20130815.ebuild:
+ Version bump to newest master version.
*raspberrypi-firmware-1_pre20130807 (15 Aug 2013)
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130815.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130815.ebuild
new file mode 100644
index 000000000000..3fee802d4851
--- /dev/null
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130815.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130815.ebuild,v 1.1 2013/08/15 18:29:55 xmw Exp $
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="Raspberry PI boot loader and firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_COMMIT="e0590d6dda"
+SRC_URI=""
+for my_src_uri in bootcode.bin fixup{,_cd,_x}.dat start{,_cd,_x}.elf ; do
+ SRC_URI="${SRC_URI} https://github.com/raspberrypi/firmware/raw/${MY_COMMIT}/boot/${my_src_uri} -> ${PN}-${MY_COMMIT}-${my_src_uri}"
+done
+
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="~arm -*"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+RESTRICT="binchecks strip"
+
+src_unpack() { :; }
+
+pkg_preinst() {
+ if [ -z "${REPLACING_VERSIONS}" ] ; then
+ local msg=""
+ if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
+ msg+="/boot/cmdline.txt "
+ fi
+ if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
+ msg+="/boot/config.txt "
+ fi
+ if [ -n "${msg}" ] ; then
+ msg="This package installs following files: ${msg}."
+ msg="${msg} Please remove(backup) your copies durning install"
+ msg="${msg} and merge settings afterwards."
+ msg="${msg} Further updates will be CONFIG_PROTECTed."
+ die "${msg}"
+ fi
+ fi
+}
+
+src_install() {
+ insinto /boot
+ local a
+ for a in ${A} ; do
+ newins "${DISTDIR}"/${a} ${a#${PN}-${MY_COMMIT}-}
+ done
+ newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
+ newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
+ newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"