summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-10-18 09:57:50 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-10-18 09:57:50 +0000
commitbbaa64485519c3d3f2852a5f3831de23e192d15c (patch)
tree83a8ca95d40d96d05224c483f232b6aa80d704c5 /sys-boot/plymouth
parentVersion bump. (diff)
downloadgentoo-2-bbaa64485519c3d3f2852a5f3831de23e192d15c.tar.gz
gentoo-2-bbaa64485519c3d3f2852a5f3831de23e192d15c.tar.bz2
gentoo-2-bbaa64485519c3d3f2852a5f3831de23e192d15c.zip
sys-boot/plymouth: Pre 0.9 snapshot ebuild.
Pre 0.9 snapshot ebuild based on latest git sources. It introduces libkms. EAPI bumped to 4. (Portage version: 2.1.10.27/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/plymouth')
-rw-r--r--sys-boot/plymouth/ChangeLog11
-rw-r--r--sys-boot/plymouth/files/0.9_pre20111013-gentoo-fb-path.patch25
-rw-r--r--sys-boot/plymouth/metadata.xml2
-rw-r--r--sys-boot/plymouth/plymouth-0.9_pre20111013.ebuild82
4 files changed, 119 insertions, 1 deletions
diff --git a/sys-boot/plymouth/ChangeLog b/sys-boot/plymouth/ChangeLog
index 9ca5ce0bef24..0a28074abef3 100644
--- a/sys-boot/plymouth/ChangeLog
+++ b/sys-boot/plymouth/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-boot/plymouth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.14 2011/07/03 10:06:14 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.15 2011/10/18 09:57:50 aidecoe Exp $
+
+*plymouth-0.9_pre20111013 (18 Oct 2011)
+
+ 18 Oct 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +files/0.9_pre20111013-gentoo-fb-path.patch,
+ +plymouth-0.9_pre20111013.ebuild, metadata.xml:
+ Pre 0.9 snapshot ebuild based on latest git sources. It introduces libkms.
+
+ EAPI bumped to 4.
*plymouth-0.8.3-r5 (03 Jul 2011)
diff --git a/sys-boot/plymouth/files/0.9_pre20111013-gentoo-fb-path.patch b/sys-boot/plymouth/files/0.9_pre20111013-gentoo-fb-path.patch
new file mode 100644
index 000000000000..cb0f0d5af3bb
--- /dev/null
+++ b/sys-boot/plymouth/files/0.9_pre20111013-gentoo-fb-path.patch
@@ -0,0 +1,25 @@
+From 5fd3ed5a1f661eb1d99e1d4df5edad8410cc54e3 Mon Sep 17 00:00:00 2001
+From: root <root@christoph.egore.lan>
+Date: Sun, 25 Oct 2009 03:55:54 +0100
+Subject: [PATCH] Gentoo does not have /dev/fb, but /dev/fb0 (at least on i915 KMS)
+
+---
+ src/plugins/renderers/frame-buffer/plugin.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/libply/ply-frame-buffer.c b/src/libply/ply-frame-buffer.c
+index a1e4fcd..19aab4b 100644
+--- a/src/plugins/renderers/frame-buffer/plugin.c
++++ b/src/plugins/renderers/frame-buffer/plugin.c
+@@ -46,7 +46,7 @@
+ #include <linux/fb.h>
+
+ #ifndef PLY_FRAME_BUFFER_DEFAULT_FB_DEVICE_NAME
+-#define PLY_FRAME_BUFFER_DEFAULT_FB_DEVICE_NAME "/dev/fb"
++#define PLY_FRAME_BUFFER_DEFAULT_FB_DEVICE_NAME "/dev/fb0"
+ #endif
+
+ struct _ply_frame_buffer
+--
+1.6.5
+
diff --git a/sys-boot/plymouth/metadata.xml b/sys-boot/plymouth/metadata.xml
index 3f55ebd9f38b..bbd0aa9bdd52 100644
--- a/sys-boot/plymouth/metadata.xml
+++ b/sys-boot/plymouth/metadata.xml
@@ -7,6 +7,8 @@
</maintainer>
<use>
<flag name="gdm">Enables smooth transition to GDM</flag>
+ <flag name="libkms">Provides abstraction to the DRM drivers (intel,
+ nouveau and vmwgfx at this moment)</flag>
<flag name="openrc">Installs plugin for OpenRC</flag>
<flag name="pango">Adds support for printing text on splash screen and
text prompts, e.g. for password</flag>
diff --git a/sys-boot/plymouth/plymouth-0.9_pre20111013.ebuild b/sys-boot/plymouth/plymouth-0.9_pre20111013.ebuild
new file mode 100644
index 000000000000..a6ae170936bc
--- /dev/null
+++ b/sys-boot/plymouth/plymouth-0.9_pre20111013.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.9_pre20111013.ebuild,v 1.1 2011/10/18 09:57:50 aidecoe Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Graphical boot animation (splash) and logger"
+HOMEPAGE="http://cgit.freedesktop.org/plymouth/"
+SRC_URI="
+ http://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2
+ http://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE_VIDEO_CARDS="video_cards_intel video_cards_nouveau video_cards_radeon"
+IUSE="${IUSE_VIDEO_CARDS} gdm +libkms +openrc +pango static-libs"
+
+CDEPEND=">=media-libs/libpng-1.2.16
+ >=x11-libs/gtk+-2.12:2
+ pango? ( >=x11-libs/pango-1.21 )
+ video_cards_intel? ( x11-libs/libdrm[video_cards_intel] )
+ video_cards_nouveau? ( x11-libs/libdrm[video_cards_nouveau] )
+ video_cards_radeon? ( x11-libs/libdrm[video_cards_radeon] )
+ "
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ "
+RDEPEND="${CDEPEND}
+ >=sys-kernel/dracut-008-r1[dracut_modules_plymouth]
+ openrc? ( sys-boot/plymouth-openrc-plugin )
+ "
+
+DOCS=(AUTHORS README TODO)
+PATCHES=(
+ "${FILESDIR}"/${PV}-gentoo-fb-path.patch
+ )
+
+src_prepare() {
+ autotools-utils_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-system-root-install
+ $(use_enable libkms)
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ $(use_enable video_cards_intel libdrm_intel)
+ $(use_enable video_cards_nouveau libdrm_nouveau)
+ $(use_enable video_cards_radeon libdrm_radeon)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use static-libs; then
+ mv "${D}/$(get_libdir)"/libply{,-splash-core}.{a,la} \
+ "${D}/usr/$(get_libdir)"/ || die 'mv *.{a,la} files failed'
+ gen_usr_ldscript libply.so libply-splash-core.so
+ else
+ einfo "Removing /usr/$(get_libdir)/plymouth/*.la"
+ rm "${D}/usr/$(get_libdir)"/plymouth/{*.la,renderers/*.la} \
+ || die 'rm *.la'
+ fi
+
+ insinto /usr/share/plymouth
+ newins "${DISTDIR}"/gentoo-logo.png bizcom.png
+}
+
+pkg_postinst() {
+ elog "Follow instructions on"
+ elog ""
+ elog " http://dev.gentoo.org/~aidecoe/doc/en/plymouth.xml"
+ elog ""
+ elog "to set up Plymouth."
+}