summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2010-07-26 11:00:51 +0000
committerFabio Erculiani <lxnay@gentoo.org>2010-07-26 11:00:51 +0000
commit486a34e315567cf9ce92deb676fe22ef06a07e87 (patch)
tree8844d03bb2310c82b183036b3e5f51c9372ee18b /sys-boot/os-prober
parentBugfix release, closes bug #329771 by Oliver Jaksch. (diff)
downloadgentoo-2-486a34e315567cf9ce92deb676fe22ef06a07e87.tar.gz
gentoo-2-486a34e315567cf9ce92deb676fe22ef06a07e87.tar.bz2
gentoo-2-486a34e315567cf9ce92deb676fe22ef06a07e87.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/os-prober')
-rw-r--r--sys-boot/os-prober/ChangeLog7
-rw-r--r--sys-boot/os-prober/os-prober-1.39.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-boot/os-prober/ChangeLog b/sys-boot/os-prober/ChangeLog
index e3ff4f025e7d..b24b771b26bb 100644
--- a/sys-boot/os-prober/ChangeLog
+++ b/sys-boot/os-prober/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/os-prober
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.4 2010/06/04 02:31:38 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.5 2010/07/26 11:00:51 lxnay Exp $
+
+*os-prober-1.39 (26 Jul 2010)
+
+ 26 Jul 2010; Fabio Erculiani <lxnay@gentoo.org> +os-prober-1.39.ebuild:
+ Version bump
*os-prober-1.38 (04 Jun 2010)
diff --git a/sys-boot/os-prober/os-prober-1.39.ebuild b/sys-boot/os-prober/os-prober-1.39.ebuild
new file mode 100644
index 000000000000..9b0452c27bf3
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.39.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/os-prober-1.39.ebuild,v 1.1 2010/07/26 11:00:51 lxnay Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e "s:/lib/udev:/$(get_libdir)/udev:g" common.sh || die "sed failed on common.sh"
+ find "${S}" -type f -exec sed -i -e "s:/usr/lib/:/usr/libexec/:g" {} + || die "failed on find and sed lib->libexec"
+ sed -i -e "s:/lib/ld\*\.so\*:/lib*/ld*.so*:g" os-probes/mounted/common/90linux-distro || die "sed failed on 90linux-distro"
+
+ # Just use the default rules provided by GNU Make
+ rm Makefile
+}
+
+src_compile() {
+ tc-export CC
+ emake newns || die "emake failed"
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober || die "dobin failed"
+
+ exeinto /usr/libexec/os-prober
+ doexe newns || die "doexe newns failed"
+
+ insinto /usr/share/os-prober
+ doins common.sh || die "doins common.sh failed"
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/libexec/$dir
+ doexe $dir/common/* || die "doexe failed in $dir/common"
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/* || die "doexe failed in $dir/$debarch"
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/libexec/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx || die "doexe failed on 20macosx"
+ fi
+
+ dodoc README TODO debian/changelog || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "If you intend for os-prober to detect versions of Windows installed on"
+ elog "NTFS-formatted partitions, your system must be capable of reading the"
+ elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}