summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-08 23:57:05 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-08 23:57:05 +0000
commit8ddb91f4415ec59e30b6c4a35d601c0872997171 (patch)
tree59717f6bd2be155d1fc84745eb64933e818e68ad /sys-boot/netboot
parentFix for xulrunner-1.9.2 by Ian Stakenvicius, fixes #303183 (diff)
downloadgentoo-2-8ddb91f4415ec59e30b6c4a35d601c0872997171.tar.gz
gentoo-2-8ddb91f4415ec59e30b6c4a35d601c0872997171.tar.bz2
gentoo-2-8ddb91f4415ec59e30b6c4a35d601c0872997171.zip
Version bump, and work around parallel make issue, and respect LDFLAGS (bug #248408).
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sys-boot/netboot')
-rw-r--r--sys-boot/netboot/ChangeLog11
-rw-r--r--sys-boot/netboot/files/netboot-0.10.2-ldflags.patch38
-rw-r--r--sys-boot/netboot/netboot-0.10.2.ebuild51
3 files changed, 98 insertions, 2 deletions
diff --git a/sys-boot/netboot/ChangeLog b/sys-boot/netboot/ChangeLog
index 31bf24e79fcb..538a9b324b3b 100644
--- a/sys-boot/netboot/ChangeLog
+++ b/sys-boot/netboot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/netboot
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/ChangeLog,v 1.6 2008/11/13 20:02:53 bangert Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/ChangeLog,v 1.7 2010/02/08 23:57:04 jer Exp $
+
+*netboot-0.10.2 (08 Feb 2010)
+
+ 08 Feb 2010; Jeroen Roovers <jer@gentoo.org> +netboot-0.10.2.ebuild,
+ +files/netboot-0.10.2-ldflags.patch:
+ Version bump, and work around parallel make issue, and respect LDFLAGS
+ (bug #248408).
13 Nov 2008; Thilo Bangert <bangert@gentoo.org> metadata.xml:
remove superflous whitespace from maintainer
diff --git a/sys-boot/netboot/files/netboot-0.10.2-ldflags.patch b/sys-boot/netboot/files/netboot-0.10.2-ldflags.patch
new file mode 100644
index 000000000000..2cb245076d90
--- /dev/null
+++ b/sys-boot/netboot/files/netboot-0.10.2-ldflags.patch
@@ -0,0 +1,38 @@
+--- netboot-0.10.2/make.config.in.org 2007-02-01 13:09:18.000000000 +0100
++++ netboot-0.10.2/make.config.in 2010-02-09 00:34:15.000000000 +0100
+@@ -105,7 +105,7 @@
+ INCLUDE = $(patsubst %,-I%,$(subst :, ,$(VPATH)))
+ CDEFS = @DEFS@ -DNETBOOT
+ CFLAGS = @CFLAGS@ $(CDEBUG) $(CDEFS) $(INCLUDE)
+-LDFLAGS = -s
++LDFLAGS = @LDFLAGS@
+ SYSLIBS = @LIBS@
+ BDBLIB = @BDBLIB@
+ ODBCLIB = @ODBCLIB@
+--- netboot-0.10.2/misc/Makefile.org 2007-02-01 19:42:10.000000000 +0100
++++ netboot-0.10.2/misc/Makefile 2010-02-09 00:39:21.000000000 +0100
+@@ -76,7 +76,7 @@
+
+ gccrules: $(LIBTOOL) gccrules.o $(LIBNBA)
+ @$(LIBTOOL) --mode=link \
+- $(CC) $(CFLAGS) -o gccrules gccrules.o $(LIBS) \
++ $(CC) $(CFLAGS) $(LDFLAGS) -o gccrules gccrules.o $(LIBS) \
+ -no-install
+
+
+@@ -89,13 +89,13 @@
+
+ gccopt: $(LIBTOOL) gccopt.o $(LIBNBA)
+ @$(LIBTOOL) --mode=link \
+- $(CC) $(CFLAGS) -o gccopt gccopt.o $(LIBS) \
++ $(CC) $(CFLAGS) $(LDFLAGS) -o gccopt gccopt.o $(LIBS) \
+ -no-install
+
+
+ nbmd5: $(LIBTOOL) nbmd5.o $(LIBNBA)
+ @$(LIBTOOL) --mode=link \
+- $(CC) $(CFLAGS) -o nbmd5 nbmd5.o $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o nbmd5 nbmd5.o $(LIBS)
+
+
+ instdrv: instdrv.in
diff --git a/sys-boot/netboot/netboot-0.10.2.ebuild b/sys-boot/netboot/netboot-0.10.2.ebuild
new file mode 100644
index 000000000000..fb1a54ea7c36
--- /dev/null
+++ b/sys-boot/netboot/netboot-0.10.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/netboot-0.10.2.ebuild,v 1.1 2010/02/08 23:57:04 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="netbooting utility"
+HOMEPAGE="http://netboot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/lzo-2
+ >=sys-libs/db-4"
+RDEPEND="${DEPEND}
+ !net-misc/mknbi"
+
+src_prepare() {
+ cp -av make.config.in{,.org}
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ find "${S}" -name \*.lo -exec rm {} \;
+}
+
+src_configure() {
+ econf --enable-bootrom --with-gnu-cc86="$(tc-getCC)" \
+ --with-gnu-as86="$(tc-getAS)" --with-gnu-ld86="$(tc-getCC)"|| die 'cannot configure'
+ # --enable-config-file
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README doc/*
+ docinto FlashCard
+ dodoc FlashCard/README FlashCard/*.ps
+ mv "${D}"/usr/share/misc "${D}"/usr/share/${PN}
+ rm -rf "${D}"/usr/lib/netboot/utils
+
+ dodoc "${S}"/mknbi-dos/utils/mntnbi.pl
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}"/mknbi-mgl/misc/mgl.vim
+}