summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-04 09:37:37 +0000
committerJustin Lecher <jlec@gentoo.org>2014-12-04 09:37:37 +0000
commitc9c08f5718867ab8a332004856a260cad43adf3e (patch)
tree538bc34f3c4ef871b80cc6ef0358f79ffc7bf14f /sys-boot/grub
parentsci-geosciences/qlandkartegt: Version Bump, #519950 (diff)
downloadgentoo-2-c9c08f5718867ab8a332004856a260cad43adf3e.tar.gz
gentoo-2-c9c08f5718867ab8a332004856a260cad43adf3e.tar.bz2
gentoo-2-c9c08f5718867ab8a332004856a260cad43adf3e.zip
sys-boot/grub: Fix QA issues with bash-completions, #526138
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog8
-rw-r--r--sys-boot/grub/files/grub-2.02_beta2-bash-completions.patch129
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r4.ebuild340
-rw-r--r--sys-boot/grub/metadata.xml30
4 files changed, 491 insertions, 16 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index d67f77f18b87..1aa77a69b675 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.329 2014/12/03 17:11:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.330 2014/12/04 09:37:37 jlec Exp $
+
+*grub-2.02_beta2-r4 (04 Dec 2014)
+
+ 04 Dec 2014; Justin Lecher <jlec@gentoo.org> +grub-2.02_beta2-r4.ebuild,
+ +files/grub-2.02_beta2-bash-completions.patch, metadata.xml:
+ Fix QA issues with bash-completions, #526138
03 Dec 2014; Mike Gilbert <floppym@gentoo.org> grub-2.02_beta2-r3.ebuild:
Stable on x86, bug 522314. Thanks to Poly-C for testing.
diff --git a/sys-boot/grub/files/grub-2.02_beta2-bash-completions.patch b/sys-boot/grub/files/grub-2.02_beta2-bash-completions.patch
new file mode 100644
index 000000000000..46f65a657799
--- /dev/null
+++ b/sys-boot/grub/files/grub-2.02_beta2-bash-completions.patch
@@ -0,0 +1,129 @@
+ util/bash-completion.d/grub-completion.bash.in | 39 +++++++++-----------------
+ 1 file changed, 13 insertions(+), 26 deletions(-)
+
+diff --git a/util/bash-completion.d/grub-completion.bash.in b/util/bash-completion.d/grub-completion.bash.in
+index 44bf135..d4235e7 100644
+--- a/util/bash-completion.d/grub-completion.bash.in
++++ b/util/bash-completion.d/grub-completion.bash.in
+@@ -166,13 +166,11 @@ _grub_set_entry () {
+ }
+
+ __grub_set_default_program="@grub_set_default@"
+-have ${__grub_set_default_program} && \
+- complete -F _grub_set_entry -o filenames ${__grub_set_default_program}
++complete -F _grub_set_entry -o filenames ${__grub_set_default_program}
+ unset __grub_set_default_program
+
+ __grub_reboot_program="@grub_reboot@"
+-have ${__grub_reboot_program} && \
+- complete -F _grub_set_entry -o filenames ${__grub_reboot_program}
++complete -F _grub_set_entry -o filenames ${__grub_reboot_program}
+ unset __grub_reboot_program
+
+
+@@ -198,8 +196,7 @@ _grub_editenv () {
+ }
+
+ __grub_editenv_program="@grub_editenv@"
+-have ${__grub_editenv_program} && \
+- complete -F _grub_editenv -o filenames ${__grub_editenv_program}
++complete -F _grub_editenv -o filenames ${__grub_editenv_program}
+ unset __grub_editenv_program
+
+
+@@ -219,8 +216,7 @@ _grub_mkconfig () {
+ fi
+ }
+ __grub_mkconfig_program="@grub_mkconfig@"
+-have ${__grub_mkconfig_program} && \
+- complete -F _grub_mkconfig -o filenames ${__grub_mkconfig_program}
++complete -F _grub_mkconfig -o filenames ${__grub_mkconfig_program}
+ unset __grub_mkconfig_program
+
+
+@@ -254,13 +250,11 @@ _grub_setup () {
+ }
+
+ __grub_bios_setup_program="@grub_bios_setup@"
+-have ${__grub_bios_setup_program} && \
+- complete -F _grub_setup -o filenames ${__grub_bios_setup_program}
++complete -F _grub_setup -o filenames ${__grub_bios_setup_program}
+ unset __grub_bios_setup_program
+
+ __grub_sparc64_setup_program="@grub_sparc64_setup@"
+-have ${__grub_sparc64_setup_program} && \
+- complete -F _grub_setup -o filenames ${__grub_sparc64_setup_program}
++complete -F _grub_setup -o filenames ${__grub_sparc64_setup_program}
+ unset __grub_sparc64_setup_program
+
+
+@@ -305,8 +299,7 @@ _grub_install () {
+ fi
+ }
+ __grub_install_program="@grub_install@"
+-have ${__grub_install_program} && \
+- complete -F _grub_install -o filenames ${__grub_install_program}
++complete -F _grub_install -o filenames ${__grub_install_program}
+ unset __grub_install_program
+
+
+@@ -327,8 +320,7 @@ _grub_mkfont () {
+ fi
+ }
+ __grub_mkfont_program="@grub_mkfont@"
+-have ${__grub_mkfont_program} && \
+- complete -F _grub_mkfont -o filenames ${__grub_mkfont_program}
++complete -F _grub_mkfont -o filenames ${__grub_mkfont_program}
+ unset __grub_mkfont_program
+
+
+@@ -358,8 +350,7 @@ _grub_mkrescue () {
+ fi
+ }
+ __grub_mkrescue_program="@grub_mkrescue@"
+-have ${__grub_mkrescue_program} && \
+- complete -F _grub_mkrescue -o filenames ${__grub_mkrescue_program}
++complete -F _grub_mkrescue -o filenames ${__grub_mkrescue_program}
+ unset __grub_mkrescue_program
+
+
+@@ -400,8 +391,7 @@ _grub_mkimage () {
+ fi
+ }
+ __grub_mkimage_program="@grub_mkimage@"
+-have ${__grub_mkimage_program} && \
+- complete -F _grub_mkimage -o filenames ${__grub_mkimage_program}
++complete -F _grub_mkimage -o filenames ${__grub_mkimage_program}
+ unset __grub_mkimage_program
+
+
+@@ -422,8 +412,7 @@ _grub_mkpasswd_pbkdf2 () {
+ fi
+ }
+ __grub_mkpasswd_pbkdf2_program="@grub_mkpasswd_pbkdf2@"
+-have ${__grub_mkpasswd_pbkdf2_program} && \
+- complete -F _grub_mkpasswd_pbkdf2 -o filenames ${__grub_mkpasswd_pbkdf2_program}
++complete -F _grub_mkpasswd_pbkdf2 -o filenames ${__grub_mkpasswd_pbkdf2_program}
+ unset __grub_mkpasswd_pbkdf2_program
+
+
+@@ -460,8 +449,7 @@ _grub_probe () {
+ fi
+ }
+ __grub_probe_program="@grub_probe@"
+-have ${__grub_probe_program} && \
+- complete -F _grub_probe -o filenames ${__grub_probe_program}
++complete -F _grub_probe -o filenames ${__grub_probe_program}
+ unset __grub_probe_program
+
+
+@@ -482,8 +470,7 @@ _grub_script_check () {
+ fi
+ }
+ __grub_script_check_program="@grub_script_check@"
+-have ${__grub_script_check_program} && \
+- complete -F _grub_script_check -o filenames ${__grub_script_check_program}
++complete -F _grub_script_check -o filenames ${__grub_script_check_program}
+
+
+ # Local variables:
diff --git a/sys-boot/grub/grub-2.02_beta2-r4.ebuild b/sys-boot/grub/grub-2.02_beta2-r4.ebuild
new file mode 100644
index 000000000000..865c3e6c1ab3
--- /dev/null
+++ b/sys-boot/grub/grub-2.02_beta2-r4.ebuild
@@ -0,0 +1,340 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r4.ebuild,v 1.1 2014/12/04 09:37:37 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+GRUB_AUTOGEN=1
+
+if [[ -n ${GRUB_AUTOGEN} ]]; then
+ PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+ inherit python-any-r1
+fi
+
+inherit autotools-utils bash-completion-r1 eutils flag-o-matic mount-boot multibuild pax-utils toolchain-funcs versionator
+
+if [[ ${PV} != 9999 ]]; then
+ if [[ ${PV} == *_alpha* || ${PV} == *_beta* || ${PV} == *_rc* ]]; then
+ # The quote style is to work with <=bash-4.2 and >=bash-4.3 #503860
+ MY_P=${P/_/'~'}
+ SRC_URI="mirror://gnu-alpha/${PN}/${MY_P}.tar.xz
+ http://dev.gentoo.org/~floppym/dist/${P}-gentoo.tar.xz"
+ S=${WORKDIR}/${MY_P}
+ else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ http://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
+ S=${WORKDIR}/${P%_*}
+ fi
+ KEYWORDS="~amd64 ~x86"
+ PATCHES=()
+else
+ inherit git-r3
+ EGIT_REPO_URI="git://git.sv.gnu.org/grub.git
+ http://git.savannah.gnu.org/r/grub.git"
+fi
+
+DEJAVU=dejavu-sans-ttf-2.34
+UNIFONT=unifont-7.0.01
+SRC_URI+=" mirror://gnu/unifont/${UNIFONT}/${UNIFONT}.pcf.gz
+ truetype? ( mirror://sourceforge/dejavu/${DEJAVU}.zip )"
+
+DESCRIPTION="GNU GRUB boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+
+# Includes licenses for dejavu and unifont
+LICENSE="GPL-3 truetype? ( BitstreamVera GPL-2-with-font-exception )"
+SLOT="2"
+IUSE="debug device-mapper doc efiemu mount +multislot nls static sdl test truetype libzfs"
+
+GRUB_ALL_PLATFORMS=(
+ # everywhere:
+ emu
+ # mips only:
+ qemu-mips loongson
+ # amd64, x86, ppc, ppc64:
+ ieee1275
+ # amd64, x86:
+ coreboot multiboot efi-32 pc qemu xen
+ # amd64, ia64:
+ efi-64
+)
+IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
+
+# os-prober: Used on runtime to detect other OSes
+# xorriso (dev-libs/libisoburn): Used on runtime for mkrescue
+RDEPEND="
+ app-arch/xz-utils
+ >=sys-libs/ncurses-5.2-r5
+ debug? (
+ sdl? ( media-libs/libsdl )
+ )
+ device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+ libzfs? ( sys-fs/zfs )
+ mount? ( sys-fs/fuse )
+ truetype? ( media-libs/freetype:2= )
+ ppc? ( sys-apps/ibm-powerpc-utils sys-apps/powerpc-utils )
+ ppc64? ( sys-apps/ibm-powerpc-utils sys-apps/powerpc-utils )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ app-misc/pax-utils
+ sys-devel/flex
+ sys-devel/bison
+ sys-apps/help2man
+ sys-apps/texinfo
+ grub_platforms_coreboot? ( media-libs/freetype:2 )
+ grub_platforms_qemu? ( media-libs/freetype:2 )
+ grub_platforms_ieee1275? ( media-libs/freetype:2 )
+ grub_platforms_loongson? ( media-libs/freetype:2 )
+ grub_platforms_xen? ( app-emulation/xen-tools )
+ static? (
+ app-arch/xz-utils[static-libs(+)]
+ truetype? (
+ app-arch/bzip2[static-libs(+)]
+ media-libs/freetype[static-libs(+)]
+ sys-libs/zlib[static-libs(+)]
+ )
+ )
+ test? (
+ dev-libs/libisoburn
+ app-emulation/qemu
+ )
+ truetype? ( app-arch/unzip )
+"
+RDEPEND+="
+ kernel_linux? (
+ grub_platforms_efi-32? ( sys-boot/efibootmgr )
+ grub_platforms_efi-64? ( sys-boot/efibootmgr )
+ )
+ !multislot? ( !sys-boot/grub:0 )
+ nls? ( sys-devel/gettext )
+"
+
+STRIP_MASK="*/grub/*/*.{mod,img}"
+RESTRICT="test"
+
+QA_EXECSTACK="
+ usr/bin/grub*-emu*
+ usr/lib*/grub/*/*.mod
+ usr/lib*/grub/*/*.module
+ usr/lib*/grub/*/kernel.exec
+ usr/lib*/grub/*/kernel.img
+"
+
+QA_WX_LOAD="
+ usr/lib*/grub/*/kernel.exec
+ usr/lib*/grub/*/kernel.img
+ usr/lib*/grub/*/*.image
+"
+
+QA_PRESTRIPPED="
+ usr/lib.*/grub/.*/kernel.img
+"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ # Bug 439082
+ if ! test-flags-CC -fuse-ld=bfd > /dev/null &&
+ $(tc-getLD) --version | grep -q "GNU gold"; then
+ eerror "GRUB does not function correctly when built with the gold linker."
+ eerror "Please select the bfd linker with binutils-config."
+ die "GNU gold detected"
+ fi
+ fi
+}
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ fi
+ default_src_unpack
+}
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" epatch
+
+ [[ ${PATCHES} ]] && epatch "${PATCHES[@]}"
+
+ sed -i -e /autoreconf/d autogen.sh || die
+
+ if use multislot; then
+ # fix texinfo file name, bug 416035
+ sed -i -e 's/^\* GRUB:/* GRUB2:/' -e 's/(grub)/(grub2)/' docs/grub.texi || die
+ fi
+
+ epatch "${FILESDIR}"/${P}-bash-completions.patch
+
+ epatch_user
+
+ if [[ -n ${GRUB_AUTOGEN} ]]; then
+ python_setup
+ bash autogen.sh || die
+ fi
+
+ if [[ -n ${AUTOTOOLS_AUTORECONF} ]]; then
+ autopoint() { return 0; }
+ eautoreconf
+ fi
+}
+
+setup_fonts() {
+ ln -s "${WORKDIR}/${UNIFONT}.pcf" unifont.pcf || die
+ if use truetype; then
+ ln -s "${WORKDIR}/${DEJAVU}/ttf/DejaVuSans.ttf" DejaVuSans.ttf || die
+ fi
+}
+
+grub_configure() {
+ local platform
+
+ case ${MULTIBUILD_VARIANT} in
+ efi-32)
+ platform=efi
+ if [[ ${CTARGET:-${CHOST}} == x86_64* ]]; then
+ local CTARGET=${CTARGET:-i386}
+ fi ;;
+ efi-64)
+ platform=efi
+ if [[ ${CTARGET:-${CHOST}} == i?86* ]]; then
+ local CTARGET=${CTARGET:-x86_64}
+ local TARGET_CFLAGS="-Os -march=x86-64 ${TARGET_CFLAGS}"
+ local TARGET_CPPFLAGS="-march=x86-64 ${TARGET_CPPFLAGS}"
+ export TARGET_CFLAGS TARGET_CPPFLAGS
+ fi ;;
+ guessed) ;;
+ *) platform=${MULTIBUILD_VARIANT} ;;
+ esac
+
+ local myeconfargs=(
+ --disable-werror
+ --program-prefix=
+ --libdir="${EPREFIX}"/usr/lib
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable debug mm-debug)
+ $(use_enable debug grub-emu-usb)
+ $(use_enable device-mapper)
+ $(use_enable mount grub-mount)
+ $(use_enable nls)
+ $(use_enable truetype grub-mkfont)
+ $(use_enable libzfs)
+ $(use sdl && use_enable debug grub-emu-sdl)
+ ${platform:+--with-platform=}${platform}
+
+ # Let configure detect this where supported
+ $(usex efiemu '' '--disable-efiemu')
+ )
+
+ if use multislot; then
+ myeconfargs+=( --program-transform-name="s,grub,grub2," )
+ fi
+
+ mkdir -p "${BUILD_DIR}" || die
+ run_in_build_dir setup_fonts
+
+ autotools-utils_src_configure
+}
+
+src_configure() {
+ # Bug 508758.
+ replace-flags -O3 -O2
+
+ # We don't want to leak flags onto boot code.
+ export HOST_CCASFLAGS=${CCASFLAGS}
+ export HOST_CFLAGS=${CFLAGS}
+ export HOST_CPPFLAGS=${CPPFLAGS}
+ export HOST_LDFLAGS=${LDFLAGS}
+ unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
+
+ use static && HOST_LDFLAGS+=" -static"
+
+ export TARGET_LDFLAGS+=" $(test-flags-CC -fuse-ld=bfd)"
+
+ tc-export CC NM OBJCOPY STRIP
+ export TARGET_CC=${TARGET_CC:-${CC}}
+ tc-export BUILD_CC # Bug 485592
+
+ # Portage will take care of cleaning up GRUB_PLATFORMS
+ MULTIBUILD_VARIANTS=( ${GRUB_PLATFORMS:-guessed} )
+ multibuild_parallel_foreach_variant grub_configure
+}
+
+src_compile() {
+ # Sandbox bug 404013.
+ use libzfs && addpredict /etc/dfs:/dev/zfs
+
+ multibuild_foreach_variant autotools-utils_src_compile
+
+ use doc && multibuild_for_best_variant \
+ autotools-utils_src_compile -C docs html
+}
+
+src_test() {
+ # The qemu dependency is a bit complex.
+ # You will need to adjust QEMU_SOFTMMU_TARGETS to match the cpu/platform.
+ multibuild_foreach_variant autotools-utils_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant autotools-utils_src_install \
+ bashcompletiondir="$(get_bashcompdir)"
+
+ mv "${ED}"/$(get_bashcompdir)/grub{,-install} || die
+
+ bashcomp_alias grub-install \
+ grub2-set-default \
+ grub2-mkrescue \
+ grub2-reboot \
+ grub2-script-check \
+ grub2-editenv \
+ grub2-sparc64-setup \
+ grub2-mkfont \
+ grub2-mkpasswd-pbkdf2 \
+ grub2-mkimage \
+ grub2-bios-setup \
+ grub2-mkconfig \
+ grub2-probe
+
+ use doc && multibuild_for_best_variant run_in_build_dir \
+ emake -C docs DESTDIR="${D}" install-html
+
+ if use multislot; then
+ mv "${ED%/}"/usr/share/info/grub{,2}.info || die
+ fi
+
+ insinto /etc/default
+ newins "${FILESDIR}"/grub.default-3 grub
+}
+
+pkg_postinst() {
+ mount-boot_mount_boot_partition
+
+ if [[ -e "${ROOT%/}/boot/grub2/grub.cfg" ]]; then
+ ewarn "The grub directory has changed from /boot/grub2 to /boot/grub."
+ ewarn "Please run grub2-install and grub2-mkconfig -o /boot/grub/grub.cfg."
+
+ if [[ ! -e "${ROOT%/}/boot/grub/grub.cfg" ]]; then
+ mkdir -p "${ROOT%/}/boot/grub"
+ ln -s ../grub2/grub.cfg "${ROOT%/}/boot/grub/grub.cfg"
+ fi
+ fi
+
+ mount-boot_pkg_postinst
+
+ elog "For information on how to configure GRUB2 please refer to the guide:"
+ elog " http://wiki.gentoo.org/wiki/GRUB2_Quick_Start"
+
+ if has_version 'sys-boot/grub:0'; then
+ elog "A migration guide for GRUB Legacy users is available:"
+ elog " http://www.gentoo.org/doc/en/grub2-migration.xml"
+ fi
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ if ! has_version sys-boot/os-prober; then
+ elog "Install sys-boot/os-prober to enable detection of other operating systems using grub2-mkconfig."
+ fi
+ if ! has_version dev-libs/libisoburn; then
+ elog "Install dev-libs/libisoburn to enable creation of rescue media using grub2-mkrescue."
+ fi
+ fi
+}
diff --git a/sys-boot/grub/metadata.xml b/sys-boot/grub/metadata.xml
index 05e88393345a..438d39abded5 100644
--- a/sys-boot/grub/metadata.xml
+++ b/sys-boot/grub/metadata.xml
@@ -1,30 +1,30 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>base-system</herd>
-<maintainer>
- <email>base-system@gentoo.org</email>
-</maintainer>
-<maintainer restrict="&gt;=sys-boot/grub-2">
- <email>floppym@gentoo.org</email>
- <name>Mike Gilbert</name>
-</maintainer>
-<use>
- <flag name='device-mapper'>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>base-system@gentoo.org</email>
+ </maintainer>
+ <maintainer restrict="&gt;=sys-boot/grub-2">
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+ <use>
+ <flag name="device-mapper">
Enable support for device-mapper from <pkg>sys-fs/lvm2</pkg>
</flag>
- <flag name='efiemu'>
+ <flag name="efiemu">
Build and install the efiemu runtimes
</flag>
- <flag name='mount'>
+ <flag name="mount">
Build and install the grub-mount utility
</flag>
- <flag name='libzfs'>
+ <flag name="libzfs">
Enable support for <pkg>sys-fs/zfs</pkg>
</flag>
- <flag name='multislot'>
+ <flag name="multislot">
Allow concurrent installation of <pkg>sys-boot/grub:0</pkg> and
<pkg>sys-boot/grub:2</pkg> by renaming all programs.
</flag>
-</use>
+ </use>
</pkgmetadata>