summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-09 07:12:47 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-09 07:12:47 +0000
commit630726b4ea3eab83f73022f016a6a2f37f590a2e (patch)
tree395c7b3e74f211b0ad5775bde32ccc3e95d64324 /sys-boot/grub
parentVersion bump for readline-6.3 support #503600 by Guillaume Castagnino. (diff)
downloadgentoo-2-630726b4ea3eab83f73022f016a6a2f37f590a2e.tar.gz
gentoo-2-630726b4ea3eab83f73022f016a6a2f37f590a2e.tar.bz2
gentoo-2-630726b4ea3eab83f73022f016a6a2f37f590a2e.zip
Use single quotes around ~ to get consistent behavior in <=bash-4.2 and >=bash-4.3 versions #503860 by Lars Wendler.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-2.00_p5107-r2.ebuild7
-rw-r--r--sys-boot/grub/grub-2.02_beta2.ebuild5
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild5
4 files changed, 16 insertions, 8 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index fe82d6fc358c..3a183ddfc070 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.307 2014/02/28 18:14:39 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.308 2014/03/09 07:12:47 vapier Exp $
+
+ 09 Mar 2014; Mike Frysinger <vapier@gentoo.org> grub-2.00_p5107-r2.ebuild,
+ grub-2.02_beta2.ebuild, grub-9999-r1.ebuild:
+ Use single quotes around ~ to get consistent behavior in <=bash-4.2 and
+ >=bash-4.3 versions #503860 by Lars Wendler.
28 Feb 2014; Mike Gilbert <floppym@gentoo.org>
-files/1.99-call_proper_grub_probe.patch,
diff --git a/sys-boot/grub/grub-2.00_p5107-r2.ebuild b/sys-boot/grub/grub-2.00_p5107-r2.ebuild
index 3baf92f27651..38a85ab19585 100644
--- a/sys-boot/grub/grub-2.00_p5107-r2.ebuild
+++ b/sys-boot/grub/grub-2.00_p5107-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00_p5107-r2.ebuild,v 1.6 2013/12/09 23:27:48 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00_p5107-r2.ebuild,v 1.7 2014/03/09 07:12:47 vapier Exp $
EAPI=5
@@ -13,7 +13,8 @@ inherit autotools-utils bash-completion-r1 eutils flag-o-matic mount-boot multib
if [[ ${PV} != 9999 ]]; then
if [[ ${PV} == *_alpha* || ${PV} == *_beta* || ${PV} == *_rc* ]]; then
- MY_P=${P/_/~}
+ # The quote style is to work with <=bash-4.2 and >=bash-4.3 #503860
+ MY_P=${P/_/'~'}
SRC_URI="mirror://gnu-alpha/${PN}/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
else
diff --git a/sys-boot/grub/grub-2.02_beta2.ebuild b/sys-boot/grub/grub-2.02_beta2.ebuild
index 6315bb7dc665..d6902a053e73 100644
--- a/sys-boot/grub/grub-2.02_beta2.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2.ebuild,v 1.3 2014/02/13 02:29:59 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2.ebuild,v 1.4 2014/03/09 07:12:47 vapier Exp $
EAPI=5
@@ -18,7 +18,8 @@ inherit autotools-utils bash-completion-r1 eutils flag-o-matic mount-boot multib
if [[ ${PV} != 9999 ]]; then
if [[ ${PV} == *_alpha* || ${PV} == *_beta* || ${PV} == *_rc* ]]; then
- MY_P="${P/_/~}"
+ # The quote style is to work with <=bash-4.2 and >=bash-4.3 #503860
+ MY_P=${P/_/'~'}
SRC_URI="mirror://gnu-alpha/${PN}/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
else
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index 11213c0606f5..8c14c6fb5edc 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.12 2014/02/13 02:29:59 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.13 2014/03/09 07:12:47 vapier Exp $
EAPI=5
@@ -18,7 +18,8 @@ inherit autotools-utils bash-completion-r1 eutils flag-o-matic mount-boot multib
if [[ ${PV} != 9999 ]]; then
if [[ ${PV} == *_alpha* || ${PV} == *_beta* || ${PV} == *_rc* ]]; then
- MY_P="${P/_/~}"
+ # The quote style is to work with <=bash-4.2 and >=bash-4.3 #503860
+ MY_P=${P/_/'~'}
SRC_URI="mirror://gnu-alpha/${PN}/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
else